Become a MacRumors Supporter for $50/year with no ads, ability to filter front page stories, and private forums.


macrumors newbie
Original poster
Apr 17, 2022
Hey folks,

I have a new external SSD (Samsung T7 2TB) connected to my Mac Mini M2, but it's getting automatically unmounted when I plug in an older external hard drive. The SSD is set up for Time Machine with APFS format. As soon as I plug 2nd drive in (Verbatim Store 'n' Go 500GB, formatted as APFS from older Mac) the SSD icon disappears from the desktop and the popup shows saying the drive hasn't been ejected properly. A few seconds later the icon will reappear as the SSD reconnects. The other ext. hard drive icon also displays.

What's also weird is the 2nd hard drive will not display on my desktop unless the SSD is connected. I've tried it in both USB ports but the Mac Mini doesn't seem to pick it up. However, if I plug the SSD in first, then plug in the Verbatim drive, it mounts to desktop... but only after it pushes off the SSD...

I've tried attaching a Toshiba Canvio Alu 1TB hard drive (currently Mac OS Extended until I reformat to APFS) when the SSD is plugged in and no ejection or mounting issues. Does that sound like the older Verbatim hard drive is a bit dodgy?
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.