External Hard drive shows in Disk Utility, but not in Finder

Discussion in 'Mac Basics and Help' started by OldCorpse, Mar 24, 2011.

  1. OldCorpse macrumors 65816


    Dec 7, 2005
    compost heap
    Here's the hardware:

    Late 2009 iMac 27" i7 2.8GHz 8GB RAM 1TB HDD Seagate running OS X 10.6.7

    Problem external drive: Western Digital My Book Studio II - 4 TB (2 x 2 TB) USB 2.0/FireWire 800/400/eSATA Desktop External Hard Drive.

    The WD drive is configured in RAID1, and about 40% full (i.e, there's about 900GB on it). It is connected to the iMac through USB.

    I have a number of drives plugged into the iMac including a few more WD My Book drives. I don't shut the iMac overnight.

    This morning, I saw one of the external drives (the 4 TB) was not showing on the desktop. I can't get it to show. Here's what I did:

    1)I repaired permissions a few times
    2)rebooted a few times
    3)I disconnected the USB cable on both the WD and on the iMac, and reconnected several times.
    4)I tried all the USB ports on the iMac. So it is NOT a bad port/ports.
    5)I tried a different new USB cable. So it is NOT a bad USB cable.
    6)I disconnected the USB cable completely, and connected the WD to the iMac through a FW cable and the FireWire800 port. So it is not a problem with the USB interface on either the WD drive or the iMac.
    7)connected the WD drive to my iBook running 10.4.11 - same result. So it's probably NOT a problem with the iMac.

    Throughout all this, all the other drives show up, but not this one.

    There appears nothing wrong with it, externally, i.e. the drives spin up, and the LED lights show activity when I plug the USB cable to the iMac and pull it out again.

    Here's what it looks like: I can see it in Disc Utility, though it doesn't show the name I gave it, instead it has a generic 2TB WD My Book Media and disk5s2 name under it.

    When I select "info" it shows as USB connection bus etc.

    I also have the WD Drive Manager installed. The drive appears there as well, but shows as Used Space 0% which is wrong (actually it's some 45%). Temperature: OK and RAID Status: Healthy. I launch the manager, and it shows the following info:

    "RAID Setting: RAID 1
    RAID Status: Healthy

    Disk A Status: Good
    Disk B Status: Good"

    It is exactly the same situation and the same readings when I hook it up to my iBook.

    So: Why is it not showing on the desktop (Finder), and why is it showing as 0% used in WD Drive Manager?

    And: How do I get this to work? I have some very important data on it - that's why I had it in RAID1. Is the enclosure toast? Is it the RAID controller? What next? Can I just extract one drive, put it in a different enclosure and get the data off it? What do I do? Thanks!
  2. ThirteenXIII macrumors 6502a

    Mar 8, 2008
    usually when I see disk5s2 in my drives, either something with the enclosure is bad or the drive went offline without being properly ejected.

    Have you tried clicking on the drive in Disk Utility and did a verify disk or Unmount then remount in Disk Utility, sometimes that has helped my drives come back online
  3. OldCorpse thread starter macrumors 65816


    Dec 7, 2005
    compost heap
    Wow, ThirteenXIII you are a lifesaver! OK, so I couldn't mount and unmount the drive because that option was greyed out in the Disk Utility, but I did click on Verify. It showed that the header was damaged and it needed repair. I hit Repair - though with great fear, as I was afraid it would not work well with a RAID1 type situation. But. It did repair, then the drive briefly appeared on the desktop, greyed out, then it disappeared. I tried ejecting the drive through Disk Utility, but it didn't react, so I just pulled the cable and plugged it back in. Suddenly it appeared on the desktop! I briefly opened it to see if my files were there, and yes they were!

    But I'm very worried that the whole thing is on the blink. So, I hooked up another enclosure with some Hitachi drives (2TB + 2TB) in RAID1 and I fired up SuperDuper! and am in the process of copying the whole drive from the WD to the new Hitachi drives. This will take many hours, and I hope will not fail! Then I intend to put aside the WD as I don't trust it anymore. We'll see - right now it is copying.

    Thank you again, this has been a nightmare, and I was losing hope, but you rescued my data: THANK YOU!!!
  4. The-Pro macrumors 65816

    Dec 2, 2010
  5. ThirteenXIII macrumors 6502a

    Mar 8, 2008
    Not a problem, you're welcome. I'm glad that allowed the drive to show up long enough to go through your data.
    Definitely get it off those drives and that enclosure - definitely sounds like something is problematic with the enclosure.

    So far all the data is transferring just fine? no corruption i take it?
  6. OldCorpse thread starter macrumors 65816


    Dec 7, 2005
    compost heap
    Yeah, I feel superlucky... basically it was all my music, close to a 1 TB's worth, accumulated over the years, a lot of it irreplaceable. The RAIDed drive was for security and my media server. Shows you, can't even trust RAID1. What the heck is one supposed to do? Make ten copies on ten drives? It's not even practical, for the simple reason that I keep adding more music (and sometimes erasing some), so I gotta be able to do it on a continuous basis, which wirks well on a mirrored drive, but wouldn't be practical to keep copying and syncing onto more external drives.

    It is copying right now (so far 115GB in 80 minutes), but there's still almost ten times as much left, so it's too early to say if any of it is corrupt. I'm just hoping the copying operation doesn't fail. I'll come back here and report on the result, sometime tomorrow.

    Thanks again!
  7. OldCorpse thread starter macrumors 65816


    Dec 7, 2005
    compost heap
    Drives copied, everything A OK!

    All right, SuperDuper! worked a treat, and the copying operation was successful. No files were lost or corrupted that I can see.

    I had a bit of a struggle with pointing iTunes to the new drive (also RAID1), it wouldn't take, kept reverting to old location. Then a ton of files showed as missing, but I kept running consolidation and finally it all settled, and now it seems like I got all my files. I guess iTunes is weird.

    So, I'm retiring the WD, don't want to take a chance on it anymore. Now I have a new enclosure with Hitachi Drives, 2TB + 2TB in RAID1 formation. It's my new music storage/server.

    But this showed me that even RAID1 is not bulletproof. So I'm trying to think of a new solution to back up my files - I have to find something that does it automatically and incrementally in the background, onto completely new drives - and this has to be an automated process, because I'm always adding and subtracting music, so this has to be able to keep up. I thought RAID1 was the perfect solution, but this shows that it's not, because the RAID controller itself can fail, and then you can't even mount the drives. Hmm. Anyhow, this scare motivates me to start looking for another hardware/software solution.

    Thanks again for the help, ThirteenXIII!
  8. AppleNewton macrumors 68000


    Apr 3, 2007
    1 Finite Place
    Have you had experience with Carbon Copy Cloner?
    You can do scheduled incremental backups which might help with your situation of always changing your files.
  9. OldCorpse thread starter macrumors 65816


    Dec 7, 2005
    compost heap
    I know of CCC, but last I looked at it was like 5 years ago. I have not used it since. The trouble is, I need a very good copying program that can preserve the metadata and acls and the like - and I saw a comparison of various apps which showed SuperDuper! to be better at that than CCC, but again, that was a few years ago, so maybe CCC caught up. Anyhow, yeah, I'll look into it again, thanks for the reminder.

    What I'm really looking is for something to automatically maybe do backups once a day or so, without my having to baby it. Something that I can set once and forget. I know that windows has a brilliant little program that does that (yikes, windows often has more and better app choices) and sends you an email about what it does every time - it's called Cobian.
  10. thaiman, Sep 6, 2011
    Last edited: Sep 6, 2011

    thaiman macrumors newbie

    Mar 1, 2011
    Similar Problem with Solution

    On my unibody MacBook Pro running Lion OSX, I had my terradrive with my time machine backups disappear from my finder. When I went to the disk utility it showed up, but I tried to repair it and it said that it couldn't. I almost panicked and was ready to run around to the repair shop, but I noticed my finder doing other odd things. :confused:

    So I ran the verify microscope icon on my utilities for my internal drive. Sure enough there was a problem... 'wrong number of hard links'... then I was prompted to startup and run the disk utility from my startup disk.

    I recently bought Lion OSX from the App store and thought, oh crap, I don't have a startup disk. Fortunately research revealed that Lion OSX partitions the startup disk on to part of my harddrive. In order to boot from the startup disk and run the disk utility, you need to restart while holding down 'command R'.

    I ran the repair disk and 10 minutes later, then after the success message, I ran a repair on the external hard drive just to be safe. The harddrive had no problems. I restarted and viola, all the problems were solved!

    Thank god I didn't panick and go running on a wild goose chase to find a repairman I could trust, since I live hundreds of miles away from the nearest Apple Store.:)
  11. rumirocks macrumors newbie

    Dec 11, 2011
    You have one thing left to do: buy DiskWarrior from Alsoft.com and keep it in a vault so you can find it when you need it. The $99 is worth every penny X 100. Read the reviews. It works when Disk Utility doesn't, or when you can't even turn your machine on to get to Disk Utility. Be sure to get the right version for your machine.
  12. tixrus macrumors newbie

    Nov 2, 2011
    Please help me, similar problem

    My reliable 1TB LaCie w/ all Time Machines from two computers failed to mount a few days after I bought Lion. It has always been taken care of, almost always dismounted before unplug and/or power off, and always use the proper power adapter. I bought it in 2009. It was used in Australia (it is a USA model) with appropriate adapter for several months.

    It wouldn't mount on the older comp either. It shows up in the disk utilities on both. I have it hooked up to the older comp (can't take Lion, so it is on Snow Leopard) and I am running a repair on the Terabyte main drive as we speak. The UI for that is dreadful. Right away it said:

    Volume Repair Complete
    Updating boot support partitions for the volume as required.

    Now it just shows a stripey thing, with no indication of progress. How long should that take? It has been going for 20 minutes. If it fails will it tell me or will it just loop forever? The drive is making little drive noises but it doesn't sound like it's beating itself up. What if I click STOP REPAIR. I am afraid to.

    I'm told the LaCies occasionally have bad power supplies. The existing one SEEMS fine, physically the drive is OK looking & the blue light is on, how would you know if it is bad.
  13. Doug482 macrumors newbie

    Feb 2, 2012
    Cape Town, South Africa
    External drive won't mount

    Hi People,
    I'm hoping that someone can tell me how to get my external La Cie drive to mount. I've tried using Disk Utility to repair the disk but I get the following message "Repairing volume failed: Unrecognized file system".
    It happened after I closed the lid of my laptop on the drive without ejecting it first :(
    I'd really like to not loose the 500GB of data I have on this external drive. I don't want to spend $99 on DiskWarrior for this 1 problem. Does anybody have any other advice for me?
    Kind regards
  14. mspt2012 macrumors newbie

    Sep 17, 2012
    here is a script ... open up script editor and paste this in

    tell application "System Events" to set visible of disk "Name of Hard Drive" to true
    tell application "Finder" to quit
    delay 1
    tell application "Finder" to launch
    delay 1
    tell application "System Events" to quit

    then change "Name of Hard Drive" to the name of whatever hard drive you want and click run and it will pop up on your desktop!!!
    Reply With Quote
  15. CASLondon macrumors 6502a

    Apr 18, 2011

    Can I ask you a question?

    I have two external drives, one seagate one Hitachi, pulled from Lacie Porsche enclosures that woundn't power up anymore. When I stick the disks in a dock, they spin up, but I can't see them in Disk Utility or Finder (but System Profiler sees a mass storage device on that bus)

    Is this something that sounds like DiskWarrior might help see the drives? They had been working perfectly when the enclosures were working ok, and they are spinning ok. Just not visible at all.
  16. TomCat macrumors member

    Jul 12, 2000
    A better idea might be to invest the $100, wait until you have a problem, and then buy it. That way it WILL be the right version, even if you have changed computers or upgraded the OS. At least for a while; no need to start the expiration clock until you need the utility.

    And that is the problem with DW, TechTool, and all of the other utilities, is that it costs money to upgrade them. You end up rebuying them every year just to keep up with the OS. It seems to make sense to avoid that as long as possible by not buying them until you need them.

    DW is pretty great, BTW.
  17. LaCieTech macrumors member

    Jul 18, 2012

    This issue sounds very typical of volume corruption which is a fairly common occurrence after updating the OS, especially if the disk was connected while you updated. I don't know why exactly, its just a trend we tend to see a lot around here.

    The easiest way to restore the disk will be to format it. If data is a concern, you can try an application like DiskWarrior or Data Rescue 3. DiskWarrior is more likely to work if in DU you can see the old volume name (like Backup or LaCie) but it won't work if DU shows a volume like "disk2V4" or something along those lines.

    If the later is the case, I recommend either Data Recovery or formatting the disk and restoring from a backup. If you need more help, we can be reached at www.lacie.com/mystuff. ~mn, LaCie



    I don't think DiskWarrior has much chance in this situation. That application repairs corruption on volumes but won't work if the disks are not detected at all. It sounds like whatever caused the enclosure to stop also fried the disks. A power surge or physical damage can do that to a hard drive. If you would like us to help investigate further via troubleshooting, give us a ring at 503.844.4500 (USA) or www.lacie.com/mystuff

    ~mn, LaCie
  18. Roxxy macrumors newbie

    Nov 5, 2012
    External HD not shown in Finder

    After trying to empty Trash, I stopped the process (after 24 hrs! and over 900,000 items to go). The external WD 1 TB hard drive isn't showing in Finder. It appears under system profiler and disk utility. Unfortunately the options under DU are gray, including the verify button. This HDD contains all of my pictures, documents & music that I can't replace. Help please :confused:
  19. texasmccoy macrumors member


    Sep 24, 2010
    Montgomery County, Texas
    Hi All,
    Most of the info in this thread is above my head, as I am nowhere near being a guru. But I just wanted to drop a note in here that I experienced a similar problem earlier this year where my internal hard drive would randomly not show up in Finder. I'd try some of the tweaks suggested above, sometimes it worked and sometimes it didn't. This continued on for a number of months until finally my hard drive decided to kiss this world good bye and die on me, taking not all but quite a big handful of data with it that I had not backed up with Time Machine for awhile. For anyone who has had this happen, you know what a traumatic experience this can be. I tried to have a data recovery service get my stuff of my failed drive and they were unable to because of magnetic damage. So I guess the point of me sharing this sob story is that I'd suggest to anyone that is having any issues with a randomly disappearing drive, whether it be external or internal, you would be wise to backup your data in another location if you have even the slightest notion that something is amiss with your drive. Trust me, hard drive failure is NO FUN :(
  20. mcbeani macrumors newbie

    Jan 31, 2013
    External Hard drive shows in Disk Utility, but not in Finder

    Before I start, I know that this question has technically been solved before, but not exactly in my case. Keep in mind that I'm a graphic designer, this is why I am so passionate about fixing this issue. So, here's the story. Yesterday, I sold my Mac mini (Late 2009). I had plans of buying the new MacBook Pro w/ Retina Display (15 inch), and that worked out perfectly. I bought the MacBook and sold my Mac mini. Prior to selling the Mac mini, I decided to format an old hard drive that I had, which was a 160GB hard drive. My plan was to sell the computer with the 160GB HDD, and keep my 750GB HDD. I know my fair share of computing and repair, so I replaced the hard drive myself, and reinstalled Mac OS X ML on the 160GB HDD. I installed the OS via external SATA to USB connection, and it booted up perfectly through that connection to my Mac mini. Then, when I took out the 160GB HDD, my computer booted to my priority internal drive, which was the 750 GB HDD, that I'm having problems with currently. It booted up perfectly, and all of my information was on it. So, at that point, seeing that everything was flawless, I extracted the 750GB HDD, from inside the computer and replaced it with the 160GB HDD, which I formatted, reinstalled ML on, and was planning on selling it with. The 160GB HDD booted perfectly and everything was working on the Mac mini, but then, I plugged in my 750GB HDD via USB connection, to see if my files and everything was still there, I got a message saying, "The disk you inserted is not readable by this computer" and it gave me three options underneath, which were: "Initialize...", "Ignore" and "Eject". I pressed on initialize, and tried to do everything that I possibly could, without formatting it, and all of the options like "Verify Disk" and "Repair Disk" were "grayed out", if you know what I mean. I tried plugging it into all 5 USB ports, but I got the same message. It was recognized in Disk Utility, but not in Finder. So, I sold the computer with the 160GB HDD that was working fine, but now I had another dilemma which was why my 750GB HDD, isn't showing up in Finder. I can hear the HDD spinning when I plug it in via USB. This Hard Drive has run Mac OS X Lion and Mountain Lion on it, I've never installed Windows on it. So, it was properly formatted for a Mac. Now, I went out and bought the MacBook Pro with Retina Display that I needed, and I tried doing the same thing, which was plugging it in via USB, and seeing if Finder would pick it up. Still, nothing. I ended up with the same message.

    I've called Western Digital, and they told me to try booting up the 750GB HDD, in an older Macbook Pro, to see if it will boot, and recovery all of the files from there. The problem is, I don't know anybody with an older MBP. I called Best Buy and they said that they could take a look at it, but I would truly prefer by fixing this on my own, without having to pay them. That would be my LAST resort. I'm aware that I can't boot up the 750GB HDD in my new MBP w/ Retina because it can only carry SSD. So, I'm basically puzzled. If anybody could help me out, it'd be greatly appreciated. Like I said before, I'm a graphic designer, and I'm in desperate need of the files that were on my 750GB HDD. Thanks.
  21. Andy Arms macrumors newbie

    Jun 4, 2015

    I ran into same issue. To gain access to drive, open disk utility and right-click on drive and select either "reveal drive in finder", or if that doesn't work, select "open drive", you can then select "get info" to check ownership, etc., try some of the other suggestions given here to get your drive to mount and show up in Finder. But in the meantime, you will have access to your Time Machine files.
  22. nerocaesar macrumors newbie

    Jul 9, 2015
    Hello All, I've through many forums and this is the best one I found to describe my problem:
    Only shows in Disk utility
    Hard drives spins fine
    I have verified and repaired many times
    I have ejected many times
    I have reset the computer many time
    I have unplugged it and let it sit for days
    I have changed the ports I use
    The mount option is greyed out
    Lacie Stripped Raid is "Offline"
    Lacie Raid Slice is "Missing"
    The repair and verify say "no errors" and "OK"

    Any idea as to what is going on?
    its a 4TB (2tb+2tb) HD using the thunderbolt port

    Thanks for your time
  23. AppleNewton macrumors 68000


    Apr 3, 2007
    1 Finite Place
    is the hard drive partition greyed out too? or is it solid?

    Volume Name
    Partition Name

    Could be the external enclosure, something with the chipset or power supply.
    If you boot into the recovery partition does it allow you to mount in DU there?
  24. nerocaesar macrumors newbie

    Jul 9, 2015
    The partition does seem to be greyed out as well. I'm not quite sure how to boot into the recovery partition... Screenshot.jpg
  25. cowfish macrumors member

    Jul 23, 2009
    I would suspect the enclosure. Something having to do with the raid controller.

Share This Page