iPhone X Face ID fixed?

rcp27

macrumors regular
Original poster
May 12, 2010
202
1
a bit of background: I got an iPhone X in December last year, and it had a bug where after an interval of between perhaps a couple of hours up to a day or two, Face ID would stop working. Turning the phone off and on again would make it work again until at random it would stop. I had figured that as a reboot made it work it was a software rather than hardware problem that at some point would get fixed. I stuck with it right through until iOS 12 came along and still no fix. I got annoyed and started searching, and found people suggesting it might be a hardware problem after all, so I was trying to find a gap in my schedule to make an appointment at my nearest Apple store. A little over a week ago overnight my phone did its thing and quietly updated to 12.1. Since then then Face ID has worked flawlessly for me. It’s now long enough that I’m beginning to think this might be the software fix I had finally given up hope of ever getting. Am I just having a lucky spell and the old problem will return, or is this a genuine fix? Does anyone else have any related experience?
 

AppleHaterLover

macrumors 68000
Jun 15, 2018
1,898
1,903
It may not be a “you” problem, but only you will be able to know if it’s fixed or not.

I am not aware of any iOS update specifically to fix Face ID timeout issues.
 

J0ker

macrumors member
Oct 21, 2011
38
18
This thread on the apple support forums describes exactly the issue I’ve been having, so while it’s clearly not an “everyone” issue, it’s more than just a “me” issue

https://discussions.apple.com/thread/8169232
Interesting, not doubting it's happening to you, but I've actually never heard of this until now. I've owned the X since release and it's always worked great. Hope the update has fixed this issue for you, permanently.
 

ATC

macrumors 65816
Apr 25, 2008
1,076
278
Canada
In the last couple of weeks I’ve had maybe two instances where it asked to enter passcode to enable faceID. Both instance my phone was on a wireless charging stand on a bedside table, with the phone facing my general direction while in bed.

I don’t know if it’s the same exact issue as the OP but I chalked it up to the phone perhaps seeing my face at a weird angle and after a few attempts to unlock it reverted to the passcode to re-enable. It hasn’t happened enough for me to know for sure what triggered it.