Failed 2.2 2G unlock fail, Restore error 1600

Discussion in 'Jailbreaks and iOS Hacks' started by funktown4, Jan 16, 2009.

  1. funktown4 macrumors newbie

    Joined:
    Jan 16, 2009
    #1
    So here's the deal:

    I had a very nicely unlocked 2G iPhone with firmware 2.2 that had a hardware issue. I took it to the Apple Store and they very nicely told me that since the issue was not software related that they would replace my phone, Yay AppleCare!

    So I took this shiny new phone home and tried to unlock it by putting it into recovery mode and option restoring via itunes with my custom restore image. To my dismay I got restore error -21, or something like that.

    So I tried DFU mode. Same result, different restore error, 1600.

    I tried my old 2.1 unlocked firmware. Restore error 1600.

    I tried a vanilla restore in itunes to 2.1. No dice.

    As per a recommendation in: http://forums.macrumors.com/showthread.php?t=560227

    I tried to do a Quickpwn of my phone. Restore error 1600.

    I've tried silly this like nuking device support library files after getting my phone recognized in recovery mode in itunes. And even terminating my network connection before doing an option restore.

    I'm at a loss here.

    Could there be something with the fact that this phone was never activated, because it was a service replacement, have something to do with my issues?

    I'm also not sure what firmware the service replacement came with.

    If anyone has any insight, it would be much appreciated. (Starting to pull my hair out here)

    Thanks (opt + Sht + K)
     
  2. jav6454 macrumors P6

    jav6454

    Joined:
    Nov 14, 2007
    Location:
    1 Geostationary Tower Plaza
    #2
    Errors with 1600 or their derivatives mean USB related errors. Try reseting your Mac/PC and changing USB ports. Then retry.

    Post if no avail...
     
  3. ilfn143 macrumors 6502

    Joined:
    Aug 27, 2008
    Location:
    Enron by the Sea
    #3
    if you use windows xp, create a new user with admin privilege. restart your computer login as new user, open itunes and go from there. if that doesn't work try different usb port or different computer.
     
  4. funktown4 thread starter macrumors newbie

    Joined:
    Jan 16, 2009
    #4
    No Dice

    I'm using a Mac, a known good OS, and known good port. It's not a user issue either. Tried a different user just in case. I do get a error -21 when I try restoring from recovery mode instead of DFU. Any ideas?

    Thanks ( Opt + Sht+ K )
     
  5. moniquetx macrumors member

    Joined:
    Sep 25, 2008
    Location:
    Dallas, TX
    #5
    I had the exact same issue after I got my iPhone replaced. I was getting the same errors. After about ten attempts (changing computers, changing USB ports) I found out that it was the USB cable.

    I know it sounds weird but it's true. I had problems restoring a few years back with an iPod Mini and that's what alerted me to change the cable.

    First, do a clean restore with iTunes (keep on trying until it works) and then try to unlock. Then set up your iPhone as a new phone.

    Hope it helps.
     

Share This Page