OS X Failure to launch ETS2 from Steam, El Cap 10.11.6

Discussion in 'Mac and PC Games' started by Tazling, Mar 25, 2018.

  1. Tazling macrumors newbie

    Joined:
    Jul 7, 2016
    #1
    Hey all; got a weird one. Since Mar 21 when a new version of Steam client rolled out, I have not been able to launch my copy of Euro Truck Simulator 2. This is a sim I have heavily invested in (both in DLCs and in playing hours -- more than 450 hours over the last 2+ years!) so it's pretty frustrating to have it suddenly and mysteriously broken. I'm really jonesing for my ETS2 fix after several days of not being able even to start the game.

    The failure to launch comes in two basic flavours: 1) Steam hangs and has to be Force Quit (I have left it for multiple minutes and nothing ever happens); 2) the game starts to launch, but never paints anything on screen, then quickly crashes taking Steam with it.

    I should perhaps mention that I've had intermittent trouble launching ETS2 over the last few months -- sometimes had to try 2 or 3 times before getting a successful launch -- but this complete failure is new. It coincided with a Steam update, which made me pretty suspicious.

    I've been in touch with Steam Support and of course, they ask "is your OSX up to date?" well, of course not :) I've been staying with stable, reliable El Cap for as long as I could while Apple messed about with various Sierra features. Reading about the amount of stuff that can break when you go to HS, I have been stubborn about not upgrading. But am now wondering if I'm forced to do it. While I wait for 10.13.4 (allegedly a bit more stable than the last couple of HS) I wondered if anyone has a clue they'd be willing to share.

    Has anyone else had trouble trying to launch ETS2 from Steam client with El Cap 10.11.6? Did you upgrade to Sierra or HS? Did it fix the problem? Anyone else had intermittent (then not so intermittent) failures to launch?

    BTW, yes I have tried it with all user mods removed; I have tried it with all my profiles removed; I have "checked integrity of game files" after a reboot; I have run diagnostics on my system memory. The only thing I have not yet done is to uninstall and reinstall the game from scratch (ouch, lotta download bandwidth burned up!).

    System: Hackintosh, Intel i7-6700K, 32GB RAM, Asus Strix GTX970, NVIDIA web driver

    Everything worked fine until March 21; been driving ETS2 at highest video settings, game absolutely stable. Oh yeah and other Steam games are launching OK, including ATS! During the hang, Steam gets about 21% of the CPU, does no disk i/o, uses almost no memory. WTH is it doing...?
     
  2. Tazling thread starter macrumors newbie

    Joined:
    Jul 7, 2016
    #2
    WOO HOO I fixed it!!

    Did not need to upgrade to HS. The trick is to destroy Steam client utterly and reinstall from scratch.

    Here's the drill:

    1) find your Library/Application\ Support/Steam folder. Should be in the Library hierarchy in your home dir.
    2) copy the folder "steamapps" from that Steam folder to a safe place -- you don't want to lose it, or you'll be DL'ing all your content all over again.
    3) nuke the Steam folder (yes, just grit your teeth and do it)
    4) re-download Steam from scratch, Replace any existing exe, let it go through all its upgrades, re-authenticate (yaaawn).
    5) shut'er down again and put the content of that steamapps folder you saved, into the new steamapps folder created when Steam started up for the first time.
    6) restart Steam client (all your games should be back in your library)...
    7) try launching whatever was giving you grief before...

    This almost totally fixed the problem for me. There is one small wrinkle left, which is that I don't seem to be able to start the game more than once from the same Steam client session; I have to Quit Steam and restart it before starting the game. I can live with that.
     

Share This Page