Become a MacRumors Supporter for $25/year with no ads, private forums, and more!

Fantastical 2 and Spaces/Mission Control

RainCityMacFan

macrumors 6502a
Original poster
Jun 10, 2007
922
3
NC
Does anyone with Fantastical 2 have the issue where if you click on the icon at the menu bar from a different space, it switches you to the Desktop space?

This never happened with v1 and the fact that this happens with v2 renders it pretty annoying to use :(

Is this a feature or is there an option to fix this some how?
 

Naio

macrumors member
Apr 2, 2015
75
11
Does anyone with Fantastical 2 have the issue where if you click on the icon at the menu bar from a different space, it switches you to the Desktop space?

This never happened with v1 and the fact that this happens with v2 renders it pretty annoying to use :(

Is this a feature or is there an option to fix this some how?

I have no idea if this is going to work or not, but I think it's worth a shot:

Uncheck "When switching to an application, switch to a Space with open windows for the application" in Mission Control in System Preferences.

If that option if already unchecked; I have no idea, sorry.
 

RainCityMacFan

macrumors 6502a
Original poster
Jun 10, 2007
922
3
NC
I ended up getting a reply from Flexibits.

Just got to go into preferences --> Appearances, and check Hide in Dock!
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.