Finder window won't open

Discussion in 'Mac Apps and Mac App Store' started by HipHopTrex, Mar 8, 2015.

  1. HipHopTrex macrumors member

    Joined:
    Mar 9, 2012
    #1
    I've been trying to open a finder window the usual way, clicking the icon on the dock, but it won't work anymore. No window appears. I can open one my clicking on the icon and then command+N but that's it.

    Things I've tried so far: deleting the plist, restarting my macbook, force quitting the finder. All to no avail.

    I'm on Yosemite 10.10.3. mid2013 MBA.
     
  2. Ulenspiegel, Mar 8, 2015
    Last edited: Mar 8, 2015

    Ulenspiegel macrumors 68020

    Ulenspiegel

    Joined:
    Nov 8, 2014
    Location:
    Land of Flanders and Elsewhere
    #2
    To be honest with you I have no idea what might cause this problem. Nevertheless I would try the following:

    1. Delete the Finder plist and the Dock plist.
    2. In Terminal: Killall Finder and then Killall Dock.
    3. Start Finder.

    Second what I would try is to install a Finder plug-in like TotalFinder (there is a trial version, good for this purpose) to check what kind of effect will it have on starting Finder.

    No more ideas. Good luck, m8.
     
  3. Gregg2 macrumors 603

    Joined:
    May 22, 2008
    Location:
    Milwaukee, WI
    #4
    Your usual way is different from mine. I find that opening a finder window from the right side of the Dock, through the Documents stack, is rather cumbersome, especially if I need to "drill down" into my folder structure. I prefer to open my Mac Mini HD window from the Desktop, then use the Sidebar to get where I need to go.

    You say that you tried deleting "the plist". Which one? My guess, from the context of your post, is the Finder's plist. I would have tried the Dock's plist for sure, but the linked thread says someone solved the same problem by deleting the Finder's plist!

    I suggest that you try going to another account and see if the problem also occurs there. Create a troubleshooting account if you only have one User account now.
     
  4. HipHopTrex thread starter macrumors member

    Joined:
    Mar 9, 2012
    #5
    Tried both the plist things you recommended, and Killall Finder and Dock, neither worked.

    Before proceeding though, basically you just want me to download TotalFinder and see if that can force Finder to open, or is there something else?

    Thanks for the help!
    Thanks for the link! Alas, nothing in there helped me.
     
  5. fretdevil macrumors member

    Joined:
    Jun 15, 2010
    Location:
    San Diego
    #6
    Finder (10.10.3)

    I had the same problem. Logic X (10.10.1 update) was the culprit.

    If you want to run BETA software, be ready for the consequences. This is one of them.

    I restored 10.10.3 multiple times and left the Logic X Update unresolved. The dock icon for finder worked as expected. After applying the Logic X update the behavior resumed and I could not open Finder via a single click on the dock icon. (Other options for opening a Finder window work as expected)

    *** The same behavior may be caused by other apps. I am just relaying my experience ***
     
  6. Ulenspiegel macrumors 68020

    Ulenspiegel

    Joined:
    Nov 8, 2014
    Location:
    Land of Flanders and Elsewhere
    #7
    I am sorry to hear that. And yes, I would try the plug-in to see whether it can force Finder to open.
    Though fretdevil has a very good point. What apps have you installed lately on your Mac?
     
  7. HipHopTrex thread starter macrumors member

    Joined:
    Mar 9, 2012
    #8
    Normally I wouldn't run beta software, but I needed it for a freaking class. :( Thanks for relaying the information though. At least I'm glad (no offense to your problem) that it at least seems to be spread across apple programs.
    Okay I tried it. It works...somewhat. Seems like it works half the time, which is better so thanks for the help!

    duetdisplay, a reinstall of chrome which is my backup browser, and the photos beta, which I had to have for a class. Causing me problems than it's worth! Thanks again for the assistance I greatly appreciate it!
     

Share This Page