FIXED: Emoji Predictions not working

Discussion in 'iOS 10' started by richardc1983, Sep 14, 2016.

  1. richardc1983 macrumors regular

    Joined:
    Nov 13, 2010
    Location:
    Leeds, UK
    #1
    Cannot get these to work at all, have tried turning on/off predictive, deleting the keyboards, dictionary's, restarting the device everything but predictions will still not work.

    http://www.macrumors.com/how-to/ios-10-messages-emoji/

    I can however at the end of my message press the emoji button and it will then offer me alternatives but I want it to do this as I am going along.

    Any advice?
     
  2. headOfFamilyItSupport macrumors newbie

    Joined:
    May 19, 2016
    #2
    --- Post Merged, Sep 14, 2016 ---
    I think I can help. I struggled to get this to work at first. When you have finished your message, press and hold the icon of the globe/smiley face and select the Emoji keyboard. Select the orange words to replace them with the recommended emoji icon. hope this works for you.
     
  3. _Refurbished_ macrumors 68000

    _Refurbished_

    Joined:
    Mar 23, 2007
    #3
    Don't think it's designed the way you want it to be. I have to do the same thing
     
  4. headOfFamilyItSupport macrumors newbie

    Joined:
    May 19, 2016
    #4
    If I type " Love cats and dogs" then I get Emoji suggestions as I type just like predictive text. All except "and"
     
  5. richardc1983 thread starter macrumors regular

    Joined:
    Nov 13, 2010
    Location:
    Leeds, UK
    #5
    Well I am not getting that!
    --- Post Merged, Sep 14, 2016 ---
    This is the way I am currently doing it, but Emoji's should be offered as predictive the same way words are, you shouldn't have to do it at the end.
    --- Post Merged, Sep 14, 2016 ---
    Read the link in my post, and even apples own website demonstrates that it should work the way "I want it to be". Lots of posts all over that they are not working.
     
  6. headOfFamilyItSupport macrumors newbie

    Joined:
    May 19, 2016
    #6
    I have three keyboards enabled. English, English (Australian) and Emoji. All auto buttons are switched on.
     
  7. richardc1983 thread starter macrumors regular

    Joined:
    Nov 13, 2010
    Location:
    Leeds, UK
    #7
    I've fixed it: The fix is to basically switch to the emoji keyboard and send loads of emoji's to yourself in a few messages. Then it starts working!!!
     
  8. headOfFamilyItSupport macrumors newbie

    Joined:
    May 19, 2016
  9. J_Thomas macrumors newbie

    J_Thomas

    Joined:
    Jan 9, 2016
    Location:
    Tacoma, WA
    #10
    Thank you! It actually worked for me too...been driving me nuts trying to figure it out. Thanks again
     
  10. bruitmonkey macrumors member

    bruitmonkey

    Joined:
    Jan 22, 2014
    Location:
    Riga, Latvia
    #11
    Does this feature work only with English keyboard?
     

Share This Page