Flashing Folder on New Sierra Install

Discussion in 'Mac Basics and Help' started by Texas_Toast, May 20, 2018.

  1. Texas_Toast macrumors 6502a

    Texas_Toast

    Joined:
    Feb 6, 2016
    Location:
    Texas
    #1
    This must be what HELL is like...

    Back in January I was methodically learning how to "harden" my Retina with Sierra on it. When I was almost done with everything, during Apple > Shutdowns, I would get a black screen with a working mouse pointer and it just hung in a semi on/semi off state.

    About the same time, I noticed that when logging in after booting up, the cursor was hanging and everytime I tried to log in it failed because the hanging cursor meant my password wasn't entirely received.

    After spending a few months "hardening" my Retina, I gave up and had to rebuild it from scratch - as in download Sierra, create an installer, and go through the whole setup process again.

    It is now almost June, and I was hoping to wrap up "hardening" my - never used - late 2015 Retina tonight.

    I just added a "standard" user, and choose Apple > Shutdown.

    And you can guess what happened next...

    The screen went black, but was still on, I saw a mouse pointer that can still be moved, and my computer stayed on, but with no visible desktop.

    After waiting a couple minutes, I did a hard shutdown, and upon rebooting, I see a flashing folder...

    I am beyond NUMB right now...


    I have literally spent almost the last year setting up this now almost 3 year old Retina TWICE, and after all that effort I do not have a working machine!!!!!

    What the F*** did I do to deserve this???????????????



    Here is my thread from January with a similar abysmal outcome...

    https://forums.macrumors.com/threads/flashing-folder-with-question-mark.2099003/


    I think I spent like $1,800 on this ****ing laptop, and because of some family emergencies and what-not, I never got a chance to use my Retina when it was brand new.

    At this point I am ready to take a baseball bat to this thing...

    I have an $1,800 laptop, that is out of warranty, the last laptop Apple will ever make with a removable hard-drive, and now I have a very expensive boat-anchor!!!

    (Oh, and there used to be a troll on here that was always quick to say all of this was my fault!!!)

    I created a clone using CCC before supper tonight and before I created my "standard" user account, but at this point I feel like I have a clone of a piece of crap....

    Dear God, please someone help me figure out what is going on...

    I am DEVASTATED right now, and feel like crying...

    In fact, I have had so many life issues and computer issues, that macOS Sierra and my $1,800 laptop have become obsolete in the time it has taken me to try and get back on my feet and use my "new" MacBook Retina that I never got a chance to use!!!

    Please someone help me... :(:(:(
     
  2. hobowankenobi macrumors 6502a

    Joined:
    Aug 27, 2015
    Location:
    on the land line mr. smith.
    #2
    Sorry to hear.

    I think you might want to step back, take a breath, and think about what you want to do, and how to get there.

    Question: What does "hardening" mean?

    Security? I can't imagine anything that could take more than a couple hours that you would need to do.

    Please share what you mean and what "hardening" entails, and we can try to figure out if it has anything to do with your current issue.
     
  3. Fishrrman macrumors G5

    Fishrrman

    Joined:
    Feb 20, 2009
    #3
    Give up with the "hardening" b.s., already.

    I can't believe you have a 2015 MacBook Pro and haven't even got it "set up and working" yet.

    Do an internet recovery if you need to, to get a working copy of the OS on it.
    Can be done in about an hour.

    Or... take it to a brick-n-mortar Apple Store genius bar and have them install a clean copy of the OS onto it...
     
  4. Texas_Toast thread starter macrumors 6502a

    Texas_Toast

    Joined:
    Feb 6, 2016
    Location:
    Texas
    #4
    Apparently you didn't read a thing I typed above...
     
  5. hobowankenobi macrumors 6502a

    Joined:
    Aug 27, 2015
    Location:
    on the land line mr. smith.
    #5
    Still want to know what "hardening" is...

    No way to solve the problem with lots of unknown variables. You need a clean OS with no changes to see how the machine runs. There is no easy way around it, nor any reason not to do it.

    Until you are ready to start fresh....there is nothing to be done.
     
  6. mikzn, May 21, 2018
    Last edited: May 21, 2018

    mikzn macrumors 6502a

    mikzn

    Joined:
    Sep 2, 2013
    Location:
    Vancouver
    #6
    Sounds like you did the "hard shut down" before it finished installing the new user?

    If you have a Carbon Copy clone on an external drive - can you boot from that drive? If you can, then you can install a combo updater over top of the rMBP install and see if that fixes it - you can do this while booted from the external drive.

    Download macOS Sierra 10.12.6 Combo Update - edit changed from HS to Sierra link

    I read your other thread - putting a firmware password or installing High Sierra with encryption makes thing more complicated when things don't work.

    hope you figure it out
     
  7. Texas_Toast thread starter macrumors 6502a

    Texas_Toast

    Joined:
    Feb 6, 2016
    Location:
    Texas
    #7
    No. I finished creating a "standard" user and then I choose Apple > Shutdown. That is when things went wild.


    What is a "combo updater"?


    It also makes your computer more secure. (And I'm running Sierra.)
    --- Post Merged, May 21, 2018 ---
    It is the term used in IT to secure something...

    Both you and @Fishrrman are missing the key point...

    I just used my bootable installer to re-install Sierra this last week!!

    I do have a "clean" copy of Sierra on my Retina and with no software installed!

    I should not be getting these kinds of issues with a clean install!

    Which leads me to believe I have a bad SSD or logic board...
     
  8. mikzn, May 21, 2018
    Last edited: May 21, 2018

    mikzn macrumors 6502a

    mikzn

    Joined:
    Sep 2, 2013
    Location:
    Vancouver
    #8
    Combo updater is an update you can download and install over top of an existing install that does not have to go through each update - and usually brings the OS install to the latest version. Much quicker and easier than starting from scratch and always works for me (YMMV)

    If you can boot from your back up drive (Clone) - you can download it from the support page linked above (changed it to Sierra). It can replace any missing files or corrupted files and make sure the update is installed correctly.

    Sorry I missed your comment about Sierra / not High Sierra - and now changed the above link to Sierra
     
  9. hobowankenobi, May 21, 2018
    Last edited: May 21, 2018

    hobowankenobi macrumors 6502a

    Joined:
    Aug 27, 2015
    Location:
    on the land line mr. smith.
    #9
    I understand the concept. Can't troubleshoot concepts. While there are some best practices (and even those would be debated) there are no standards. If you asked 10 IT departments, you would get 10 diffident answers.

    What—specifically—did you do/change/configure to "harden" it?

    Since it did boot and run, but is now (after making config changes) not booting, you should consider that the changes may have caused a problem. The way to rule that out is undo them, or start fresh. Again. Starting fresh may be faster and easier than the undo...

    If you have a hardware problem, the only fix will be hardware. To prove you you have a hardware problem, you need to see if you can get a virgin OS (no changes) to run and be stable:

    So first steps, to see if it will run correctly and be stable would be one of these options:
    1. Use Recovery Mode to run Disk Utility to test/repair your boot volume
    2. Use Recovery Mode to reinstall the OS, which will repair/replace and damaged essential boot files
    3. Reinstall from your USB installer
    4. Boot to known good external boot OS drive and test/repair/reinstall
    5. Boot to known good external boot OS drive and run Combo Updater for the correct OS
    6. Boot to target mode and test/repair/reinstall from another Mac, or run Combo Updater for the correct OS
    7. Remove the internal drive and see if boots and behaves well on an external bus

    If after doing one of the above, and running the Mac for a good long while under load and lots of reboots, and the problem does not return, then odds are you have (had) a config problem, not a hardware problem.

    If you can't get a fresh install to boot, or it does but fails again during testing WITHOUT ANY CONFIG CHANGES then you could very well have a hardware problem. If the SSD is failing, you should get some errors running DU. Not always...depending on what the issue is. Even a bad SATA cable is possible, and was fairly common on some models.

    Not a dig....but if you are unfamiliar with what a Combo Updater is or what it does, you probably should not be "hardening" your Mac. Combo Updates are fairly basic, whereas many security measures are advanced. A mine field of issues for a non-advanced user.
     
  10. Fishrrman macrumors G5

    Fishrrman

    Joined:
    Feb 20, 2009
    #10
    OP wrote:
    "Apparently you didn't read a thing I typed above..."

    Much of what you typed doesn't make a lot of sense, from the standpoint of getting the thing running again.

    That's because it's essentially trivial to do a clean install of software on a MacBook and get it going again. Either do it with a bootable flash drive or through "internet recovery".

    Or... erase the internal drive -- WIPE IT OUT TO ZERO -- and "start completely clean".

    Thousands upon thousands upon thousands of people buy new Macbooks, go through the initial setup procedure, establish an account, and then use their computers day-to-day.

    For some reason, you cannot do this.
    You insist that it must be "more secure", "hardened", or.... something.

    Do you want it to work?
    Or are you just going to go on complaining forever, and keep coming back here again and again asking impossible questions on how to make it run after some of the operational contortions you've performed?

    The way I see it, you've got a couple of choices:
    1. Take it to Apple -- have a genius guy "wipe it" and then do a factory-fresh OS install for you. Then, boot it and set it up as any normal person would do.
    or...
    2. Take the hammer to it, or sell it, and find something else.
     
  11. hobowankenobi, May 21, 2018
    Last edited: May 21, 2018

    hobowankenobi macrumors 6502a

    Joined:
    Aug 27, 2015
    Location:
    on the land line mr. smith.
    #11
    If you mean write zeros to the entire drive...

    There is no need to write zeros to SSDs. That is only required for security reasons, and only for spinning HDs. It does however cause unnecessary wear, and add time. The bad outweighs the good.

    Because of the lack of need or usefulness, Apple has removed the Secure Erase (write zeros) option for SSDs.

    This is incorrect. If your password is incorrect (incomplete or otherwise) the log in box will shake. This specifically lets the user know that the log in credentials were challenged and not accepted.

    If you get a spinning cog...that means one of two things:

    1. The credentials were accepted, and the log in (and all possible options, including building a user home directory) are underway.
    2. The credentials were accepted, but a problem prevents the machine from logging into the user desktop (could be permissions, or a start up script or kext)
    3. The credentials were accepted, but the OS hung
    4. The machine is checking a directory server for credentials and waiting for a response (not applicable to single user/home machines NOT bound to LDAP or AD servers).
     
  12. Texas_Toast thread starter macrumors 6502a

    Texas_Toast

    Joined:
    Feb 6, 2016
    Location:
    Texas
    #12
    I made a "bootable installer" like you told me to...

    I successfully installed Sierra last week.

    I have re-booted my Retina with the clean install 100 times since then.

    Any "hardening" I have done, while not obvious to most mortals, is hardly complicated.

    Um, I added a password to my computer... Could that break it?

    I turned on FileVault 2...

    I installed a VPN...

    I secured Firefox...

    After 20 more re-boots, my Retina was working perfectly...

    I ran CCC and cloned my Retina yesterday afternoon...

    Then I added a "standard" user, and shut down my Mac.

    Is that "rocket-science"? I don't think so...

    Of course, when I chose Apple > Shut Down, my freshly rebuilt Retina blew up in a very similar way to how it did back in February...

    In your mind, I'm sure it's all *MY* fault... :rolleyes:
    --- Post Merged, May 21, 2018 ---
    As an "expert" you should know that you can't "WIPE IT OUT TO ZERO" on a SSD...


    That's it... Get frustrated at me... make it personal... And DEFINITELY blame me for these issues, because like you were here watching what happened....


    Has it ever occurred to you that I'm not an idiot when it comes to computers and Macs?? :cool:
     
  13. hobowankenobi, May 21, 2018
    Last edited: May 21, 2018

    hobowankenobi macrumors 6502a

    Joined:
    Aug 27, 2015
    Location:
    on the land line mr. smith.
    #13
    Looking back at your previous posts....I see you have been "hardening" your Mac before, and have had similar issues before. Repeatedly.

    Maybe stop?

    Do you need a firmware password? Why? Most users don't.

    Do you need to encrypt your Mac? Why? Most users don't.

    What other variables or complications have you introduced?

    Each thing you do in the name of security has consequences, and many of them are substantial. Often the consequences outweigh the need or usefulness of the secure process or requirement. Most importantly, if you want to test that your hardware is working correctly, you cannot easily verify what's wrong with lots of variables that prevent options.

    Apple won't do it, nor will any knowledgeable tech. Apple won't even troubleshoot a machine with any third party RAM. They pull it. Simply getting down to the minimal number of variables.
     
  14. Fishrrman macrumors G5

    Fishrrman

    Joined:
    Feb 20, 2009
    #14
    "Has it ever occurred to you that I'm not an idiot when it comes to computers and Macs??"

    Well, I'll assume you know much more than me.

    hobo gives VERY good information in #11 above.
    Chances are, something you've done within the account is messing things up, because the login won't complete.
    It could be a login item, a kext, something along that line that is gumming up when you login.

    For now, I'd get rid of the VPN.
    I'd also stop using Firefox, if "securing it" may be interfering with other operations.
    I'd TURN OFF FileVault -- again, to see if that makes a difference.

    In other words, remove everything that you have done to "harden" the computer. Seems like your efforts have been successful, because it's now so hardened that even you can't get to it!

    Why don't you create a "barebones, test" account, with NOTHING added to it?
    For "testing purposes only".

    If you can login to the test account, even if you can't login to your "regular" account, that points to something you've done in your account that is mucking things up.

    Personal experience in 31 years of using Macs:
    I don't "harden" anything.
    Everything on my Macs is "right out in the open", no protection at all.
    No Filevault. No EFI password. No VPN. No nuthin'.
    I WANT things to be easy to "get to".
    Somehow, I've survived.
     
  15. mikzn macrumors 6502a

    mikzn

    Joined:
    Sep 2, 2013
    Location:
    Vancouver
    #15
    From your original post . . .

    If it was my situation the last thing I did before the problem occurred would be my starting point and most suspect?

    When adding a new user there are a lot of install scripts working in background and probably were still running when you opted to by-pass that and do a "Hard Shutdown"

    You did not reply to booting from the clone / back up drive - but if this works - it will eliminate most of the hardware issues - such as the motherboard and many other hardware potential problems. If it works the combo update is an easy and most time effiecient next step.

    It still seems to me that the new user account lost the boot info ( where to boot from?) - I am sure you tried pressing option when booting the mac to find a start up folder?

    If you have another Mac (target disk mode) or can boot from the clone - this will be an easier situation to figure out.
     
  16. Texas_Toast thread starter macrumors 6502a

    Texas_Toast

    Joined:
    Feb 6, 2016
    Location:
    Texas
    #16
    I have A LOT of forensics to do on my Retina...

    Maybe I'll have a working computer on Labor Day?

    In the mean-time, for all my "haters" out there...

    The only thing I added to my Retina that I have not already been running for the past FIVE YEARS on my 2011 MacBook Pro is a firmware password.

    The only thing!

    So it would appear that I know how to build a secure Mac already, and it would appear that if I can get all of those predominately Apple items to work on a 7 year old Mac running Mountain Lion, then they sure as hell should work on a (formerly) brand new Retina!

    Of course I'm SURE that all of this is still somehow my fault...

    Post mortem to follow...
     
  17. hobowankenobi macrumors 6502a

    Joined:
    Aug 27, 2015
    Location:
    on the land line mr. smith.
    #17
    So eliminate that first?

    Setting up a firmware password does change access, bootable options, and more. If your disk is encrypted, you don't need a firmware password; it is redundant protection, and hampers troubleshooting and recovery....like what you face now.

    I thought you said you did a bunch of hardening....perhaps I misunderstood.

    Also, if you already had the drive encrypted, and/or a firmware password set during your preivous configuration, neither of those would have changed by reinstalling the OS. Unless you turned them off, and started over.
     
  18. Texas_Toast thread starter macrumors 6502a

    Texas_Toast

    Joined:
    Feb 6, 2016
    Location:
    Texas
    #18
    Over the last week, I have booted up my *new* Retina a few times...

    When I do a normal power own, it has booted up to the Desktop okay (so far).

    And when I have "option booted", I got the firmware padlock as expected, I entered my firmware password, and then I got a choice of disks to boot to. So that has been working okay (so far) as well.


    Nonetheless, I am seriously tempted to call Apple on Tuesday, and see if I can get the supervisor I spoke to when Apple sold me a boat anchor back in 2016. (You see, my original Retina was D.O.A. and I had to fight with corproate to send out a a new replacement.)

    I have heard that Apple has some program where you play a (high) flat-fee, and they guarantee to fix your Mac?


    Here is why I worry that I have a hardware issue...


    1.) This replacement *new* Retina has had LOTS of problems when I shut it down using Apple > Shut Down.

    2.) This *new* Retina has frozen up temporarily (i.e. pointer freezes) A LOT.

    3.) This *new* Retina had some strange issues with the OS slowing down to where EVERY TIME I typed in my system password, it wouldn't take it because it was only capturing every other keystroke. (If my password was "password" then Sierra was only capturing "pswr"!)

    4.) After I built a bootable Sierra installer and re-built my system from scratch, I had the issues mentioned in my OP.

    I know how to install an OS and set up a machine, so for it to puke right after I built it makes me think it is less an OS issue and more likely a firmware or hardware issue.

    5.) Every time I would Command+R boot into Recovery Mode and format my *new* Retina's internal hard-drive using Disk Utility, when I chose "Erase" I would ALWAYS get an error that it didn't format my hard-drive.

    So I had to try a second time and format it as "TEST", and then do it a third time to get it formatted like I wanted.

    That is NOT normal, and that happens every time I try to format my internal drive.


    That being said, I wonder if maybe there are some bad blocks on my internal, factory, SSD?

    Or maybe there is something wrong with the logic board?



    Since this is out of warranty - although never used - looks like I'll be out a grand to get this resolved... :rolleyes:
     
  19. Texas_Toast thread starter macrumors 6502a

    Texas_Toast

    Joined:
    Feb 6, 2016
    Location:
    Texas
  20. DeltaMac macrumors G3

    DeltaMac

    Joined:
    Jul 30, 2003
    Location:
    Delaware
    #20
    I think that you have a botched macOS installation.

    But ---
    Turn OFF the EFI (firmware) password for now. Use it a couple of days, with your normal user account, or logged in to an admin user. Shut down when not using it, so it gets a good boot from cold (power off) each time you want to use it.
    If you get a good boot (no flashing folder) for a few days use, then you could try re-enabling the firmware password. Don't change ANYTHING else that would affect your booting. If you then get problems with booting, you know that there is some incompatibility with the Booting while the EFI password is enabled. Turn it off. Ignore that "feature".

    If the firmware password has no effect, either good or bad, then, I would posit that (I think) you have a flaky SSD.
    The only way to test this is to replace your SSD proactively.

    The part that concerns me the most is the missing characters when you type in your login password.
    Is that only when you login to your Mac system - or, every time you are asked for a password (to install new software, for example) Those would be the same password, but very different events, I think.
    I would suggest that you double check about typing that password: when you need to type that password, pause before typing, then type each character approximately one per second (don't be in a rush for this test, just type one at a time, with short pause between each) if it still misses characters on initial system login, then I have no clue. If it ignores every other character later on, say to install new software, etc, then you may have some kind of user issue in your system software. If you are logged in as a normal user (not admin account), and see that - log out, then log in to your admin account, and try the same install (or whatever for the admin password). If THAT works, then it's your standard user account. If no change, then it's a general system problem of some kind - reinstall macOS next - and try the password stuff again.

    I'm kinda rambling here, because I DON'T know what other software you have installed that might affect I/O in your system. There's LOTS of experimenting here. Too bad you don't have someone local who you can call on to help you out some, even to just pick their brain a little.
     
  21. Texas_Toast thread starter macrumors 6502a

    Texas_Toast

    Joined:
    Feb 6, 2016
    Location:
    Texas
    #21
    Except I had this problem in January when I was using the original OS from Apple...

    And after doing a clean install using my bootable Sierra installer, it happened a second time.

    (BTW, I just used my bootable Sierra installer on my *used* Retina, and so far, so well. Will keep configuring and hardening my *used* Retina this weekend, and see what happens...)


    I turned off the EFI password when I first had issues last weekend. Since then I have re-booted several times and things seem to be working okay now.

    I have the EFI password turned back on, and I can boot up straight to my standard user and admin user okay.

    I can also option-boot to another drive like my clone and that works okay with the EFI password on.

    Have NOT had any hanging up so far logging in or in general, of course I am nervous as hell that I'll get burned once I start adding applications and data... :(


    I'm leaning towards that, but what do I do?

    Buying a replace 1TB SSD from somewhere like OWC will cost me $700+

    And I no longer have a warranty due to all that happened on the family front...

    Time = $$$, but I'd hate to piss away $700-$1,000 when it could be a software issue... :oops:


    And because I am a privacy and security nut, once I have business data on my SSD, if there is an issue then I;ll yank it out and smash it up with a hammer. (Umm, that is why I bought a 2nd *used* Retina - because this is my "last hur-rah" as far as *removable* hard-drives go...)


    Understand the issue isn't a faulty keyboard or logic board, but rather - as far as I can tell - the OS hanging up.

    In January, it seemed to me that Sierra was only getting "pswr" or more like "word" instead of "password" because it was hanging for the first second while I logged in.

    (FWIW, I use a "pass-phrase" that is 5 words long plus additional characters...)

    I haven't had that issue with my latest install on my *new* Retina, but then the fact that I got a black screen with cursor and couldn't get things shut down after a fresh install, and then I got the flashing folder icon a couple times before I was able to boot up again to my internal drive is very concerning to me!!!

    I'm thinking next week I need to call Apple and plead my case with someone higher up.

    Not looking for a new mac or any hand-outs, but those bastards already shipped me a D.O.A. Retina in August 2016, and now look what is happening...

    I have pissed away at least 6 months with booth of these issues and that probably costs me more $$$ than just replacing things with a new laptop!! (I have a website and business on hold while I try to get my computer issues sorted out...)


    All I have on my *new* Retina right now is base Sierra + patched Sierra + Firefox + CCC + VPN client.

    Pretty simple stuff.

    And while I have FileVault 2 and the EFI password turned on, counter to what Fishrrman says, I have used both for years with NO ISSUES on my 2011 MacBook, so to say those or unnecessary and risky features to use is silly.

    Had all of this happened on my 2011 MBP, I'd go buy a $65 HDD from B&H, install it myself in a few minutes, and be back up and running.

    All of this miniature, soldered, unservicable hardware is not only a PITA, but it is costing people like me thousands of dollars when it fails...

    Thanks Tim! :mad:
     
  22. Texas_Toast thread starter macrumors 6502a

    Texas_Toast

    Joined:
    Feb 6, 2016
    Location:
    Texas
    #22
    @Fishrrman,

    The last time we spoke, below are some of the *nice* things you had to say...


    So here's the funny thing...

    As it turns out, I had a bad logic board in both of my Retinas!!

    In fact, out of the 3 MacBook Pro Retinas that I have ever owned, ALL 3 OF THEM HAD BAD LOGIC BOARDS!!

    100% Failure Rate!!

    The first, "brand new" Retina, that I bought back in August 2016 was dead-on-arrval (DOA), and I had to fight viciously with Apple to get them to send me a new one. (All while my father was dying in a nursing home?!)

    And the "brand new" repalcement Retina that Apple sent me - which is what this and many other threads have been about - also had a bad logic board in it! (And in the end, I got stuck paying something like $600 to pay Apple to replace it?!)

    And then the "near new" Retina I bought from Macs4U - for which there are also lots of threads on here - also had a bad logic board in it.

    One again... 100% Failure Rate on all of the Retinas I have owned. (And these were the "good ones" before Apple quality really started going down-hill.)


    So, with all of that being said, I would like to make a few points...

    Point #1:
    When it comes to Macs and macOS, there are a lot of brilliant people on MacRumors, and I will be the first one to admit that your knowledge about Macs in most impressive.


    Point #2:
    I am NOT the idiot that you (and others) painted me out to be!!


    Point #3:
    Simply put, I was right and you were wrong...

    All of the problems I mentioned in this, and numerous other threads, were the result of sh*tty Apple components, and had NOTHING to do with my ability to "harden" my MacBooks!!


    Point #4:
    Since replacing both logic boards, I have not had a single problem in over 7 months!!! (And, yeah, I hardened the holly-hell out of my Macs and they run perfectly!)


    Not sure if you will read this post, and if you do, if you will care. But either way, I wanted to set the record *straight* for all of my naysayers out there... :rolleyes:
     

Share This Page