freeze on ml

Discussion in 'OS X Mountain Lion (10.8)' started by iOrbit, Jul 31, 2012.

  1. iOrbit macrumors 6502a

    Joined:
    Mar 8, 2012
    #1
    i just had a bit of a nasty freeze on mountain lion, the cursor was moving fine but everything else was unresponsive (gestures, dock, app, menu bar)

    and then after trying to figure out the short cut key to force quit, the dock graphically kind of messed up, icons switched around and were badly misaligned from their shadows.

    im concerned about what caused this, i just installed 16gb of ram, samsung ssd 830 today.

    everything has been running flawlessly for since 10 hours ago.

    the only things iv done recently, is turn Trim on, and install some apps, i turned trim on a few hours ago. but this crash happened 5 minutes into using a new app i bought - 'reeder'

    anyone had this experience with reeder?

    i hope i don't have a bad hdd/ram..
     
  2. slrandall macrumors 6502

    Joined:
    Jun 15, 2011
    #2
    Verified your disk with Disk Utility?
     
  3. iOrbit thread starter macrumors 6502a

    Joined:
    Mar 8, 2012
    #3
    just verified, apparently all is ok, im not sure if the system is performing exactly how it was before the crash, could be placebo.

    im running memtest right now, so far ok.

    if its to do with trim, well it happen once a day?

    i have no idea what could have caused it.

    im using steam and i installed a bunch of games a hour or more before the crash.

    gonna list the apps i had installed at the time:

    dropbox
    skype
    steam
    adium
    air media server
    instant
    disk doctor
    mindnode lite
    photosketcher
    color splash studio
    mplayerx
    skitch
    the unarchiver
    better touch tool
    perian
    carousel
    xee
    day one
    pic frame
    trim enabler
    black magic disk
    cheatsheet
    caffeine
     
  4. iOrbit, Aug 4, 2012
    Last edited: Aug 4, 2012

    iOrbit thread starter macrumors 6502a

    Joined:
    Mar 8, 2012
    #4
    just had another identical freeze.

    i'm not sure whats going on :(

    the apps i had running are

    app store, mail, safari, contacts, calander, itunes, messages, reminders,
    notes, skype, adium, dropbox.

    i'm on a late 2011 mbp, 16gb ram, samsung 830 ssd.

    i have trim enabled, and thats the only thing i can suspect.

    its happened to me twice, over a 3d heavy use period.
    it may be 4 days even.

    i'm finding it hard to figure out whats causing it, i was using mountain lion for about 3 days before i upgraded my computer, and i didnt have a crash.

    i upgraded my macbook to 16 gb of ram and to a samsung 830 ssd, those plus trim are really the only new things im using/doing on them machine. i have most of the same apps installed, and in use.

    i'v turned off trim to see if its that. i have taken the risk i suppose of installing things that might not be fully compatible with lion?

    i.e. Perian.

    i wondered if i had bad ram, so i ran memtest but it said all was fine, but is memtest 100% reliable at telling good ram from bad?
     
  5. Woodcrest64 macrumors 6502a

    Woodcrest64

    Joined:
    Aug 14, 2006
    #5
    I had something similar happen to me on my retina macbook pro 2 days ago.

    I plugged in my headphones and my trackpad buttons stopped working. I did hit something on the keyboard as I tried to plug in my headphones but I'm not sure if that is what caused the problem.

    I essentially thought my system was frozen but the keyboard abled me to navigate osx to shutdown. However even with shutting down and restarting that did not fix my problem. I had to enable my bluetooth mouse and my trackpad starting working.

    I haven't had the problem happen to me again but it was odd. I too have 16gb of memory on my macbook.

    I think ML still has a few kinks in it.
     
  6. iOrbit thread starter macrumors 6502a

    Joined:
    Mar 8, 2012
    #6
    my freezes are a little different,

    i think both times it happened, i was interacting with the DOCK

    the time that just happened now, i literally clicked on itunes in the dock to bring it back up.

    then the menu bar froze on ituens, i couldn't click anything, i could still move the mouse cursor around but nothing was responsive. in the end i closed the lid to see if i could put it to sleep and wake it back up. instead the cursor just turned into a beachball and wouldn't move anymore.

    im very unsettled by this, especially if its a hardware problem, as that means the headache of having to open up my mbp more times and see how things run on 'less' hardware.

    :(
     
  7. SlCKB0Y macrumors 68040

    SlCKB0Y

    Joined:
    Feb 25, 2012
    Location:
    Sydney, Australia
    #7
    I have the exact same setup, except my SSD is a crucial M4. I was running fine for a month on Lion and since installing Mountain Lion i've been getting the exact same intermittent crashing.

    I've also noticed some graphical corruption in Mail.
     
  8. iOrbit thread starter macrumors 6502a

    Joined:
    Mar 8, 2012
    #8
    did you turn trim on since you installed your ssd? iv turned my trim off to see how i go without it.

    i bought my ram from crucial. their 8gb ram ran perfectly for me for a 3 months.

    im sure my ssd is on the latest firmware or atleast one that everyone was saying they had no problems on
     
  9. SlCKB0Y macrumors 68040

    SlCKB0Y

    Joined:
    Feb 25, 2012
    Location:
    Sydney, Australia
    #9
    I had trim enabled on my SSD under Lion for more than a month without issue. This crashing only started about a week into using ML (I enabled trim as soon as I installed ML so it was running for about a week with this enabled without issue).
     
  10. iOrbit thread starter macrumors 6502a

    Joined:
    Mar 8, 2012
    #10

    i just had another crash, same kind. while trim was turned off. so i can rule out Trim i think.

    i can only now think its down to hardware, can apps that are installed but not being used, cause this kind of crashing?

    i noticed this crash happened at exactly the same time as the last one - while interacting with the dock. i clicked the notes app which was already running, and before it could move much in its genie effect, the system and the dock froze except for the mouse cursor.

    i decided to be patient to see if anything happened - all that happened were some graphical glitches on the dock, and the notes app after it managed to just appear at the front of my other app (reminders)

    despite the graphical glitches, this cant be a gpu problem can it? i mean, the glitches are not consistent, and i can still move the cursor around.

    the newest hardware i'v installed - hdd or ram.. not sure hwat to take out, i suppose i should try running the system on 1 stick of ram from the new modules and see if it keeps happening. or put my 8gb of ram back in (where i had no issue).
     
  11. colloc macrumors member

    Joined:
    Jul 27, 2012
    #11
    Run some utility to check your RAM. If SSD's okay then RAM's the next suspect. ML must be staggering because it cannot read from some bad ram blocks, causing the system to become unresponsive.
     
  12. Dizzle88 macrumors newbie

    Dizzle88

    Joined:
    Sep 25, 2008
    #12
    The same thing as OP happened to be after I installed TRIM enabler with a Crucial M4. It has happened since I turned it off also but I didn't have any problems before and had been running ML
     
  13. iOrbit thread starter macrumors 6502a

    Joined:
    Mar 8, 2012
    #13
    i ran memtest, and everything came back fine according to it, is memtest 100% accurate?

    the system generally runs perfect, it just has those random freeze moments, they happen about once every 24 hours or more. under a fair amount of use.

    do you think a reformat would fix this then? im not sure. was your ssd the only upgrade you made?
     
  14. SlCKB0Y, Aug 5, 2012
    Last edited: Aug 5, 2012

    SlCKB0Y macrumors 68040

    SlCKB0Y

    Joined:
    Feb 25, 2012
    Location:
    Sydney, Australia
    #14
    I just had another crash. I'm now convinced this is related to gfx drivers/flash....my system logs also support this.

    ----------

    We're running a .0 OS release and my hardware has been fine up until this point.

    A hardware fault is not at the top of my list.

    EDIT:

    This fits my issue:
    http://code.google.com/p/chromium/issues/detail?id=137261

    This is of particular interest to me:
    And this matches as well:
    https://discussions.apple.com/thread/4170395?start=0&tstart=0

    Possibly also relevant:
    http://code.google.com/p/chromium/i...fied Owner Mstone OS&sort=-modified&id=137667

    I get this repeated in my logs at the time of the crash:

     
  15. iOrbit thread starter macrumors 6502a

    Joined:
    Mar 8, 2012
    #15
    thats interesting, i mean the graphical glitching m witnessing supports it, but it seems strange, im sure ml ran fine for 3 days at least, before my upgrades. then after that i had this issue.

    can everyone who thinks they have this issue, describe what actually happens in the freeze in detail? for me its happened twice while clicking the dock. and the dock graphically gets messed up (shadows remain bt icons move and become froze.

    the system doesnt respond anywhere, including the menu bar.

    interestingly the cursor remains unfrozen and i can move it (no beachball) until i click on the menu bar or try and do something.


    and can everyone state their hardware machine?

    mines a late 2011 macbook pro, 2.2ghz base model 15 inch.

    AMD Radeon HD 6750M 512 MB

    how can i find logs of my issue??
     
  16. SlCKB0Y macrumors 68040

    SlCKB0Y

    Joined:
    Feb 25, 2012
    Location:
    Sydney, Australia
    #16
    mine ran fine for at least a week before this started.

    Mine has happened a number of ways. Sometimes i'll be in Chrome with a few youtube windows open...I'll go to click on a video link and BAM! or another time a mouse over the dock causing the icons to zoom and same thing.

    Regardless of the trigger, the screen freezes up, no icons zoom, no menus or window movements work even though I can still move the mouse around. This usually ends in a beachball and then total system freeze.

    Interestingly, on at least one occasion whilst still able to move the mouse, I could hear the Adium alert sounds of people logging on - so that app was still running it just couldn't draw to the screen.

    In Mail.app I've also noticed graphical artefacts being shown in place of email images. This doesn't coincide with crashes necessarily but supports the idea that this is a gfx problem.

    Next time it happens i'm going to try and SSH in to the Mac.

    Late 2011 13" MBP, base model, HD3000 gfx (yours will have this as well). + 16GB G.Skill "For Mac" RAM and a 256GB Crucial M4 SSD.

    The easy way is to go to Applications >> Utilities >> Console

    On the left hand side try "All messages" or under files "system.log"

    Then simply try and match the time of your crash with the logs. Keep in mind there will be a lot of logging from the reboot you performed after the lockup.
     
  17. SlCKB0Y, Aug 5, 2012
    Last edited: Aug 5, 2012

    SlCKB0Y macrumors 68040

    SlCKB0Y

    Joined:
    Feb 25, 2012
    Location:
    Sydney, Australia
    #17
    More links for you:

    http://apple.stackexchange.com/ques...ently-full-screen-flash-in-chrome/58595#58595

    http://apple.stackexchange.com/ques...mountain-lion-hung-but-the-mouse-still-worked
    http://www.dslreports.com/forum/remark,27397208

    These ones shows the general GFX glitchiness I see in Mail.app:

    https://discussions.apple.com/thread/4160728?start=0&tstart=0
    https://discussions.apple.com/thread/4145850?start=0&tstart=0
     
  18. iOrbit thread starter macrumors 6502a

    Joined:
    Mar 8, 2012
    #18
    thanks sickboy, i have to get ready to go work right now but i checked the console and i have the same messages in my console as yours, repeated several times

    i will be back to check out the rest later, i hope we get to the bottom of this problem, i wonder hwy it seems like its only a few of us affected on various models of machine?

    i only use lion mail, and i don't recall seeing anything strange or glitchy on it yet.
     
  19. SlCKB0Y macrumors 68040

    SlCKB0Y

    Joined:
    Feb 25, 2012
    Location:
    Sydney, Australia
    #19
    I think it might be more than it seems as I've had at least three things cause it (with I believe the root cause being GFX drivers) and so it is being attributed to other things.

    The results that I have posted so far a just a sample of the following searches:

    mountain lion lock up
    chrome lock up mac
    mountain lion dock lock up
    etc etc...but they all seem to be related to the same root cause.

    So depending on what people are doing at the time of the crash, they will attribute this bug to that and so it makes searching for it a lot harder.

    Of course, it might be some obscure bug which is caused by graphics drivers but only shows up on non-standard hardware - like people who have a third-party SSD.

    That is worst case scenario as if it is a purely software problem which is not hardware dependant then it will get fixed and if it were a hardware problem I could return the hardware....but a combination means Apple won't fix it and the hardware vendors won't find a fault...
     
  20. TomDD macrumors newbie

    Joined:
    Aug 7, 2012
    #20
    Having the same problem on my MacBook Pro 2011 model with Intel 3000 and Mountain Lion installed. It only happens to me while using Chrome and mostly while viewing videos on YouTube, not sure if that is a coincidence or not.

    Ran memtests etc... with no issues and getting the same message in the System log regarding the graphics engine hanging.

    TomDD
     
  21. SlCKB0Y macrumors 68040

    SlCKB0Y

    Joined:
    Feb 25, 2012
    Location:
    Sydney, Australia
    #21
    Most of the times it has happened to me it has been whilst using Chrome for Youtube(flash).

    Are you using the stock HDD and/or RAM?
     
  22. TomDD macrumors newbie

    Joined:
    Aug 7, 2012
    #22
    No I ugraded both a while ago when using Lion (8GB Crucial RAM, 1TB Samsung M8 drive) and have had no issues till upgrading to Mountain Lion. I've kept the originals with no changes so if it continues will revert to the originals and see if it still happens.

    TomDD
     
  23. Predator69 macrumors member

    Predator69

    Joined:
    Jun 29, 2012
    #23
    ML creating more issues by the day . Woder if apple going to come out with a patch or upgrade for ML
     
  24. Loco.Dice, Aug 9, 2012
    Last edited: Aug 9, 2012

    Loco.Dice macrumors newbie

    Joined:
    Mar 8, 2008
    #24
    My 13" i5 2011 MacBook Air has lockups as well. The only custom option I have is the USA keyboard, purchased at Apple online.

    I thought I had isolated the problem to Google RSS reader "Caffeinated" but it seems to be happening even when Caffeinated is closed (completely closed, so application quit).

    The complete system freezes and only the mouse cursor moves. Happens with and without peripherals connected. With and without an external VGA display using the Apple adapter.

    My logs show these messages when things go wrong:

    Code:
    8/9/12 11:42:43.000 AM kernel[0]: stampWait: Overflowed checking for stamp 0xdb0171 on MAIN ring: called from 
    8/9/12 11:42:43.000 AM kernel[0]: timestamp = 0xdb014b
    8/9/12 11:42:43.000 AM kernel[0]: ****  Debug info for *possible* hang in MAIN graphics engine  ****
    8/9/12 11:42:43.000 AM kernel[0]: ring head    = 0x2ac0ef64, wrap count = 342
    8/9/12 11:42:43.000 AM kernel[0]: ring tail    = 0x0000fe10
    8/9/12 11:42:43.000 AM kernel[0]: ring control = 0x0000f401   enabled, auto report disabled, not waiting, semaphore is waiting, length = 0x010 4KB pages
    8/9/12 11:42:43.000 AM kernel[0]: timestamps = 0xdb014b
    8/9/12 11:42:43.000 AM kernel[0]: Semaphore register values:
    8/9/12 11:42:43.000 AM kernel[0]: VRSYNC: (0x12044) = 0xdb014b
    8/9/12 11:42:43.000 AM kernel[0]: BRSYNC: (0x22040) = 0x1
    8/9/12 11:42:43.000 AM kernel[0]: RVSYNC: (0x 2040) = 0x0
    8/9/12 11:42:43.000 AM kernel[0]: BVSYNC: (0x22044) = 0x0
    8/9/12 11:42:43.000 AM kernel[0]: RBSYNC: (0x 2044) = 0x0
    8/9/12 11:42:43.000 AM kernel[0]: VBSYNC: (0x12040) = 0x0
    8/9/12 11:42:43.000 AM kernel[0]: trying to clear semaphore wait on MAIN ring
    8/9/12 11:42:43.000 AM kernel[0]: After attempt to clear semaphore wait = 0x0000f001 no longer waiting
    
    This message block repeats itself until I force shut down the machine.

    It happens every day. Google Chrome has never been installed on my system in case anyone wonders since that comes up a lot. I only use Safari.

    -edit-

    I forgot to mention this is a clean install. I downloaded Mountain Lion from the App Store in Lion, created a bootable USB drive and performed a clean install.
     
  25. SlCKB0Y macrumors 68040

    SlCKB0Y

    Joined:
    Feb 25, 2012
    Location:
    Sydney, Australia
    #25
    Thanks for the info. I think this further supports the idea that this is a graphics driver issue with the HD3000.

    Hopefully 10.8.1 which is in the pipeline fixes this as its a pretty nasty bug.
     

Share This Page