Fresh Sierra and iOS 10 installs - Can't send iMessages from computer

Discussion in 'macOS Sierra (10.12)' started by Itzamna, Aug 8, 2017.

  1. Itzamna macrumors 6502

    Joined:
    Jun 5, 2011
    #1
    Hello there.
    So I decided to update my computer and iPhones operating system and everything is working normally except iMessages.



    I can send iMessages and normal SMS from my iPhone, but on my computer I can only send SMS's. Everytime I try to send a sms to a iPhone I get an error saying that the number I'm trying to reach is not registered.



    Now, the weird thing is that if I put the country code on the number, the iMessage is sent! That's a major inconvenient because we barely use the code country here and none of my contacts have it.



    Is there a way to fix this without having to edit ALL my contacts to add the country code?



    Thank you!
     
  2. Lunder89 macrumors 6502

    Lunder89

    Joined:
    Oct 16, 2014
    Location:
    Denmark
    #2
    Try to turn off iMessage on your iPhone, and then re-enable it. That sometimes does the trick.
     
  3. Itzamna thread starter macrumors 6502

    Joined:
    Jun 5, 2011
    #3

    Thank you for your answer. I've done that already... A few times now. With no success. :(

    No one ever experienced this?
     
  4. RumorMania macrumors newbie

    Joined:
    Aug 9, 2017

Share This Page