full screen photo when someone calls

Discussion in 'iPhone' started by Dr4Eyes, Aug 18, 2008.

  1. Dr4Eyes macrumors newbie

    Aug 18, 2008
    Fremont, CA
    How do you get your caller's ID photo to be full screen when they call instead of just the small box in the top corner?? Sorry if this has been discussed prior, new 3G iphone guy here :D
  2. Julien macrumors G4


    Jun 30, 2007
    Better question is how did you get it in a small box in the top corner?:confused:
  3. Jeremy1026 macrumors 68020


    Nov 3, 2007
    You have to add the contacts photo using your phone, instead of syncing it from your computer.
  4. TwoBytes macrumors 68030


    Jun 2, 2008
    All old contacts from other phones transfered to the iphone will appear this way.
    Add pictures from either
    mobile me
    your phone
    sync pics from your desktop to your iphone and then add
  5. deannnnn macrumors 68000


    Jun 4, 2007
    New York City & South Florida
    If you use Address Book on your Mac to set a picture to a contact, it will show up in the small box.

    If you set a picture to a contact directly from your iPhone, it will show up full screen.
  6. davidhalfbreed macrumors newbie

    Jun 18, 2009
    It also works if you ad the photo via MobileMe
  7. Dr4Eyes thread starter macrumors newbie

    Aug 18, 2008
    Fremont, CA
    ok kool
  8. fjfjfjfj macrumors 6502

    Mar 20, 2009
    New York, NY
    I love that people have the same OCD questions that I do about stuff.

    Why would they have two different display options - I would think no matter how the photo was added it should appear the same way.

    Now I have to decide how I want all of them to show and go back and add them the same way so they all appear the same.
  9. drbob20 macrumors member

    Jan 16, 2008
    Agreed, why don't they all show up the same way & is there a fix? I imported my contacts from my address book, so is small my only option? There's no way I can change all manually. Seems odd.....
  10. Burr510 macrumors member


    Nov 20, 2010

    It may have something to do with the quality of the image. I know when I had my android phone the contact pics would show full screen... but they looked very distorted and blurry. Probably because they came from my Gmail contacts which were not high quality… even though I uploaded it from a high quality image

    Maybe a little image quality control from Apple
  11. DDustiNN macrumors 68000


    Jan 27, 2011
    All of my contact photos were synced from Facebook. I also dislike that only a tiny picture shows up when they're calling... And I also dislike that it shows my lock-screen photo for calls. Kinda weird.
  12. shakeman0 macrumors 6502a


    Jul 20, 2009
    This is how I did it.
  13. patp Guest

    Apr 10, 2008
    good info. i was wondering about this too, but didn't want to get the regulars all worked up for not searching first.

    thanks for the info.
  14. kicko macrumors 65816

    Aug 26, 2008
    i'm not sure why they dont just make that an option in iOS, myself i perfer the smaller pics since bigger ones can get a little distored sometimes, but it all personal choice. I just find it a pain i can only add pics to contacts from the iphone. I usually email it it to myself, then save and add to the contact.
  15. xraydoc macrumors demi-god


    Oct 9, 2005
    Not sure, could be wrong, but I think it has something to do with the vcard format used for contacts. Vcard may use a low quality picture, hence the small image, while pictures that reside on the phone can be called up instead, hence the full-screen image.

    At least that's my theory.
  16. himesh macrumors regular

    Dec 7, 2010
    Birmingham, England
    I did mine through facebook and it fills the screen when the person calls
  17. Don Walters macrumors newbie

    May 30, 2011
    Mine is still not working. I'm on Verizon with an iphone 4 and I am syncing my contacts using Gmail exchange. I went into contacts and selected photos from the phone's photo library. But it still shows a small picture when those people call me.
  18. Agent-P macrumors 68030


    Dec 5, 2009
    The Tri-State Area
    Gmail resizes the contact photos when synced with the google servers. For this reason it shows up with a small picture on the phone. That part kinda annoys me. Once my MBP gets here, I'm gonna import my contacts into address book and re-apply the contact photos.
  19. iceterminal macrumors 68000


    May 25, 2008
    Dallas Tx.
    Same problem here. What you'll have to do is NOT sync your contacts with Google, if you want the large picture. Then with each new contact you create on your iPhone you'll use a large picture.
    The simple act of syncing contacts up to Google will send all the data & pictures up to Google which will then resize the pictures and then send them back to your phone...with the small picture.
    Yes, it sucks. Many many people have this problem too.
    Turning off the contact sync was the only resolution I found to work.
  20. ilovegoodnugz macrumors regular

    Jun 29, 2010
    Sorry to bump an old post, but I just upgraded to IOS 5 and the reverse happened, now all my caller id pictures are full screen, I love them tiny! Anyway to revert back? Thanks!
  21. Matthew Yohe macrumors 68020

    Oct 12, 2006
    Use small photos.
  22. mcdj macrumors G3


    Jul 10, 2007
    I use small pics for all my ugly contacts and large ones for the better lookin' ones. No one wants a big ugly face in their big ugly face.
  23. ilovegoodnugz macrumors regular

    Jun 29, 2010
    How do I use small photos? I just want to have the small one that is in my address book on my mac, just like it was before I updated to iOS 5? Help
  24. johna1234 macrumors member

    Oct 14, 2011
    Wirelessly posted (Mozilla/5.0 (iPhone; CPU iPhone OS 5_0 like Mac OS X) AppleWebKit/534.46 (KHTML, like Gecko) Version/5.1 Mobile/9A334 Safari/7534.48.3)

    I'm with u on this , would love to know how. However I'm on a pc. I have no clue how to do this. U would think it would be an option in settings by now lol
  25. ilovegoodnugz macrumors regular

    Jun 29, 2010

Share This Page