Function keys aren't working on my iMac

Discussion in 'Mac Basics and Help' started by GPellizzon, Jul 10, 2017.

  1. GPellizzon macrumors newbie

    GPellizzon

    Joined:
    Jul 10, 2017
    Location:
    Brasil
    #1
    The only function keys I use frequently are F1, F2, F3, F10, F11 and F12 and they used to work properly until one of these days when F1, F2 and F3 stopped working all of a sudden. F10, F11 and F12 (volume keys) are still working though.

    I went through many troubleshooting guides that suggested:

    a) Toggling on/off the "Use all F1, F2, etc. as standard fuction keys" option under the keyboard section on System Preferences. Nothing happened. I even restarted the computer with it toggled on/off.

    b) Restarting the dock using the killall Dock command on Terminal. Tried it. Nothing.

    c) Resetting the System Management Controller (SMC). Apparently it's just shutting down the computer and unplugging the mains cable, plugging it back in and starting the computer back again. I tried it and nothing happened, but I wonder if I did something wrong or if the process is more complex than that. I may have unplugged the wrong cable though, not very good with this type of stuff.

    d) Turning off the "mouse keys" option under the Acessibility section of System Preferences, which I already have turned off so...

    Since I started having this problem suddenly, I wonder if it's something software related, since there were some guides that said that was possible, and I installed some new applications recently.

    I'm using an iMac OS X El Capitan 10.11.6 by the way.
     
  2. ApolloBoy macrumors 6502a

    ApolloBoy

    Joined:
    Apr 16, 2015
    Location:
    San Jose, CA
    #2
    You know you can try different keyboards on an iMac, right? It sounds like your keyboard might be faulty.
     
  3. kiwipeso1 Suspended

    kiwipeso1

    Joined:
    Sep 17, 2001
    Location:
    Wellington, New Zealand
    #3
    It sounds like you either have gunk under those keys, or that those keys have water damage.

    If it is dirt / gunk, it is simple to just pop the keys and clean the area and then put the keys back.
    If it is water damage, then those keys are damaged permanently.
     

Share This Page