Resolved Fusion drive Partition trouble

Discussion in 'iMac' started by tplessers, Jan 4, 2013.

  1. tplessers, Jan 4, 2013
    Last edited: Jan 5, 2013

    tplessers macrumors newbie

    Jan 4, 2013
    Hi all,

    My iMac is equipped with a 3.0TB fusion drive:

    2013-01-04 20:07:48 +0100: 
    	Name : 	Macintosh HD
    	Type : 	Logical Volume Group
    	Disk Status : 	Online
    	Total Capacity : 	3,12 TB (3.120.722.075.648 Bytes)
    	Free Space : 	115 KB (114.688 Bytes)
    	Physical Backing : 	disk0s2,disk1s2
    Using Disk Utility, I splitted the partition in half using the +button, but after it resized, I ended up with a partition size that wasn't my original idea. Disk utility stated I could merge the partition back together by pressing the -button. Here I got an error:

    2013-01-04 23:37:20 +0100: Partition failed for disk APPLE HDD ST3000DM001 Media This operation couldn’t proceed because the target’s boot helper was mounted; you may want to try again.
    I'm now stuck with 1 partition of 1.2TB, and 1.8TB of free space. It won't create a new partition for me, and I can't resize the existing one. Verify/Repair Disk on the Macintosh HD drive states no issues.

    All I want is to have one big 3.0TB partition again. How should I proceed?

    To the command line : diskutil list

    Tims-iMac:~ Tim$ diskutil list
       #:                       TYPE NAME                    SIZE       IDENTIFIER
       0:      GUID_partition_scheme                        *3.0 TB     disk0
       1:                        EFI                         209.7 MB   disk0s1
       2:          Apple_CoreStorage                         1.2 TB     disk0s2
       3:                 Apple_Boot Recovery HD             650.0 MB   disk0s3
       #:                       TYPE NAME                    SIZE       IDENTIFIER
       0:      GUID_partition_scheme                        *121.3 GB   disk1
       1:                        EFI                         209.7 MB   disk1s1
       2:          Apple_CoreStorage                         121.0 GB   disk1s2
       3:                 Apple_Boot Boot OS X               134.2 MB   disk1s3
       #:                       TYPE NAME                    SIZE       IDENTIFIER
       0:                  Apple_HFS Macintosh HD           *1.3 TB     disk2
    and diskutil cs list gives:

    Tims-iMac:~ Tim$ diskutil coreStorage list
    CoreStorage logical volume groups (1 found)
    +-- Logical Volume Group BA85DD7A-BF5E-4BCC-A511-485FBF9F12DF
        Name:         Macintosh HD
        Size:         1318399279104 B (1.3 TB)
        Free Space:   24576 B (24.6 KB)
        +-< Physical Volume 7C342F88-576E-45E6-B97F-8A67AF6B9459
        |   ----------------------------------------------------
        |   Index:    0
        |   Disk:     disk1s2
        |   Status:   Online
        |   Size:     120988852224 B (121.0 GB)
        +-< Physical Volume 055B8A07-39F6-4338-922E-77EA03CA3550
        |   ----------------------------------------------------
        |   Index:    1
        |   Disk:     disk0s2
        |   Status:   Online
        |   Size:     1197410426880 B (1.2 TB)
        +-> Logical Volume Family BBB8E5DE-6E51-4D1F-A807-34F4191961F9
            Encryption Status:       Unlocked
            Encryption Type:         None
            Conversion Status:       NoConversion
            Conversion Direction:    -none-
            Has Encrypted Extents:   No
            Fully Secure:            No
            Passphrase Required:     No
            +-> Logical Volume 068215E6-3ACA-44C8-B160-8B52243D569E
                Disk:               disk2
                Status:             Online
                Size (Total):       1303868776448 B (1.3 TB)
                Size (Converted):   -none-
                Revertible:         No
                LV Name:            Macintosh HD
                Volume Name:        Macintosh HD
                Content Hint:       Apple_HFS
  2. brou macrumors newbie

    Dec 7, 2010
  3. tplessers thread starter macrumors newbie

    Jan 4, 2013
    I found the solution without reformatting :

    diskutil coreStorage resizeStack 068215E6-3ACA-44C8-B160-8B52243D569E 3079061004288B
    This resized my partition back to its original size, leaving all data intact.
  4. maveri8888, Jan 5, 2013
    Last edited: Jan 5, 2013

    maveri8888 macrumors newbie

    Feb 9, 2011
    EDIT : Just realized this post said "resolved", will start a new thread.
  5. iHaddock macrumors newbie

    Feb 4, 2013
    Singapore / UK

    I have exactly the same issue as the OP.

    Tried to add a partition to my 2013 3TB Fusion drive for my iPhoto library, asked for 200GB but it formatted to approximately 4 times this value.

    Went to delete the partition, and got an error message - now stuck with (something like) 1.2TB of "Free Space" which cannot be formatted/resized.

    Spent over 2 hours on the phone with Apple senior support, in recovery mode, internet recovery mode - you name it!

    No joy though, 3 different advisors are unable to fix the issue.

    What's the risk if I use the command stated earlier:

    diskutil coreStorage resizeStack 068215E6-3ACA-44C8-B160-8B52243D569E 3079061004288B

    Also - what is the 3079061004288B part?

    Any help greatly appreciated!

  6. Andrew*Debbie, Mar 13, 2013
    Last edited: Mar 13, 2013

    Andrew*Debbie macrumors member

    Nov 6, 2010
    North Wales, United Kingdom
    About 3tb in bytes.

    type man diskutil at a command prompt.

    see the SIZES section near the end for more.

    3079061004288b is not the same as 3T or 3Ti
  7. iHaddock macrumors newbie

    Feb 4, 2013
    Singapore / UK
    Thanks Andrew.. I think your correct, and now you've pointed it out it's logical!!

    Think I'm going to clone my drive and give this a go tomorrow.
  8. Foxer macrumors 65816


    Feb 22, 2003
    Washington, DC
    I've got the exact same problem it seems. I was trying to install boot camp, but the process froze during the partitioning stage and now I'm left with a dead partition that I can't do anything with and can't delete.

    So how do I use that command line? Type it into Terminal?
  9. iHaddock macrumors newbie

    Feb 4, 2013
    Singapore / UK
    Update from me on this - Apple say my issue cant be fixed via terminal, and have offered a replacement machine...
  10. tuma macrumors newbie

    Mar 28, 2013
    I got the same problem too... decided to split my 1tb fusiondrive into two partitions, now im stuck with 620gb of free space :/ have anyone got a solution for this? I cant delete the free space and make 1 partition again. been trying ipartition, recovery disk utility, terminal diskutil no luck so far :(
  11. iVoid macrumors 65816

    Jan 9, 2007
    I had a imac with Fusion drive get corrupted and fixed it.

    What I ended up doing is to boot the iMac with fusion drive up into target disk mode (T at startup), connect it via thunderbolt or tb-firewire cable to a Snow Leopard Mac.

    On the SL Mac use Disk utility to partition each physical drive with a single GUID partition.

    Reboot the iMac into internet recovery (Command-R) mode and goto the
    Disk Utility.

    It should complain that the fusion drive is broken and offer to fix it. Allow it and you should be all set (reinstall ML of course after).
  12. Serban Suspended

    Jan 8, 2013
    So if you want 2 partitions i guess the best way is to make a boot camp for windows. You let around 300GB for MacOs partition and the rest for windows. When you want your full partition back you can delete windows bootcamp and you are in 1 partition again. I don't know if you want 3 partitions how is the best way..without to have problems lately
  13. asupergav macrumors newbie

    Feb 3, 2011
    I have the exact same problem as tplessers. This seems to be a common problem with the Fusion Drive. I, too, am desperate to know what tplessers entry "3079061004288B" is and how to find it for my disk. Many thanks.
  14. gnasher729 macrumors P6


    Nov 25, 2005
    3079061004288B would be the size of whatever he was doing in Bytes (that's what the B stands for). You can specify size in B(ytes), K(ilobytes) = 1000 bytes), M = million, G = billion, T = trillion, Ki = 1024, Mi = 1024 x 1024, Gi = 1024 x 1024 x 1024.

    Disk Utility would give you sizes of disks, partitions and so on.
  15. asupergav macrumors newbie

    Feb 3, 2011
    Many thanks for your reply gnasher729. I understood that the numbers related to the size of his hard drive. But I was wondering whether the specific figure he quotes at the end was taken from somewhere in his system or whether it is an arbitrary figure. It is very specific which led me to believe that he may have got it from specifications he does not quote. I have been trying to find a similar figure from my system but to no avail. If it is an arbitrary figure, then presumably I can enter an appropriate figure when I write my Terminal commands?
  16. asupergav macrumors newbie

    Feb 3, 2011
    Many thanks for taking the time to reply, Gnasher729. I previously tried inputing 3079061004288B at the end of my specific Terminal commands (since I, too, have a 3TB HD) but I got a Terminal message to try another size which is why I posted on this thread. I have just tried again after leaving it a couple of hours and this time it worked!

Share This Page