G5 Twitches, Won't fully boot

Discussion in 'PowerPC Macs' started by Mac03ForLife, Jun 6, 2018.

  1. Mac03ForLife macrumors regular

    Mac03ForLife

    Joined:
    Sep 19, 2017
    Location:
    Washington, DC
    #1
    Hello!
    This is unusual, considering I generally can help most people

    Anyways
    I was reconfiguring my workshop last night, and after not booting my PMacG5 for close to 2 months, I decided I would hit the button and see what happens. As it turns out, it clicks, the fans twitch, but it won't get further than that.

    I removed and reseated the RAM, fans, and CMOS battery, checked the CMOS battery, (it's pretty good), and put everything back.

    What I have not tried is reseating processors, power supply connectors, etc

    I have removed the HDD in the assumption that constantly trying to hit power would not be good for it

    Please send help quickly, I need this machine to work for tomorrow ;)
     
  2. z970mp macrumors 65816

    z970mp

    Joined:
    Jun 2, 2017
    #2
    Try reseating the processors and power supply connectors.
     
  3. Mac03ForLife thread starter macrumors regular

    Mac03ForLife

    Joined:
    Sep 19, 2017
    Location:
    Washington, DC
  4. RhianB macrumors 6502a

    RhianB

    Joined:
    Sep 3, 2016
    Location:
    505 USA
    #4
    Try resetting the PMU. The process is below.

    https://support.apple.com/en-us/HT1436

    Another thing to try is to unplug everything from the box, completely discharg any stored electricity by holding the power button for 5-10 seconds & let it sit for a few hours up to overnight - then plug it back in & give it a try.

    The thought being that a cap in the psu is going bad so draining everything may help you to get it started long enough to use & then swap out with a new psu.

    Best of luck. Mine did the same - got it started a few times but ultimately a new psu fixed it.
     

Share This Page