GCC -- C compiler OS 10.6 (snow leopard)

Discussion in 'Mac Programming' started by Lolmaniac, Oct 5, 2009.

  1. Lolmaniac macrumors newbie

    Oct 5, 2009
    Help me please, I cant compile C in my snow leopard.

    I`ve already installed Xcode Tools, it worked fine in 10.5 but I updated to 10.6, and I tried to download the new version of the Xcode Tools (3.14), and the gcc compiler doesn`t work anymore.

    I use the terminal to compile, and now, when I type gcc, the terminal shows me a msg: -bash: gcc: command not found.

    PS: I work with C and not obj-C.
  2. gnasher729 macrumors P6


    Nov 25, 2005
    That's not the new version of XCode. Current XCode version is 3.2. And maybe you should use XCode directly so you get clang + LLVM for better code, better error messages, and faster compile times.
  3. electroshock macrumors 6502a


    Sep 7, 2009
    Uninstall any existing Xcode installations. Then insert your Snow Leopard install DVD, go to Optional Tools folder, and install Xcode.
  4. FineTuner macrumors newbie

    Jul 6, 2011
    Thanks to Lolmaniac for posting the question, and for electroshock's reply. You guys made my life easier :D

Share This Page