"Get mail" on IMAP mail account on Mac won't fetch new mail

Discussion in 'macOS' started by AZRob, Jul 24, 2013.

  1. AZRob macrumors member

    Joined:
    Jul 9, 2011
    #1
    All,

    I just switched from a POP email account to an IMAP account on my Mac Mini running Mountain Lion. I am using the same ISP for IMAP that I used for POP, which is COX (Phoenix). I also switched to IMAP on my iPhone 5.

    Everything works great on the iPhone. However on the Mac my "Get Mail" button doesn't have any effect nor does "Get New Mail" work. The Mac just beeps at me as if to say either there is no mail to fetch or something is wrong with your request. If I restart Mail, it will fetch and if I just take the account offline and then online it will fetch. Plus I can send mail.

    All settings are normal per COX. I spent an hour with them on the phone and they couldn't find anything wrong. Plus the fact that it works on the iPhone seems to indicate (to COX at least) that the issue is my Mac.

    The problem on the Mac is systemwide - I get the same issue with a different user account as well.

    Now here's the funny part - once in a while I do get email from COX. But it doesn't happen that often. Right now its been 2 hours since I last got mail although there are messages waiting to be delivered.

    So maybe the COX server does push out every once in a while, but the real issue is "why can't I initiate a pull from my Mac"?

    Has anybody seen this?

    thanks,

    Rob from AZ
     
  2. jwjsr macrumors 6502

    jwjsr

    Joined:
    Mar 15, 2012
    Location:
    Fairhope, Alabama
    #2
    I have a similar prob with Mac mail. Sometimes new inbox msgs do not show/download. I haven't looked into it yet as I just go to gmail when I notice.
     
  3. johncrab macrumors 6502

    johncrab

    Joined:
    Aug 11, 2011
    Location:
    Scottsdale, AZ
    #3
    Cox is going to call this a Mac problem but I use IMAP accounts from various providers in Mac Mail without any problems. BUT, I am seeing the exact same problem you describe. The only way to use Cox's IMAP with Mail is to quit Mail and re-launch mail each time you want to fetch new mail. That's the only thing that works. The Mac going to sleep and waking up won't even do it. There may be something Apple can do in Mail to make it work with this goofy system, but I've gone back to the POP settings and have given up on IMAP through Cox. It just doesn't work.
     
  4. AZRob thread starter macrumors member

    Joined:
    Jul 9, 2011
    #4
    I have an open case with Apple right now. At the engineers' request I have sent them trace logs run while replicating the issue. It appears they are working on it.
     
  5. AZRob thread starter macrumors member

    Joined:
    Jul 9, 2011
    #5
    Hi all,

    Just wanted to report that things seem to be moving along. I have an open ticket with COX support and today they told me that this issue has become very known to COX. In fact, they have "a whole department" working on fixing it. So what was unknown 6 weeks ago ago has now become a big enough deal that a group in the Atlanta Cox corporate office is working on it. The name of the group or team or department, whatever it is, is ATLROC20547.

    Stay tuned,

    Rob
     
  6. matt2053 macrumors 6502a

    Joined:
    Jul 8, 2012
    #6
    I used to have many of the problems described in this thread. Then I tried these steps and it worked!

    1. Remove troublesome mail account or accounts
    2. Quit Mail.app
    3. Move this file to the trash: ~/Library/Containers/com.apple.mail/Data/Library/Preferences/com.apple.mail.plist
    4. Start Mail.app
    5. Add the mail accounts back

    This worked for me. I thought I'd at least offer it as a possibility you can try if frustrated. If it causes a problem you can restore the file from the trash.
     
  7. AZRob thread starter macrumors member

    Joined:
    Jul 9, 2011
    #7
    Hi Matt,

    Thank you for that. I tried it and at first it may have worked - I'm not sure, because a lot of emails came in at the same time. But after 10 minutes it was back to the same old behavior. Interestingly, when I first created the account the IDLE was unchecked...but after a few restarts of the client, it was grayed out again with IDLE checked. In the Preferences for your Mail account is the IDLE grayed out and/or checked?

    Rob
     
  8. matt2053 macrumors 6502a

    Joined:
    Jul 8, 2012
    #8
    Mine looks like this.
     

    Attached Files:

  9. AZRob thread starter macrumors member

    Joined:
    Jul 9, 2011
    #9
    Two things:

    1. I noticed that the one person who replied that they were having the same problem, is, like me, living in Scottsdale, Arizona. Coupled with the fact that at least SOME, if not most are not having this problem, I am beginning to wonder if this is tied to a local Cox server. After all, this is a national forum and yet I see no one yet who has the issue showing up who is not in Scottsdale.

    If there is anyone out there who is in Scottsdale reading this and is using the Mac Mail client with Cox, could they please chime in and let us know if they are successful or not? For what it's worth, I took my Mac from zip coded 85255 to 85259, still in Scottsdale and had the same problem. Both are in North Scottsdale.

    Thanks,

    Rob

    ----------

    I stand corrected. This poster is from Alabama, though obviously they are not a Cox customer. Jwjsr, who is your ISP, may I ask?
     
  10. satcomer, Oct 13, 2013
    Last edited: Oct 13, 2013

    satcomer macrumors 603

    satcomer

    Joined:
    Feb 19, 2008
    Location:
    The Finger Lakes Region
    #10
    I the Cox ISP in NVA and have tried their IMAP service before and it was a disaster. There techs said even on their Windows machines the IMAP function of Cox was not setup right. When I asked if this could be fixed the Cox tech said he has been trying to get this fixed for over 3 years with no luck.

    Plus I found a Cox email setup page in Phoenix: Phoenix Cox - Set IP an Email Account in Mail for Mac OS X.
     
  11. jwjsr macrumors 6502

    jwjsr

    Joined:
    Mar 15, 2012
    Location:
    Fairhope, Alabama
    #11
    AT&T , mine is working fine now, but I didn't find out what the problem was.
     
  12. AZRob thread starter macrumors member

    Joined:
    Jul 9, 2011
    #12
    Thanks, satcomer, for the setup page but I have used that many times and my settings are always correct.

    I am curious - when you used the IMAP service before, was it as a Business customer? I would like to know if this issue preceded the Retail rollout.

    Rob
     
  13. satcomer macrumors 603

    satcomer

    Joined:
    Feb 19, 2008
    Location:
    The Finger Lakes Region
    #13
    No I am just a plain customer. This only happened a year ago.
     
  14. AZRob thread starter macrumors member

    Joined:
    Jul 9, 2011
    #14
    Oh, I didn't know that other Cox areas got Residential IMAP sooner than we did. We just got it in June. I thought it was just rolled out nationwide then.

    Did the Cox techs give you any idea what the issue was that you can recall? Your report is the first time I have heard of anyone at Cox admitting that they were part of the problem. Did they have any theory as to why some users have the problem and not others? I am guessing that maybe some servers are better configured or resourced than others.....

    Rob
     
  15. satcomer macrumors 603

    satcomer

    Joined:
    Feb 19, 2008
    Location:
    The Finger Lakes Region
    #15
    At the time Cox in Northern Virginia (about late 2011 and they called it a "Beta Test"). It setup but for some reason would only let Mail connect only every 10 minutes. So If I opened Mail and connected to the Cox IMAP server it would act fine. However if i was manually checking the server 7 minutes later it would not connect. Then it would error out for about 4 hours.

    So when i was talking to phone tech (on a Saturday afternoon) he gave me the skinny on his problems with the IMAP service also. I was thinking that was very good for him to share that so that is why I'll never release the tech's name. I want the person to keep their job.

    I just know their DNS server was centrally located somewhere in central part of the country. So when I switched to OpenDNS (instructional video) and my Internet starting acting faster when going from page to page. This really convinced my not to try their IMAP again and switched to Apple & Google for email. YMMV.
     
  16. Jack M. macrumors newbie

    Joined:
    Dec 1, 2013
    #16
    I have the exact same issue and live in Scottsdale. Spent quite a bit of time with both Apple and Cox. Cox says it isn't their problem and Apple says the same.

    The work around that Apple gave me was to take the email account offline and then back online instead of closing mail and restarting it. You can put a button on your tool bar that takes you off/on line so it is two clicks. Welcome to 1995!

    It is worth the hassle to get the benefits of IMAP but it is frustrating.
     
  17. jwjsr macrumors 6502

    jwjsr

    Joined:
    Mar 15, 2012
    Location:
    Fairhope, Alabama
    #17
    I'm with AT&T in Alabama. I was having Mac mail problems as you describe. About 2 months ago I called apple an tech remotes in and deleted my pop gmail account and also did some other pretty complicated stuff I couldn't follow. It helped but evidently pop gmail was not the whole problem as my mail is late and weird on the Mac . Gmail on iPhone is fine. I might call AppleCare back on this
     
  18. AZRob thread starter macrumors member

    Joined:
    Jul 9, 2011
    #18
    Jwjsr,

    This thread is devoted to people having difficulty with the IMAP protocol. I don't think any of us had issues with Cox when using POP. Are you sure you are using POP?

    Rob
     
  19. jwjsr macrumors 6502

    jwjsr

    Joined:
    Mar 15, 2012
    Location:
    Fairhope, Alabama
    #19
    I'm apologize for not making myself clear, the apple tech deleted my gmail pop account so I am now on gmail Imap.
     
  20. jwjsr macrumors 6502

    jwjsr

    Joined:
    Mar 15, 2012
    Location:
    Fairhope, Alabama
    #20
    I called AppleCare again on this because my IMAP gmail inbox was not fetching timely. They had me delete the google gmail account under mail preferences /accounts. They then had me add it back and now my inbound email is working/fetching instantaneously as it should. I will watch it tomorrow to ensure it is still behaving, if not I will report back.
     
  21. AZRob thread starter macrumors member

    Joined:
    Jul 9, 2011
    #21
    So, just to clarify…are you using Gmail only, Cox only, or a combination, for example, with the Cox mail coming to you via Gmail? The last option should work..it's just not direct from Cox.
     
  22. jwjsr macrumors 6502

    jwjsr

    Joined:
    Mar 15, 2012
    Location:
    Fairhope, Alabama
    #22
    On my mac mini I am using osx 10.9 w/Mail version 7.0. I have 2 email accounts set up in osx mail, Gmail and iCloud. My ISP is AT&T.
     
  23. AZRob thread starter macrumors member

    Joined:
    Jul 9, 2011
  24. AZRob thread starter macrumors member

    Joined:
    Jul 9, 2011
    #24
  25. AZRob thread starter macrumors member

    Joined:
    Jul 9, 2011
    #25
    Okay, so I called Apple about this latest development and this is what the representative told me (paraphrasing):

    "Apple acknowledges there is a problem and they have narrowed it down to "just a few" providers - not just Cox. The engineers are aware of this issue and they are looking into it. We no longer report this issue to them because they are already working on it."

    I asked, does this mean that Apple is attempting to fix the problem, that it is not just a case of "it's the providers' fault and we can't fix it"? The representative said "Yes".

    So, take that for whatever it's worth. After all, I was told last summer that "the engineers are looking into it" and nothing came back but fingerpointing at Cox. So let's hope that what I was told is in fact the case, that they are looking into it again with the intention of fixing it.

    Rob
     

Share This Page