Getting Error (21) Stuck in Recovery mode

Discussion in 'Jailbreaks and iOS Hacks' started by raichu06, Nov 23, 2008.

  1. raichu06 macrumors newbie


    Nov 23, 2008
    San Antonio/Austin Texas
    Ok so I followed the steps on various web pages and on the forum in order to upgrade to 2.2 and jailbreak. Everything in pwnagetool 2.2 was going well put it in expert mode, booted it up to 1000, built the ipsw. Restored phone, put it into recovery mode, option clicked "restore" selected ipsw built from pwnage and it starts up then, "iphone could not be restored an unknown error (21) occured" rebuilt the ipsw twice now and still the same thing. I don't know what else to do I am stuck and desperate for a solution =[ Please help :(
  2. tjpoch macrumors member


    Apr 5, 2008
  3. eyesicksun macrumors newbie

    Jun 20, 2007
    Same problem here

    Here's some more details.

    Basically, my 2g iphone (tmobile) was running on Pwnage 1.1, and I tried to update to 2.2 by following these directions:

    Everything went smoothly in Pwnage, and I put the phone into recovery mode, as the directions above instructed. When I went to go restore the iphone with my custom ipsw an error message came up in iTunes "The iPhone "iPhone" could not be restored. An unknown error occurred (21). I tried several more times without any luck, used a different USB, reinstalled the IPSW... nada.

    My main concern now is that I am stuck in recovery mode, and haven't been able to find a way to get out of it. I've gone through dozens of threads and have come up empty handed. The normal reboot does not work (holding down power and home), and it just keeps popping back up in recovery mode. I tried using iNdependence (I use a Macbook Pro.. not the newest model), as some threads suggested, but it doesn't recognize a phone being connected. I think I might have gotten the phone into DFU mode one time, but I'm not quite sure what I did, and it quickly went back to recovery mode. (When it was in DFU I tried to restore, and it came up with the error message "The iPhone "iPhone" could not be restored. An unknown error occurred (1600)"

    If someone can help us out with this, I'll be forever grateful.


  4. andyblila macrumors 65816


    Jul 8, 2008
    On My iPhone, or my iPad?
    I would head over to iClarified and follow the instructions there.
  5. jav6454 macrumors P6


    Nov 14, 2007
    1 Geostationary Tower Plaza
    I see 2 mistakes here.

    You are not supposed to have the root partition at 1000MB. 600MB is fine. (unless you are downloading loads of applications from Cydia/Installer)

    Another problem is that you need to use DFU mode, not Restore mode.
  6. jzjz macrumors newbie

    Dec 4, 2008
    i use 2G iphone and upgrade from 2.0 pwnage tool.
    i was stucked in the recovery mode stated that an error (21) as well.
    i tried to do follow those instructions from people here.
    and finally i done it. 2.2 version

    what i have done is :
    1. i restore with itunes original firmware.
    2. in pwnage , i went to expert mode then change the capacity in General mode to exactly 1,000.
    then create new firmware with pwnage as normal.
    3. i do the DFU mode again.
    4. restore the iphone with the new firmware as normal.

    and that's it.

    at first , i still have stucked in recovery mode when i changed the capacity to >1000 and also not doing the DFU mode yet.
    so i think if you do DFU mode again , that should fixed yr error (21).
    because my iphone had been unlocked before so i didnt do DFU mode at the beginning.

    hope it helps....
    thx for every posts ,,,, u helped me from becoming nuts...... fixing the iphone from error (21)
  7. pienaarteta macrumors newbie

    Oct 14, 2008
    So I need to download an early version of itunes to perform a restore to basic? I can't get DFU as it doesn't detect my ipod.

    What firmware is the default. I bought iPOD Nov 07 so is this 1.3

Share This Page