Giving Dictionary permanent permission to open

Discussion in 'macOS Sierra (10.12)' started by JohnDohe, Mar 14, 2017.

  1. JohnDohe macrumors member

    Joined:
    Jul 17, 2013
    Location:
    Mac OS Extended (Journaled) ???
    #1
    Hi,

    I'm on Sierra 10.12.3 (16D32).

    Whenever I hi-lite a word, right-click, and choose "Search Dictionary"
    I'm presented with a dialog box to allow or cancel this request:
    "Do you want to allow this page to open “Dictionary”?"

    Here's a screenshot:

    Screen Shot 2017-03-14 at 1.15.44 PM   Tuesday  3-14-17.png

    Why?

    Why, if Dictionary is an Apple product embedded in the Sierra OS,
    why should I have to grant it permission to open everytime!?

    How to turn this off?

    How to permanently allow Dictionary to simply look up selected words?

    Thanks!
     
  2. stradify macrumors member

    Joined:
    Jul 4, 2015
    Location:
    USA
    #2
    Try adding Apple's Dictionary to your Login Items in system preferences under Accounts.
    That way Dictionary will always be open. That's what I did since it's also necessary to do so in order to find the definition of a word.
    With the cursor over the word, whose definition you're wanting, use Command-Option-D to get the definition.
    This will only work if Dictionary is open.
     
  3. DeltaMac macrumors 604

    DeltaMac

    Joined:
    Jul 30, 2003
    Location:
    Delaware
    #3
    My Mac on Sierra does not show a choice to "Search Dictionary", when right-clicking a highlighted "word".
    It DOES have a right-click choice to 'Look up "word"'
    Is that what you meant?

    If not, what app are you using when you see that dialog box?
    Maybe you are using an app that has options to use other dictionaries, such as MS Office.
     
  4. BarracksSi Suspended

    BarracksSi

    Joined:
    Jul 14, 2015
    #4
    I've never seen a dialog box like that.

    Right-click then 'Look up "word"' is available just like DeltaMac said. Three-finger tap on a word also brings up a dictionary & thesaurus popup. The newer Force Touch trackpads can also invoke the dictionary & thesaurus with a hard press.

    OP, I think you're describing a web page that wants to open the Dictionary app. This action isn't part of macOS.
     

    Attached Files:

  5. JohnDohe thread starter macrumors member

    Joined:
    Jul 17, 2013
    Location:
    Mac OS Extended (Journaled) ???
    #5
    To all:

    Thanks for your thoughts and suggestions!

    All: please see the attached screenshots:
    One shows my context menu after hi-liting "describing" and right-clicking it.
    The other shows the Sierra Dictionary app appearing after I clicked "Allow".

    @ stratify : tried your suggestion: doesn't work. I still have to "Allow" dictionary when I select
    "Search Dictionary" from my right-click context menu after hi-liting a word.

    @ Delta Mac : I have "look up (word)" in the context menu. But thats not what I'm talking about.
    In my screenshot you can see "Search Dictionary".

    @ BaracksSi : see my latest screenshots. I have "Search Dictionary" as an option in my context menu.
    And, nope, its not a web page that wants to pull up the dictionary app, to the best of my understanding.
    From my screenshots might you have another understanding of what I'm getting and another solution?

    Here are my screenshots:

    Screen Shot 2017-03-15 at 9.13.25 PM   Wednesday  3-15-17.png

    Screen Shot 2017-03-15 at 9.13.49 PM   Wednesday  3-15-17.png



    Many thanks to all! :)

    Hopefully someone will be able to provide a solution! :)
     
  6. BarracksSi Suspended

    BarracksSi

    Joined:
    Jul 14, 2015
    #6
    Is that a different utility or maybe a browser plugin? I have none of those options.
     
  7. JohnDohe thread starter macrumors member

    Joined:
    Jul 17, 2013
    Location:
    Mac OS Extended (Journaled) ???
  8. DeltaMac macrumors 604

    DeltaMac

    Joined:
    Jul 30, 2003
    Location:
    Delaware
    #8
    Yes, looks like a plugin or extension of some kind.
    I can't tell from your screen shot - Which browser are you using?
    You have something installed that expands your contextual menu. The menu you show is much longer than standard, which has nothing at all between "Speech", and "Inspect Element"

    Do you ALSO need to give permission to Dictionary if you simply choose "Look Up (word)" at the top of your menu?

    Could be that whatever you have used to change your contextual menus is not quite compatible with Sierra.

    You MIGHT find out what that is if you download and run EtreCheck. Post the result here, which might give someone here a clue about what is happening for you.
     
  9. BarracksSi Suspended

    BarracksSi

    Joined:
    Jul 14, 2015
    #9
    The reason I said right away that this isn't a macOS thing is, that dialog box in your screenshot is what pops up in a browser window via an alert command from a webpage (Javascript or some related code).

    Does the contextual menu give you the same options when you invoke it in any other app, like Mail or Notes or whatever?

    What browser are you using when this happens?
     
  10. BarracksSi Suspended

    BarracksSi

    Joined:
    Jul 14, 2015
    #10
    There's also this: http://www.chriswrites.com/how-to-customise-the-right-click-menu-in-mac-os-x/ ...but I don't think you've set up the contextual menu using this method.

    What's happening is [or what my best guess is], macOS's built-in security is asking your permission to allow a webpage to open an app. This is meant to avoid malicious webpage scripts from launching an app and executing a preprogrammed task (such as, say, opening Address Book, exporting all your contacts' info, and uploading it to God-knows-where).

    Your other options in your contextual menu -- Google, Wikipedia, Amazon, TinEye, YouTube, and IMDb -- are just web pages, not apps, and the browser can automatically redirect to them. Dictionary, however, isn't a web page (at least, not in this case), and the browser needs you to confirm that, yes, you want to open an application residing on your computer (which, here, is Dictionary).

    I really don't think you're going to be able to bypass this. The browser isn't going to store a cookie referencing that page to allow all future "open Dictionary" requests (or it shouldn't, anyway, because a once-safe page can be changed to become malicious), and you'll still get the dialog box each time you choose this command on a different web page.

    If you choose "Look up 'word'" instead, you'll get a little Dictionary-and-Thesaurus popup like you see in the screenshot I posted. It's not opening the Dictionary app in the foreground.
     
  11. JohnDohe thread starter macrumors member

    Joined:
    Jul 17, 2013
    Location:
    Mac OS Extended (Journaled) ???
    #11
    @ Delta Mac : using Safari. "Do you ALSO need to give permission to Dictionary if you simply choose "Look Up (word)" at the top of your menu?" Answer: no.
    EtreCheck results:
    EtreCheck version: 3.1.5 (343)

    Report generated 2017-03-16 13:03:50

    Download EtreCheck from https://etrecheck.com

    Runtime 2:09

    Performance: Excellent



    Click the [Support] links for help with non-Apple products.

    Click the [Details] links for more information about that line.



    Show signature failures: Enabled



    Problem: No problem - just checking



    Hardware Information:

    Mac mini (Late 2012)

    [Technical Specifications] - [User Guide] - [Warranty & Service]

    Mac mini - model: Macmini6,2

    1 2.6 GHz Intel Core i7 (i7-3720QM) CPU: 4-core

    16 GB RAM Upgradeable - [Instructions]

    BANK 0/DIMM0

    8 GB DDR3 1600 MHz ok

    BANK 1/DIMM0

    8 GB DDR3 1600 MHz ok

    Bluetooth: Good - Handoff/Airdrop2 supported

    Wireless: Unknown

    Video Information:

    Intel HD Graphics 4000

    LG FULL HD 1920 x 1080


    System Software:

    macOS Sierra 10.12.3 (16D32) - Time since boot: about one day


    Disk Information:

    Samsung SSD 840 Series disk0 : (500.11 GB) (Solid State - TRIM: No)

    [Show SMART report]

    EFI (disk0s1) <not mounted> : 210 MB

    MAC (disk0s2) / [Startup]: 499.25 GB (175.98 GB free)

    Recovery HD (disk0s3) <not mounted> [Recovery]: 650 MB


    USB Information:

    Composite USB PS2 Converter USB to PS2 Adaptor V2.50

    Apple, Inc. IR Receiver

    Apple Inc. BRCM20702 Hub

    Apple Inc. Bluetooth USB Host Controller

    DYMO DYMO LabelWriter 450

    MediaTek Inc MT1887


    Thunderbolt Information:

    Apple Inc. thunderbolt_bus


    Configuration files:

    /etc/sysctl.conf - File exists but not expected


    Gatekeeper:

    Mac App Store and identified developers


    Unknown Files:

    ~/Library/LaunchAgents/co.iristech.Iris.plist

    ~/Downloads/Iris.app/Contents/MacOS/Iris

    One unknown file found. [Check files]


    Kernel Extensions:

    /Library/Application Support/LogMeIn/drivers

    [loaded] com.logmein.driver.LogMeInSoundDriver (4.1.7559 - 2017-01-24) [Support]



    /Library/Application Support/org.pqrs/Karabiner

    [loaded] org.pqrs.driver.Karabiner (10.22.0 - SDK 10.12 - 2016-11-20) [Support]



    /Library/Extensions

    [loaded] com.globaldelight.driver.Boom2Device (1.2 - SDK 10.10 - 2017-02-16) [Support]

    [loaded] jp.plentycom.driver.SteerMouse (4.2.3 - SDK 10.6 - 2017-02-16) [Support]



    /System/Library/Extensions

    [not loaded] com.Belcarra.iokit.USBLAN_netpart (2.0.2 - 2017-02-16) [Support]

    [not loaded] com.Belcarra.iokit.USBLAN_usbpart (2.0.2 - 2017-02-16) [Support]

    [not loaded] com.Logitech.Control Center.HID Driver (3.7.0 - SDK 10.6 - 2017-02-16) [Support]

    [not loaded] com.Logitech.Unifying.HID Driver (1.3.0 - SDK 10.6 - 2017-02-16) [Support]

    [not loaded] com.RemoteControl.USBLAN.usbpart (2.0.6 - 2017-02-16) [Support]

    [not loaded] com.devguru.driver.SamsungComposite (1.4.20 - SDK 10.6 - 2017-02-16) [Support]

    [not loaded] com.dymo.usbprinterclassdriver.kext (1.1 - SDK 10.10 - 2017-02-16) [Support]



    /System/Library/Extensions/Belcarra.USBLAN_netpart.kext/Contents/PlugIns

    [not loaded] com.belcarra.iokit.netpart.panther (1.6.1 - 2007-06-06) [Support]



    /System/Library/Extensions/Belcarra.USBLAN_usbpart.kext/Contents/PlugIns

    [not loaded] com.belcarra.iokit.usbpart.panther (1.6.1 - 2007-06-06) [Support]



    /System/Library/Extensions/RemoteControl.USBLAN_usbpart.kext/Contents/PlugIns

    [not loaded] com.RemoteControl.USBLAN.panther (1.6.1 - 2007-06-06) [Support]



    /System/Library/Extensions/ssuddrv.kext/Contents/PlugIns

    [not loaded] com.devguru.driver.SamsungACMControl (1.4.20 - SDK 10.6 - 2014-03-10) [Support]

    [not loaded] com.devguru.driver.SamsungACMData (1.4.20 - SDK 10.6 - 2014-03-10) [Support]

    [not loaded] com.devguru.driver.SamsungMTP (1.4.20 - SDK 10.5 - 2014-03-10) [Support]

    [not loaded] com.devguru.driver.SamsungSerial (1.4.20 - SDK 10.6 - 2014-03-10) [Support]



    System Launch Agents:

    [loaded] com.apple.LocalAuthentication.UIAgent.plist (2017-01-13)

    [loaded] com.apple.NowPlayingTouchUI.plist (2017-02-16)

    [loaded] com.apple.accessibility.dfrhud.plist (2016-12-19)

    [loaded] com.apple.controlstrip.plist (2017-02-16)

    [loaded] com.apple.eosauthagent.plist (2017-01-13)

    [loaded] com.apple.eospreflightagent.plist (2017-01-13)

    [loaded] com.apple.imautomatichistorydeletionagent.plist (2017-02-16)

    [loaded] com.apple.screencapturetb.plist (2017-02-16)

    [loaded] com.apple.touchbar.agent.plist (2017-02-16)

    [not loaded] 7 Apple tasks

    [loaded] 163 Apple tasks

    [running] 101 Apple tasks


    System Launch Daemons:

    [loaded] com.apple.biokitaggdd.plist (2016-12-10)

    [loaded] com.apple.biometrickitd.plist (2017-01-13)

    [loaded] com.apple.eoshostd.plist (2017-01-13)

    [loaded] com.apple.installer.osmessagetracing.plist (2017-01-13)

    [loaded] com.apple.nfcd.plist (2017-01-13)

    [loaded] com.apple.nfrestore.plist (2017-01-13)

    [loaded] com.apple.seld.plist (2017-01-13)

    [loaded] com.apple.touchbar.user-device.plist (2017-02-16)

    [loaded] com.apple.xartstorageremoted.plist (2016-12-10)

    [running] org.cups.cupsd.plist (2017-01-13)

    [loaded] org.postfix.master.plist (2016-12-10)

    [not loaded] 37 Apple tasks

    [loaded] 166 Apple tasks

    [running] 98 Apple tasks


    Launch Agents:

    [running] com.Logitech.Control Center.Daemon.plist (2013-07-13) [Support] - Invalid signature!

    [running] com.brother.LOGINserver.plist (2013-04-20) [Support] - No signature!

    [loaded] com.divx.dms.agent.plist (2017-01-13) [Support] - Invalid signature!

    [loaded] com.divx.uninstall.converter.plist (2016-12-26) - Shell script!

    [loaded] com.divx.uninstall.player.plist (2016-12-26) - Shell script!

    [loaded] com.divx.uninstall.preferences.plist (2016-12-26) - Shell script!

    [loaded] com.divx.update.agent.plist (2017-01-13) [Support]

    [running] com.dymo.dls.webservice.plist (2016-05-27) [Support] - No signature!

    [loaded] com.google.keystone.agent.plist (2017-01-13) [Support]

    [loaded] com.hp.help.tocgenerator.plist (2013-03-09) [Support] - No signature!

    [not loaded] com.logmein.logmeingui.plist (2017-01-24) [Support]

    [not loaded] com.logmein.logmeinguiagent.plist (2017-01-24) [Support]

    [not loaded] com.logmein.logmeinguiagentatlogin.plist (2017-01-24) [Support]

    [loaded] com.oracle.java.Java-Updater.plist (2017-02-24) [Support] - No signature!

    [failed] com.realvnc.vncserver.peruser.plist (2014-04-01) [Support] - /Library/vnc/vncserver_service_agent.app/Contents/MacOS/vncserver_service_agent: Executable not found!

    [not loaded] com.realvnc.vncserver.prelogin.plist (2014-04-01) [Support] - /Library/vnc/vncserver_service_agent.app/Contents/MacOS/vncserver_service_agent: Executable not found!

    [failed] com.redstonesoftware.VineServer.plist (2012-02-12) [Support] - No signature!

    [failed] com.teamviewer.teamviewer.plist (2015-04-18) [Support] - /Applications/TeamViewerHost.app/Contents/MacOS/TeamViewerHost: Executable not found!

    [failed] com.teamviewer.teamviewer_desktop.plist (2015-04-18) [Support] - /Applications/TeamViewerHost.app/Contents/Helpers/TeamViewer_Desktop: Executable not found!

    [not loaded] net.culater.SIMBL.Agent.plist (2014-08-04) [Support] - No signature!


    Launch Daemons:

    [loaded] com.adobe.fpsaud.plist (2017-02-28) [Support] - No signature!

    [not loaded] com.dymo.pnpd.plist (2016-01-28) [Support] - Invalid signature!

    [loaded] com.google.keystone.daemon.plist (2017-02-08) [Support]

    [not loaded] com.logmein.logmeinserver.plist (2017-01-24) [Support]

    [loaded] com.malwarebytes.HelperTool.plist (2016-11-28) [Support]

    [running] com.microsoft.autoupdate.helper.plist (2017-03-09) [Support]

    [loaded] com.microsoft.office.licensing.helper.plist (2016-11-29) [Support] - No signature!

    [loaded] com.microsoft.office.licensingV2.helper.plist (2015-08-15) [Support]

    [loaded] com.oracle.java.Helper-Tool.plist (2016-12-13) [Support] - Shell script!

    [loaded] com.realvnc.vncserver.plist (2014-04-01) [Support] - /Library/vnc/vncserver_service_daemon: Executable not found!

    [running] com.siber.gs-server.plist (2016-05-06) [Support]

    [loaded] com.spyresoft.dockmodhelper.plist (2014-05-17) [Support] - Invalid signature!

    [loaded] com.teamviewer.Helper.plist (2015-04-18) [Support]

    [failed] com.teamviewer.teamviewer_service.plist (2015-04-18) [Support] - /Applications/TeamViewerHost.app/Contents/MacOS/TeamViewer_Service: Executable not found!

    [failed] com.vmware.launchd.vmware.plist (2008-11-12) [Support] - /Library/Application Support/VMware Fusion/boot.sh: Executable not found!

    [not loaded] org.pqrs.Karabiner.load.plist (2016-10-31) [Support] - Shell script!


    User Launch Agents:

    [running] co.iristech.Iris.plist (2017-03-15) [Support]

    [failed] co.iristech.IrisMini.plist (2017-01-13) [Support] - /private/var/folders/03/6m1k1phx6s1gr50tzr0rn3jr0000gn/T/AppTranslocation/CCED459D-8A4B-4F43-8548-AEBDBE992E8B/d/iris-mini.app/Contents/MacOS/iris-mini: Executable not found!

    [loaded] com.adobe.ARM.[...].plist (2017-01-13) [Support] - Invalid signature!

    [failed] com.nchsoftware.expressinvoice.agent.plist (2013-08-20) [Support] - ~/Library/NCH Software/ExpressInvoice/ExpressInvoiceAgent: Executable not found!

    [running] com.sooloos.launchd.SooloosHelper.plist (2017-02-20) [Support] - No signature!


    User Login Items:

    SteerMouse Manager Application (2016-09-28)

    (/Applications/Utilities/SteerMouse.app/Contents/MacOS/SteerMouse Manager.app)

    RoboForm Application

    (/Applications/RoboForm.app)

    Karabiner Application

    (/Applications/Karabiner.app)

    Dictionary Application

    (/Applications/Dictionary.app)

    BetterTouchTool Application

    (~/Applications/BetterTouchTool.app)


    Internet Plug-ins:

    LogitechHarmony: 1.0.0.1 (2013-03-09) [Support]

    DYMO NPAPI Addin: 1.0 - SDK 10.10 (2016-05-27) [Support]

    Google Earth Web Plug-in: 6.1 (2013-03-09) [Support]

    DYMO Safari Addin: Unknown - SDK 10.10 (2016-05-27) [Support]

    OfficeLiveBrowserPlugin: 12.3.6 (2013-03-13) [Support]

    SlingPlayer: Unknown (2013-03-09) [Support]

    AdobePDFViewerNPAPI: 11.0.19 - SDK 10.6 (2017-01-13) [Support]

    FlashPlayer-10.6: 25.0.0.127 - SDK 10.9 (2017-03-16) [Support]

    DivX Web Player: 3.7.2.365 - SDK 10.10 (2016-12-26) [Support]

    LogMeIn: 1.0.961 - SDK 10.7 (2013-10-25) [Support]

    QuickTime Plugin: 7.7.3 (2016-12-19)

    Flash Player: 25.0.0.127 - SDK 10.9 (2017-03-16) [Support]

    iPhotoPhotocast: 7.0 (2013-03-09)

    LogMeInSafari32: 1.0.961 - SDK 10.7 (2013-10-25) [Support]

    AdobePDFViewer: 11.0.19 - SDK 10.6 (2017-01-13) [Support]

    SharePointBrowserPlugin: 14.7.2 - SDK 10.6 (2017-03-16) [Support]

    Silverlight: 5.1.50901.0 - SDK 10.6 (2016-11-21) [Support]

    JavaAppletPlugin: Java 8 Update 121 build 13 (2017-02-24) Check version



    Safari Extensions:

    Scroll To Top - Pratik Soni - http://pratikabu.users.sourceforge.net/extensions/scrolltotop (2016-11-20)

    Ghostery - GHOSTERY, Inc. - https://www.ghostery.com/ (2016-11-21)

    CustomSearch - SideTree.com - Software for Mac and PC - http://SideTree.com/extensions.html#CustomSearch (2015-03-31)

    RoboForm - Siber Systems - http://www.roboform.com (2017-02-13)

    AutoPagerize - swdyh - http://autopagerize.net/ (2017-03-06)

    DuckDuckGo - DuckDuckGo - http://duckduckgo.com (2017-03-11)

    NoMoreiTunes - Florian Pichler - http://nomoreitunes.einserver.de/ (2017-03-06)

    Streak - Rewardly Inc. - https://www.streak.com (2017-03-13)

    Tab Duplicator - Paul Kehrer - http://langui.sh/safari-extensions/ (2016-11-27)

    Tab Options - Canisbos Computing - http://canisbos.com/ (2016-11-20)

    KeyStroke - Rahul Abrol - http://sites.google.com/site/solushex/keystroke (2017-03-06)

    Lyrics Here by Rob W - Rob Wu - https://robwu.nl/lyricshere/ (2017-03-13)

    ClickToPlugin - Marc Hoyois - http://hoyois.github.com/safariextensions/clicktoplugin/ (2017-03-06)

    Sessions - David Yoo - https://sessions-extension.github.io/Sessions/ (2017-03-13)

    mru-tabs-switch - Andriy Tkachuk (2017-03-09)

    Translate - SideTree.com - Apps for Mac and Web - http://SideTree.com/extensions.html#Translate (2016-11-20)

    ClickToFlash - Marc Hoyois - http://hoyois.github.com/safariextensions/clicktoplugin/ (2017-03-06)

    Incognito - Orbicule - http://www.orbicule.com/incognito/ (2014-07-14)


    3rd Party Preference Panes:

    Flash Player (2017-02-28) [Support]

    Java (2017-02-24) [Support]

    Logitech Control Center (2013-07-13) [Support]

    SteerMouse (2015-04-14) [Support]


    Time Machine:

    Skip System Files: NO

    Auto backup: YES

    Volumes being backed up:

    MAC: Disk size: 499.25 GB Disk used: 323.27 GB

    Destinations:

    TimeMachineBackup [Network]

    Total size: 940.23 GB

    Total number of backups: 54

    Oldest backup: 5/8/15, 12:02 AM

    Last backup: 6/28/15, 10:31 PM

    Size of backup disk: Too small

    Backup size 940.23 GB < (Disk used 323.27 GB X 3)


    Top Processes by CPU:

    11% com.apple.WebKit.WebContent(94)

    9% WindowServer

    8% mdworker(10)

    4% kernel_task

    1% distnoted(3)


    Top Processes by Memory:

    12.56 GB com.apple.WebKit.WebContent(94)

    5.36 GB kernel_task

    475 MB Safari

    377 MB mdworker(10)

    279 MB com.apple.audio.SandboxHelper(17)


    Virtual Memory Information:

    1.65 GB Available RAM

    48 MB Free RAM

    14.35 GB Used RAM

    1.60 GB Cached files

    281 MB Swap Used


    Diagnostics Information:

    Mar 15, 2017, 05:49:30 PM ~/Library/Logs/DiagnosticReports/SIMBL Agent_2017-03-15-174930_[redacted].crash

    /Library/ScriptingAdditions/SIMBL.osax/Contents/Resources/SIMBL Agent.app/Contents/MacOS/SIMBL Agent

    Mar 15, 2017, 05:49:16 PM Self test - passed

    Mar 15, 2017, 02:43:04 PM ~/Library/Logs/DiagnosticReports/SIMBL Agent_2017-03-15-144304_[redacted].crash

    Mar 14, 2017, 06:52:42 PM /Library/Logs/DiagnosticReports/softwareupdated_2017-03-14-185242_[redacted].cpu_resource.diag [Details]

    /System/Library/CoreServices/Software Update.app/Contents/Resources/softwareupdated




    @ BaracksSi : Please see above :)
     
  12. BarracksSi Suspended

    BarracksSi

    Joined:
    Jul 14, 2015
    #12
    My guesses (without searching for more info) -- BetterTouchTool, ClickToPlugin, and -- most likely -- CustomSearch.

    Custom Search is listed in your Safari Extensions. Looks like it does exactly what shows up in your screenshots:
    http://sidetree.com/extensions.html#CustomSearch

    It's just an add-on, or an extension, and not really part of macOS. It should show up in the Extensions pane of your Safari -> Preferences window.

    Do these same options show up when you right-click (or control-click, or two-finger-click) an item anywhere else on your computer? Like in an email, or some text in Notes or TextEdit, etc?

    If not, then it's this CustomSearch thing that's causing the dialog window to pop up. Here's why I think it's happening:

    - Safari is running, and any extensions it contains -- like CustomSearch, Ghostery, ClickToFlash, etc -- are also running within Safari.
    - You're browsing the Web and want to look up a word in Dictionary, so you right-click on a word (like, say, "pizza") and choose "Search Dictionary" in the contextual menu.
    - This triggers CustomSearch to send a query to Safari, asking Safari to open Dictionary.app and look for the word "pizza".
    - Safari hears this query and, per security protocol, asks YOU via the popup window if this is what you plan to do.
    ** this is what creates the popup in your screenshot in your opening post **
    - From there, then, you click Allow or Cancel, right?

    Like I said, I don't think you can bypass this popup whenever you select "Search Dictionary" via the CustomSearch extension. Safari is working as designed, and it's preventing an extension from automatically opening an app.

    CustomSearch itself hasn't been updated in nearly two years, either, after receiving yearly-or-faster updates since its release in 2010. I don't think they're maintaining it anymore.
    http://sidetree.com/extensions/CustomSearch_changes.html

    I'd do one of two things:
    Option A: Disable CustomSearch and remove it. It's old; selecting the native, built-in "Look up..." option is just as handy; it's not hard to copy-paste something into a new tab anyway.
    Option B: Keep using CustomSearch, but either remove the "Search Dictionary" option or simply stop selecting it and use "Look up.." instead. I guess it's a workaround, but it's hardly "work" and there's not much to go "around". ;)
     
  13. DeltaMac macrumors 604

    DeltaMac

    Joined:
    Jul 30, 2003
    Location:
    Delaware
    #13
    This Safari extension is providing all your search engines in the right-click menu.
    I suspect that it may not be fully compatible with Sierra - check for updates to the plugin.
    Or, direct launch of Dictionary app is just not supported. Try contacting the developer, maybe they have other updates, or other suggestions for you.
     
  14. Sumleilmus macrumors member

    Sumleilmus

    Joined:
    Nov 6, 2011
    Location:
    /
    #14
    I wonder how you set up your Sierra, and how it differs from the way I set up mine. I look up words in lots of languages all the time. I enabled lots of dictionaries. To do this, I opened Dictionary.app and used the Preferences to add about 17 dictionaries. When I select a word in a page on either Safari or Chrome, and use the contextual menu, one choice I'm offered is "Look up 'selected word' " If I choose this, a popup window shows me all the return from Dictionary.app. I have never anything like the screen shots you posted. I am not asked any security questions. The examples below were obtained by selecting the word dictionaries in what I am writing in this post.

    Screen Shot 2017-03-18 at 13.22.22.jpg Screen Shot 2017-03-18 at 13.22.35.jpg
     
  15. DeltaMac macrumors 604

    DeltaMac

    Joined:
    Jul 30, 2003
    Location:
    Delaware
    #15
    The "Custom Search" extension, which the OP shows as installed, will modify the contextual menu in Safari.
    As I said earlier, the popup is possibly the result of that Custom Search extension - which has not been updated for a couple of years, and is probably just buggy in Sierra.
     
  16. JohnDohe thread starter macrumors member

    Joined:
    Jul 17, 2013
    Location:
    Mac OS Extended (Journaled) ???
    #16
    I thank all of you for your thoughtful and helpful answers.

    Yes, it is the "Custom Search" option that I installed that
    is the culprit. I will attempt to contact the developer for
    a Sierra update or workaround.

    I've had this extension for some time, before I upgraded
    to Sierra and it worked fine, without asking for this
    permission each and every time.

    Its a useful extension as I get a better and fuller definition
    and etymology of the word than what comes us when
    using "Look up 'selected word' ".

    Alas, I will struggle with this as is and hope for a fix in
    the future.

    Again, thanks to all ! :=))
     
  17. DeltaMac macrumors 604

    DeltaMac

    Joined:
    Jul 30, 2003
    Location:
    Delaware
    #17
    How is "one extra click to launch Dictionary" (which is all it takes from "Look up 'word" ) better than the one-click, buggy extension that you have now, that also needs your password? (to the same dictionary app?)
     
  18. JohnDohe thread starter macrumors member

    Joined:
    Jul 17, 2013
    Location:
    Mac OS Extended (Journaled) ???
    #18
    @ Delta Mac

    You're mistaken: a password not needed.

    And, the extension is not buggy to my knowledge.

    I've ask the developer and he replies that with Sierra
    theres this added thing that Apple has done that now
    requires one to "allow". But its been applied too
    broadly and indiscriminately without the ability to
    make exceptions. So its actually an Apple but, not
    this extension.

    "Look up 'word'": I have to scroll it to see all I need to see.

    With the extension, once I click "allow" I see everything in
    one screen without having to scroll.

    Personal preference.
     
  19. BarracksSi Suspended

    BarracksSi

    Joined:
    Jul 14, 2015
    #19
    Sierra is doing what an OS should've been doing since the 1990's: prevent a web browser from opening your computer's apps without explicit permission.
     
  20. JohnDohe thread starter macrumors member

    Joined:
    Jul 17, 2013
    Location:
    Mac OS Extended (Journaled) ???
    #20
    I agree.

    But I should also have the option to choose what app's I allow,
    permanently, and at my own risk.

    I don't need, or want, to be held by the hand.
     
  21. BarracksSi Suspended

    BarracksSi

    Joined:
    Jul 14, 2015
    #21
    What if an extension to which you previously gave full permission was later updated to do malicious things? It would be allowed to run whatever it wanted, good or bad, because you had said it was okay. If I was a less-than-ethical developer, this is exactly what I would do -- build a good utility, gain the trust of many users, get it installed on many systems around the world, and then update it to inject some malware.

    This isn't about holding your hand, this is about keeping watch over system access all the time.

    Like we noted earlier, the CustomSearch extension hasn't been updated in two years, so I'm pretty sure the developer has abandoned it.

    Can you set the extension to, say, "Search Dictionary.com" instead? You know, like how it can search Google or Amazon?
     
  22. JohnDohe thread starter macrumors member

    Joined:
    Jul 17, 2013
    Location:
    Mac OS Extended (Journaled) ???
    #22
    @ BarracksSi

    (Yes, I can add "Search dictionary.com" to the list, but
    thats not what I want.)

    You make a good point.

    But how would I know that an extension that I've been using
    for years had suddenly gone bad?

    Even the way it is, by mere force of habit, I would continue
    to "allow" it even after it had gone bad, so how would I know
    it was bad?

    Perhaps the OS could advise me of an update to the extension
    and for me to have to check it out and "re-allow" it to have
    automatic access again?

    But how does one learn that an extension or other app has
    turned to the dark side ... ever?
     
  23. BarracksSi Suspended

    BarracksSi

    Joined:
    Jul 14, 2015
    #23
    But it'll get you a dictionary result without taking you out of Safari. You're asking for Pepsi, but you may have to settle for Coke here.

    You wouldn't, and that's exactly why the OS should be protecting your system.

    Safari can check for updates in the Extensions pane, right?

    Usually when the tech press reports something like, "Breaking news: The browser extension named TrustMeWithYourCreditCardNumber has been sending users' information to a server in Canuckistan since its Version 6.66 update three years ago"
     
  24. JohnDohe thread starter macrumors member

    Joined:
    Jul 17, 2013
    Location:
    Mac OS Extended (Journaled) ???
    #24
    @ BarracksSi

    While opening Dictionary.com is ok, its not what I'm asking
    about, and using your argument, how do I know it hasn't
    gone rogue either?

    "Safari can check for updates in the Extensions pane, right?"
    And that ability gives me ... what?

    "... tech press reports ..."
    Not being a techie, I don't subscribe to them.
    Which do you recommend?
     
  25. BarracksSi Suspended

    BarracksSi

    Joined:
    Jul 14, 2015
    #25
    I recommend not using the CustomSearch extension anymore. It's simply not necessary. It's also old (it was last updated two Mac OSes ago, back in the Yosemite days), and the developer -- judging by his response to you -- has given up on trying to keep it working. It's like Apple added a security gate around Safari (thank goodness) and CustomSearch's developer isn't going to be able to work around it (thank goodness again, because you know as well as I do that an exploit bypassing web browser security is very valuable to malware hackers).

    --- OR --

    I might recommend configuring it to "Search Dictionary.com" instead. Maybe Merriam-Webster's website instead?

    I gave both of these recommendations already, too, near the end of post #12.

    How would I know that Dictionary.com hasn't "gone rogue"? Well, maybe it can, but because any malware should be contained within browser and not opening another app on my computer, any damage would be minimal to nonexistent.

    Here's another analogy:
    1. Searching Dictionary.com is like going to the grocery store.
    2. Opening the Dictionary app is like having someone come to my house and putting food in my kitchen.
    Option 2 seems more convenient, but do I really want a random stranger in my kitchen every time I want food? What's to keep them from giving me the wrong stuff, or planting a secret webcam inside a cabinet, or stealing my wallet when my back is turned?

    I also recommend not using Google because they track your every move and sell the resulting data to advertisers. But that's another topic.

    For Mac-related news, I still go to macsurfer.com -- any newsworthy malware stories usually pop up there, and since such stories are rare, they stand out. Check it once a day.

    Regarding how Safari can check for updates in the Extensions pane: It gives you at least some peace of mind that the extensions currently installed are also hosted by Apple in their Extensions Gallery (kind of like a min-app store for Safari extensions) and, in theory, tested and vetted to behave the way they're supposed to behave.
     

Share This Page