Gmail User Name/Pass on IPhone Incorrect Fix

DigiGuy777

macrumors newbie
Original poster
Oct 20, 2009
8
0
Hi Everyone,

Just recently my Gmail account on my IPhone no longer
worked because it said "Cannot Get Mail The user name or password
for "*******@gmail.com" is incorrect.


Well let me tell you it had me stumped for quite a while
until I decided to delete the account of my phone and
re create it. So I did and tried to get Gmail to come in on
my phone ( SAME ISSUE ).

So I deleted the account yet again but this time I did
something different.

When I went to ( ADD AN EMAIL ACCOUNT ) I didn't choose GMAIL!
Instead I chose ( OTHER )
When I hit ( SAVE ) I got a message saying something about it
not being a IMAP account. Thats not the exact thing it said but close.

Anyway I went ahead and saved it and that brought up a window giving me
the choice to create either a IMAP or POP account.

I chose POP entered the settings for my Gmail account hit save and WALLA
I get Gmail back on my IPhone again.:D

Now if I could only figure out why POP wont work in the new Mail 4.1
I would be one happy camper.

Have a great day.
 

ntrigue

macrumors 68040
Jul 30, 2007
3,804
1
I think that's on Google's end. Try Enabling Advanced IMAP in Google Labs and ensuring IMAP settings are correct.
 

b3tw33n

macrumors newbie
Jan 7, 2010
1
0
Thanks

DigiGuy777: Thanks for the solution. Good work.

ntrigue. - read posts before you reply to them. :eek:
 

mattbaj

macrumors newbie
Jan 25, 2010
1
0
The actual problem and solution (not a work around)

The Problem is that the Gmail "fetch new data" setting needs to be on "fetch" and not "manual"

if you want it to fetch manually.

- Go to - Settings>Mail, Contacts, Calenders>Fetch new data
- turn push off
- set fetch to Manually(global setting)
- Click - Advanced
- Click - yourusername@gmail.com
- Make sure this is set to fetch. (it won't fetch because you have set the global fetch setting to manual)
It should now recognize your username/password

This is what started and fixed the problem for me.
Just thought I would pass it on for those who don't want to delete their account.
 

kdstegh

macrumors newbie
May 7, 2011
1
0
The Problem is that the Gmail "fetch new data" setting needs to be on "fetch" and not "manual"

if you want it to fetch manually.

- Go to - Settings>Mail, Contacts, Calenders>Fetch new data
- turn push off
- set fetch to Manually(global setting)
- Click - Advanced
- Click - yourusername@gmail.com
- Make sure this is set to fetch. (it won't fetch because you have set the global fetch setting to manual)
It should now recognize your username/password

This is what started and fixed the problem for me.
Just thought I would pass it on for those who don't want to delete their account.
How does the "manual fetch" functionality work differently than the "push" functionality? Do I need to take a step to tell the phone to check for emails?
 

DoFoT9

macrumors P6
Jun 11, 2007
17,494
26
Singapore
The Problem is that the Gmail "fetch new data" setting needs to be on "fetch" and not "manual"

if you want it to fetch manually.

- Go to - Settings>Mail, Contacts, Calenders>Fetch new data
- turn push off
- set fetch to Manually(global setting)
- Click - Advanced
- Click - yourusername@gmail.com
- Make sure this is set to fetch. (it won't fetch because you have set the global fetch setting to manual)
It should now recognize your username/password

This is what started and fixed the problem for me.
Just thought I would pass it on for those who don't want to delete their account.
hey guys, i know this is a fairly old thread - but i thought i would add my findings.

if mattbaj's solution does not work, attempt to try this solution - it forces reauthentication through google captcha. worked perfectly for me :)
 

DoFoT9

macrumors P6
Jun 11, 2007
17,494
26
Singapore
why wouldn't you just set up gmail as exchange?
because i would rather just set it up as to how apple/gmail recommends - i guess.?

Why would you set it up as an Exchange, when there is a specific option for gmail accounts?

Thanks to DoFoT9 for the link, it worked for me. To save a bit of clicking though, just go straight here : UnlockCaptcha, to unlock it.
not a problem, ive used this link about 3 times this week so far! (setting up 100 ipads is ANNOYING!)

thanks for the quick link :D
 

Hermes Monster

macrumors 65816
May 4, 2010
1,145
304
UK
not a problem, ive used this link about 3 times this week so far! (setting up 100 ipads is ANNOYING!)

thanks for the quick link :D
no worries!

Not sure why this happens - but it's effected both of my gmail accounts and one of my gf's googlemail accounts in the same week - baffling
 

schalliol

macrumors regular
May 7, 2002
178
43
Carmel, IN
This happened on my mothers iPad and iPhone, and I used the captcha link noted above to unlock it. Very strange. Thank you, everyone!
 

beskid234

macrumors newbie
Oct 11, 2011
1
0
Log onto a computer and go to your gmail account. Change the password, then go onto your phone type in everything as you would normally to sync your email accounts and you will be able to go a head and link the account to your phone.
 

Skullbussa

macrumors member
Jul 1, 2011
53
7
Log onto a computer and go to your gmail account. Change the password, then go onto your phone type in everything as you would normally to sync your email accounts and you will be able to go a head and link the account to your phone.
Yep, tried this. Doesn't work.

I had to use the Unlock captcha link above to get this to work.

IT IS ABSOLUTELY MADDENING that I had to google search this issue and find some obscure post on a forum to get this work.

I spent a good hour troubleshooting my mom's iPad to get this to work. This is, yet again, a result of Apple tying the user's hands, dumbing-down the process, and yet making things so so so much harder to troubleshoot in the process. This kind of crap is exactly why I sold my MacBook Pro and iPhone 4...I have never in my life had so much frustration with electronics products in my life.
 

abernathymusic

macrumors newbie
Nov 24, 2008
10
0
Thanks DoFoT9!!! Just had this issue on my iPhone and the UnlockCaptcha worked. I honestly don't get why people love Gmail. I use it as a secondary account. I have much less trouble with my mac.com account!
 

wilsonldn

macrumors newbie
Nov 21, 2011
1
0
Google 2-Step Verification

I added Google 2 step verification to one of my Gmail accounts this and it killed it instantly saying that I had entered the wrong user/password on my iphone.

After trying all the other suggestions to sort the problem, with no luck, I just turned 2 step Verification off and now it works!
 

brandieleigh

macrumors newbie
Dec 11, 2011
1
0
problems

DigiGuy777 I am trying that step, but what do I enter for the incoming mail server and outgoing mail server host name and user name? I am so lost!
 

cleber.visconti

macrumors newbie
Dec 17, 2011
1
0
How to Solve Gmail: “Cannot Get Mail” The user name or password is incorrect.

Are you facing some issues with GMail on your Client/Mobile devices ? I had this issue during a few days and the main error message was: “Cannot Get Mail The user name or password is incorrect” or something referred to the imap and smtp server with wrong username and password.

This problem will cause effects on your mobile devices or e-mail client tools. The WebMail – mail.gmail.com will continue to work.

I've published the complete reference at:

http://www.clebervisconti.net/2011/12/how-to-solve-gmail-cannot-get-mail-the-user-name-or-password-is-incorrect/
 

vikram19867

macrumors newbie
Dec 20, 2011
1
0
Google Mail Fix for ios MAIL

I followed the instructions posted by 'TheEagle'. Follow the link below:

http://support.google.com/accounts/bin/static.py?hl=en&guide=1056283&page=guide.cs&answer=185833&rd=3

Apparently, the issue was with the Application Specification Password. Google helps generate a specific password for the iOS MAIL app.

I had tried every single suggestion posted here:

A. Deleting my Account and creating a new account under Other>Account. Then selecting POP and not IMAP. Didn't work.

B. Following the captcha link for google accounts. Tried it thrice, didn't work.

C. Reset my google mail password, then retried captcha. No result. Restarted my phone, and no sh**

D. Switched to fetching data manually. Then turning Push off for Fetch data. Not working.

Finally, generating a new application specific password for the MAIL app by logging into Google's Authorizing applications & sites page and following instructions in the link provided above worked. Entered my name, gmail address, and the app specific password, and walla!

I'm only posting this because it took me an entire hour to figure it out, and thanks to 'TheEagle' 's post, the google support link works, absolutely. Follow the instructions and like the poster said, It'll work like a charm!!
 

kicko

macrumors 65816
Aug 26, 2008
1,095
0
seriously just reboot the phone first, that has fixed this issue for me every time it has happened.


you dont have to change passwords, delete accounts or any of that nonsense.
 

james404

macrumors newbie
Jan 2, 2012
3
0
cannot get mail the username or password for is incorrect iphone gmail

Just solve the problem! in my Iphone gmail account in field "name" wasn't the same name as in gmail. interesting, but it works until today!! When suddenly i've got a message like "cannot get mail the username or password for (my gmail account) is incorrect" It's take time to figure out that problem is in "username" - exactly that alert said. when i've changed the "name" (in gmail account information block in iPhone) - problem was solved) sorry for bad english) Happy New Year!!!