Go to Sleep! MacBook Pro won't sleep right away...

JajoPGH

macrumors regular
Original poster
Jul 24, 2008
166
0
Hi again folks.

A small new problem I have encountered is that my computer will take a very long time to fall asleep. This happens when I go Apple > Sleep.

It will take at least a minute to go to sleep. On the other hand, if I close the lid, it will take a few seconds to go to sleep.

Any idea what this could be? It's very annoying, because sometimes I like to put the computer to sleep with the lid open.

While I'm here, I have related question. Is it bad for your computer to be put to sleep and awaken often (say twice in 5 minutes)?

Thank you!
 

whooleytoo

macrumors 604
Aug 2, 2002
6,569
641
Cork, Ireland.
It seems like it's going to 'deep sleep' when you select Sleep from the menu, but normal sleep when you close the lid.

(You can verify if this is true, by looking at the light on the front; if it's slowly throbbing, it's normal sleep; whereas if the light is off, it's in deep sleep).

The benefit of deep sleep is that it doesn't consume any power, but it does take a little longer to sleep (saving the contents of memory to disk, so it can resume on wake).

I use the Deep Sleep widget to control this.
 
Comment

JajoPGH

macrumors regular
Original poster
Jul 24, 2008
166
0
It seems like it's going to 'deep sleep' when you select Sleep from the menu, but normal sleep when you close the lid.

(You can verify if this is true, by looking at the light on the front; if it's slowly throbbing, it's normal sleep; whereas if the light is off, it's in deep sleep).

The benefit of deep sleep is that it doesn't consume any power, but it does take a little longer to sleep (saving the contents of memory to disk, so it can resume on wake).

I use the Deep Sleep widget to control this.
I tried verifying, but it turns out the light still throbs after I click "Sleep." This is strange, because I have never encountered this problem before.
 
Comment

Makosuke

macrumors 603
Aug 15, 2001
6,173
363
The Cool Part of CA, USA
They should both do the same thing--regardless of how you put the computer to sleep, an Apple laptop should pause for a moment while it saves contents of memory to disk (in case it loses power while asleep), then go to sleep and pulse the light. So far as I know the only way of getting into "deep" sleep--as in a state where it has completely powered down--is cutting power while it's asleep (correct me if they've added this to the new Unibodys).

To my knowledge, it does the same procedure regardless of how you've asked it to sleep. Are you sure you don't just THINK it's sleeping faster when you close the lid because the screen powers down immediately? Is the delay related to when the light actually starts pulsing (which is the point at which it has FINISHED going to sleep)?

My MBP, if I close the lid, will turn off the screen and turn the light on, but if I listen carefully I can hear the hard drive grinding away (and the fan running) until it has finished saving RAM contents to disk, at which point the light goes from steady on to throbbing and everything fully powers down. This takes probably 15 seconds or so with 2GB of RAM, though I've never timed it. I assume were I to select Sleep from the menu with the screen open it would take just as long but the screen would stay awake during the write-to-disk process. Never tried, admittedly, since I always just close the lid.
 
Comment

JajoPGH

macrumors regular
Original poster
Jul 24, 2008
166
0
They should both do the same thing--regardless of how you put the computer to sleep, an Apple laptop should pause for a moment while it saves contents of memory to disk (in case it loses power while asleep), then go to sleep and pulse the light. So far as I know the only way of getting into "deep" sleep--as in a state where it has completely powered down--is cutting power while it's asleep (correct me if they've added this to the new Unibodys).

To my knowledge, it does the same procedure regardless of how you've asked it to sleep. Are you sure you don't just THINK it's sleeping faster when you close the lid because the screen powers down immediately? Is the delay related to when the light actually starts pulsing (which is the point at which it has FINISHED going to sleep)?

My MBP, if I close the lid, will turn off the screen and turn the light on, but if I listen carefully I can hear the hard drive grinding away (and the fan running) until it has finished saving RAM contents to disk, at which point the light goes from steady on to throbbing and everything fully powers down. This takes probably 15 seconds or so with 2GB of RAM, though I've never timed it. I assume were I to select Sleep from the menu with the screen open it would take just as long but the screen would stay awake during the write-to-disk process. Never tried, admittedly, since I always just close the lid.
Thank you for spending the time to write that response to me...

Well, I know it takes time for the computer to be put to sleep, but before yesterday, it took 10 seconds. Now it takes close to a minute. When I close the lid, it takes long too. The Apple logo will stop glowing, but the white LED in the front will be lit and won't throb. It will take a minute or so for it to start throbbing.

What are some things I could do about this? Do I have to reinstall OSX? I really hope this isn't the tip of the iceberg of a bigger problem.
 
Comment

JajoPGH

macrumors regular
Original poster
Jul 24, 2008
166
0
Does anyone have any other suggestions on what I may do to alleviate this problem?

I don't want to resort to calling Apple.

And I really hope this is not a sign of things to come. I'm worried the computer may have several problems down the road.
 
Comment

appleaphid

macrumors newbie
Oct 30, 2009
13
0
Same problem here: macbookpro takes for ever to sleep

Hey, did anyone find the solution?

My late 2008 Macbook pro has been slow to go to sleep (close to 1min) and it used to take just a few seconds :confused:. This is using either sleep in the apple menu or closing the lid.

I have tried closing all programs, and it still takes a long time. Any help would be much appriciated.

Cheers,
Mick

Using a late 2008 Macbook pro 2.5GHz, 4RAM, 320HD, Leopard 10.6.2
 
Comment

majidmx

macrumors newbie
Dec 26, 2009
2
0
hey guys,

I Just signed up to post the reply.
I found the solution for this, you have to search for the logs and see what is taking too much time. Use the following command :
Code:
pmset -g log
Look for "applicationresponse.slowresponse" and look for the "Signature" with the longest time."
In my case it was an old print job which I had sent my mistake to an offline printer and forgot to delete it from the queue.
I went to "print and fax" in system preferences and found the printer, checked the queue and deleted the job.
Now my lovey MBP sleeps in 2 seconds like an infant.
 
Comment

onehoop

macrumors member
Jul 28, 2008
51
2
Denver
I found the solution for this, you have to search for the logs and see what is taking too much time. Use the following command :
Code:
pmset -g log
In my case it was an old print job which I had sent my mistake to an offline printer and forgot to delete it from the queue.
I went to "print and fax" in system preferences and found the printer, checked the queue and deleted the job.
Now my lovey MBP sleeps in 2 seconds like an infant.
...very interesting...
I've got 2 com.apple.powermanagement.applicationresponse.slowresponse 's.
1 is a Kernel configd and the other a PMConnection mDNSResponder. The slowresponse varies, but the last instance the Kernel was 7763ms and the PMConnection was 536ms.

Are those normal values? Anything to be done for it?

-=-=-=-

As to the OP:
My computer is the original Intel Core Duo MBP and it has always had problems with sleeping. Lately the battery is so low that it became intolerable and I would have to turn it off to travel. From searching other forums, I found that the problem was with the loose latch which would shift from time to time awakening and sleeping the computer, which would confuse the Power Management and occasionally incite a kernel panic and overheating inside my travel bag. Or so it would seem. Anyway, the solution that I found was to write out the terminal line:
Code:
sudo pmset -a lidwake 0
Sudo commands are dangerous and require you to enter your (root) password (more accurately, sudo allows you to enter root commands which then require your password unless you just entered it in the last 5 minutes or so).
Before you follow this advice blindly, it would be wise to read the
Code:
man pmset
page to see what it does. Since I've already done so, you may want to change the "-a" flag to a "-b", since it only matters when on battery.

I just did this yesterday, but preliminary tests seem to show my computer holding a charge better while closed.

Hope that helps.


M@
 
Comment

Heb1228

macrumors 68020
Feb 3, 2004
2,215
0
Virginia Beach, VA
I've also been noticing longer-than-expected sleep times when closing the lid. I ran the command that majidmx mentioned above and get two recurring errors. Anybody have an idea about fixing these?

Here's a sample of each:

Code:
- Message: PMConnection IPConfiguration com.apple.powermanagement.applicationresponse.slowresponse 2109 ms
 - Time: 2/2/10 4:47:21 PM EST 
 - Signature: IPConfiguration
Code:
 - Message: PMConnection AirPort configd plug-in com.apple.powermanagement.applicationresponse.slowresponse 2109 ms
 - Time: 2/2/10 4:47:21 PM EST 
 - Signature: AirPort configd plug-in
Looks like it has something to do with Airport/Networking not closing down a connection like it should.
 
Comment

mbrose33

macrumors newbie
Mar 26, 2010
1
0
I had the exact same problem. As one of the posters above, I had a print job in my print queue. As soon as I deleted the print job, computer started sleeping normally again.
 
Comment

apd2104

macrumors newbie
May 9, 2010
1
0
macbookpro taking a long time to sleep -- problem solved

thank you for this discussion. I was having the same problem -- the computer hanging >20 seconds before going to sleep. Couldn't figure it out. Talked to 3 different apple representatives and then ran it by a guy at the genius bar -- tried all different things: reset smc, pram reset, deleting a powerpreference plist, creating a new user and having the same issue.

The problem in my case was a print job in the print queue. Deleted that job in system preferences and it's back to crisp functioning. Wish I knew more about code and how to search for the problem myself. Thanks to majidmx for figuring it out!
 
Comment

dimchen

macrumors newbie
May 11, 2010
1
0
hey guys,

I Just signed up to post the reply.
I found the solution for this, you have to search for the logs and see what is taking too much time. Use the following command :
Code:
pmset -g log

In my case it was an old print job which I had sent my mistake to an offline printer and forgot to delete it from the queue.
I went to "print and fax" in system preferences and found the printer, checked the queue and deleted the job.
Now my lovey MBP sleeps in 2 seconds like an infant.
Thank you !! This solved my MBP slow entering sleep problem ! I was trying to print through network printer , but it failed and the tasks stuck in the queue.
 
Comment

DrBanner

macrumors newbie
Aug 11, 2010
3
0
Looks like it has something to do with Airport/Networking not closing down a connection like it should.
I have the same problem. Those two processes seem to be the culprit. Has anyone figured out a fix for this?

My MBPro used to sleep just fine (within 2 seconds) until today. Now it takes 20-30 seconds.
 
Comment

coz707

macrumors member
Jan 27, 2010
42
0
Some south of the equator
I had the same problem on my iMac...I looked at my print cue and saw something that was trying to print on a printer I threw out! I deleted the job and now my <1 second sleep time is back!
 
Comment

CrzyCanuck72

macrumors 6502a
Jun 10, 2003
913
0
I have the same problem. Those two processes seem to be the culprit. Has anyone figured out a fix for this?

My MBPro used to sleep just fine (within 2 seconds) until today. Now it takes 20-30 seconds.
Same problem! Any solutions?
 
Comment

TVM70

macrumors newbie
Oct 25, 2010
2
0
MBP slow to sleep - problem solved

Thanks for the discussion. My MBP was taking up to 30 sec to sleep but once I deleted a job hanging in the print cue all returned to normal. It's now back to sleeping instantly.
 
Comment

Mal

macrumors 603
Jan 6, 2002
6,249
17
Orlando
I know most of this thread is fairly old, but in my case it turned out to be incredibly simple. I was running Transmission, and it turns out it takes a while for it to pause the downloads that are running, so my machine would take 1-2 minutes sometimes to actually sleep. When I quit Transmission first, it would go to sleep in less than 10 seconds most of the time.

So before you go mucking around in the Terminal, try looking at the apps you're running first, and in fact try quitting everything first, just to test if it's related to an app.

jW
 
Comment

JB Tipton

macrumors newbie
Feb 5, 2011
10
0
Whether WeatherBug bug is worth it

My MacBook Pro has been taking 35 seconds or more to go to sleep since the 2nd day after I bought it. Thanks to majidmx's suggestion to investigate using
pmset -g log
I FINALLY discovered the following:

* Domain: applicationresponse.timedout
- Message: Kernel WeatherBug Alert com.apple.powermanagement.applicationresponse.timedout 30000 ms
- Time: 110313 7:41:57 am CDT
- Signature: WeatherBug Alert
- UUID: 7E960EE0-9A12-42DC-B97C-3A95BF966104
- Result: Noop
- Response time (ms): 30000

Quitting WeatherBug before sleeping my MacBook allows the machine to go to sleep immediately.

I have reported this to WeatherBug. I hope they fix it.
 
Comment

Shu15

macrumors regular
May 28, 2009
186
0
United States
Sorry to revive an old thread, but I'm having the same problem. I turned my hibernation to 0 and typed in pmset -g log but my list is HUGE. I tried to do the command-F to search for 30,000 ms response times, but that list is still huge and not everything there will be affecting the sleep, or else my sleep time would be well over 5 minutes. Is there a way to filter the list to find the culprit?

Thanks
 
Comment

Yellow 13

macrumors member
Mar 26, 2011
50
0
Erusia
terminal command

pmset -g | grep hibernatemode

you should have: hibernatemode 3



sudo pmset -a hibernatemode 0




every week or so

sudo rm /var/vm/sleepimage
 
Comment

Jiten

macrumors 6502a
Jul 16, 2008
581
0
I know this is an old thread but I just want thank the folks who answered here. I have a 11 inch 2010 Macbook Air that also took about 20 to 30 seconds to sleep. I did everything from resetting PRAM and the SMC but no avail. Then I found the post on checking for left over print jobs and deleting them. Our office have over a dozen printers so I had backlogged print jobs everywhere. I cleaned them out and it worked! My Air now instantly sleeps again!
 
Comment

yorkergizer

macrumors newbie
May 11, 2011
1
0
Thanks! I also had the printer queue problem.

For those looking in terminal, if you have something stuck in the printer queue, it will show up as:

* Domain: applicationresponse.timedout
.
.
Signature: cupsd
.
.
Response time (ms): 30000


If you see that one, take a look at your printer queue. The message shows up after the "wake" and "hibernatestats" Domains, not *before* the "wake" domain as noobs like me may have expected.
 
Comment

Similar threads

Register on MacRumors! This sidebar will go away, and you'll see fewer ads.