Google Calendar GMT

Discussion in 'iOS 8' started by nidserz, Dec 9, 2014.

  1. nidserz macrumors 6502a

    nidserz

    Joined:
    Mar 28, 2008
    Location:
    Dubai x Toronto
    #1
    Hi everyone,

    I just noticed my Google Calendar on my iPhone has started to add GMT time as a 2nd option, and when I edit the event, it is in GMT. This part is really annoying. It is showing up in the correct timeslot in GMT +4 where I am... but editing/2nd view option is really irritating.

    The weird thing is, this is only for new events I create on my iPhone . Not sure when it started. If I create it on the desktop through the web, it syncs to my iPhone without GMT.

    Now the weird thing is, I have another Google account on my iPhone and when I use that calendar, it is fine, no GMT.

    Anybody have a fix? It is driving me crazy when I have to edit and keep changing timezones. i know this is a known error, but wondering if anyone here has a solution.
     
  2. EvoXOhio macrumors member

    Joined:
    Nov 20, 2014
    #2
    I'm a recent convert to iPhone, and I've noticed this since day 1. Very annoying, would love to know if there is a fix as well.
     
  3. BrianBaughn macrumors 601

    BrianBaughn

    Joined:
    Feb 13, 2011
    Location:
    Baltimore, Maryland
    #3
    What are/is...

    The Time Zone settings, at Google, for each of those Google calendars?
    The "Time Zone Support" setting on your iPhone?
    The Date & Time settings on your iPhone?
     
  4. nidserz thread starter macrumors 6502a

    nidserz

    Joined:
    Mar 28, 2008
    Location:
    Dubai x Toronto
    #4
    I had no problems before...
    Time Zone override is off
    Date & Time on iPhone is set Automatically

    I know it's an issue with the iPhone because the same Google account I add events on the web and on calendar on my Mac (Mavericks), it adds ok and pushes to iPhone without GMT. But the minute I add an event on my phone, it adds GMT.

    I have a 2nd Google account and when I add events on that, there is no GMT. So it's this specific account and my iPhone. I deleted and readded, but same problem.
     
  5. stephen82 macrumors newbie

    Joined:
    Aug 13, 2012
    #5
    I've been searching all morning for a solution and can't find one. Make an appointment on my phone's calendar and it puts it in the correct time slot but adds GMT.

    Now when I edit that appointment it switches to GMT time and changes the appointment time hours later on my calendar. Then, when editing, I have to click on the start time, then click on time zone and manually change to "new york" From GMT. This is so annoying since when editing appointments if you are not careful the appointments will end up at different times.

    I hope someone figures this out.
     
  6. BrianBaughn macrumors 601

    BrianBaughn

    Joined:
    Feb 13, 2011
    Location:
    Baltimore, Maryland
    #6
    There's a long thread over at the Apple forums on this. From what I can tell it's a problem with iOS 8 and particular Google accounts (or calendar in an account) which explains why one account/calendar is doing this and another isn't. Also explains why everyone isn't having the issue.

    nidserz, if you create a new calendar...at the same Google account that's having the issue...does the new calendar also have the issue?
     
  7. nidserz thread starter macrumors 6502a

    nidserz

    Joined:
    Mar 28, 2008
    Location:
    Dubai x Toronto
    #7
    Thanks for the info. Yeah I read the thread. Driving me insane.

    Good idea I hadn't though of it... but unfortunately just tested it and it does the same thing :( Really hope there is a solution soon!
     
  8. jaaanson, Dec 25, 2014
    Last edited: Dec 26, 2014

    jaaanson macrumors newbie

    Joined:
    Dec 25, 2014
    #8
    Partial GMT Resolution

    I noticed this same issue with my iPhone 5s and MacBook Pro/Mac Mini after upgrading to IOS 8 and Yosemite, respectively. I should note I am a casual computer user and have been gradually switching from PC to Mac products. After the above upgrades, calendar entries were in the right time slot but also listed GMT on the iPhone calendar, which I found confusing. I eventually "solved" this issue by changing my default calendar to an iCloud based calendar, rather than the gmail calendar I had successfully used for several years. It seems Apple and Google are not playing well together on this issue, resulting in being "crowded" into one system or the other.
     
  9. Baseballdad macrumors newbie

    Joined:
    Sep 25, 2014
    #9
    I have been on 8.1.2 for quite a while and had no GMT issue. Then, all of a sudden, with no changes made by me to either my Google or Apple accounts, this GMT issue just started happening out of the blue! I've been following the thread mentioned on Apple Communities and there are no solutions. Apparently both Apple and Google are blaming each other. If I find out anything new, I'll be back !! If anyone else finds a fix, don't forget to post!!
     
  10. predation macrumors 6502a

    Joined:
    Apr 3, 2013
    #10
    yeah its BS bug that is affecting everyone with a google calendar account.
    some people say its googles need to fix, some people say apple.

    I say its apple..... its really lame....

    hoping 8.2 fixes this... argggg.
     
  11. dyusem macrumors member

    Joined:
    Feb 21, 2005
    Location:
    SF North Bay
    #11
    I too have been experiencing this problem which I've seen only randomly and without any obvious rhyme or reason...my money is on Apple as the culprit.
     
  12. Onyx666 macrumors newbie

    Joined:
    Jan 9, 2015
    #12
    Hello,

    same problem... After having spent hours trying diffrent settings or called Apple helpdesk where I got stupid people on the line pretending I was the only one to have this problem I finally understood ( - by the way the support is really useless as their only "solution" - that wouldn't have worked - was to completelly re-initialise my phone!).

    Problem : Whatever the device used (iphone, Ipad, ...) if you are using IOS8xx with a sync account on Google or Exchange, you'll have the problem as soon as the calendar entry was enterred on the device side (not in Google) and when it is synchronized. It's well explained here in this video : http://youtu.be/cgP1zyi_iV8

    If you search the web for "IOS8 GMT bugs" you'll find thousands of people in many countries having this problem. What is also frustrating (reading the forums) is that a lot of people that have contacted Apple's help line have been told that it was a Google problem and not an Apple problem... so it is Google that would have to provide a fix !!!??

    So Google sync was working with IOS7, it is working with a Samsung or Windows device, it is NOT working since the IOS8 update and Apple pretends that the problem is not on their side !!! It's really a SHAME... !!!!
    :mad::mad::mad:
     
  13. BrianBaughn macrumors 601

    BrianBaughn

    Joined:
    Feb 13, 2011
    Location:
    Baltimore, Maryland
    #13
    iOS 7 doesn't have the problem as of right now. So the difference is iOS 8. That would lead one to believe that Apple could provide a fix.

    Google might be able to provide a fix but from what we know...we don't know!

    It's definitely an iOS 8 system thing. If you download the free "CalenMob" app you can set it up three ways: (1) access your iOS calendars, (2) log into a Google account, or (3) a combination of the two. If you add an event to a Google calendar using #1 if you view the event in the iOS Calendar app it will have the GMT problem. If you add an event using #2 your iOS Calendar will not have the GMT problem.

    I suppose it might be that way for other calendar apps that access Google directly and not through the iOS calendars.
     
  14. predation macrumors 6502a

    Joined:
    Apr 3, 2013
    #14
    can we PLEASE GET MACRUMORS TO DO A FRONT PAGE ARTICLE!?!?!?!??!!

    need the force of the MACRUMORS!!!
     
  15. Onyx666 macrumors newbie

    Joined:
    Jan 9, 2015
    #15
    IOS 8.1.3 Still NOT FIXED !!!!

    IOS 8.1.3 Still NOT FIXED !!!!
    What a lack of respect for their customers...
    :mad::apple::mad:
     
  16. campyguy macrumors 68030

    Joined:
    Mar 21, 2014
    Location:
    Portland / Seattle
    #16
    I'm going to put the turd in Google's pocket. After a few meetings missed by my business partner - whose Nexus died, and now he's using a backup iPhone 5, but insists on using Google Calendar, I wanted to find out what the heck was going on. After 4 years of using Google Apps and tiring of Google continually changing how to connect to their services, I've become accustomed to performing a bit of sniffing packets on behalf of the few holdouts in my company when they gripe about not getting notifications. Google's not adhering to any open standard isn't working for us, and there's no way in hell I'm going back to Google Apps.

    We've got meetings in Boise, Seattle, Bend, and Sitka coming up, and I know he's already in Bend (so he won't be late for that one!).

    That written, I know that Google has recently started resolving all of its calendar events into UTC. I tried this out for myself tonight after reading this thread. Google was sending event confirmation in a "X-WR-TIMEZONE" element, which is not per iCalendar specifications, and dates are in UTC, AND, they're omitting the "standard" iCalendar VTIMEZONE delimiter (transmitted by an iOS device).

    So, IMO either Apple's got to modify their app and/or Google needs to adhere to or map iCal elements. My only workaround was to edit events once they're "accepted" on my partner's iPhone calendar, but my end game is to get him off GCal once and for all... :mad:
     
  17. EvoXOhio macrumors member

    Joined:
    Nov 20, 2014
    #17
    So let me get this straight - this issue doesn't exist in iOS7 or prior, and it only started happening with iOS8, and you want to blame Google? The issue started with an Apple update - the issue is Apple's. My god man put down the kool aid.
     
  18. predation macrumors 6502a

    Joined:
    Apr 3, 2013
    #18
    It's definitely with Apple. They've even acknowledged it
     
  19. EvoXOhio macrumors member

    Joined:
    Nov 20, 2014
    #19
    Can you provide a link or source to that?
     
  20. campyguy macrumors 68030

    Joined:
    Mar 21, 2014
    Location:
    Portland / Seattle
    #20
    My god man, iOS8 isn't the only platform experiencing this issue. My god man, this issue's been going back to 2011. My god man, all you have is a gripe you can't document - but I can and have (and I'm not the only one - it's on Apple Discussions!). Go get some kool aid...
     
  21. EvoXOhio macrumors member

    Joined:
    Nov 20, 2014
    #21
    I've had iPads for years and the issue started with iOS 8. I didn't have an iPhone prior to iOS 8 but I can't comment there. My coworkers with iPhones said it started with iOS 8 as well.
     
  22. mcdill macrumors newbie

    Joined:
    Mar 29, 2013
    #22
    I have this problem too with my Google Calendar account.

    Until Google or Apple (or both of them) fixes this problem, my "solution" is to use Sunrise Calendar to enter calendar events. I believe Sunrise Calendar logs onto Google Calendar directly and does not cause Apple Calendar to show GMT as a second time option.

    Kind regards
     
  23. Rhonindk macrumors 68020

    Rhonindk

    Joined:
    Oct 3, 2014
    Location:
    Bloom County: Meadow Party
    #23
    True.
    Did not see this on any OS version prior to 8.
    I get around this by linking my Exchange, Google calenders to my 6+ and when adding a new appointment ensure that Google or Exchange is selected.
     
  24. EvoXOhio macrumors member

    Joined:
    Nov 20, 2014
    #24
    Fixed: http://www.macrumors.com/2015/02/03/gmt-calendar-bug-fixed-ios-8/

    As I said earlier, this is an iOS bug that started in iOS8. It is not a Google issue nor has it been going on for years as a previous user stated. From the article, it looks like the real fix will be in iOS 8.2, but in the meantime Apple or Google has made a behind the scenes change alleviating the issue for some people.
     
  25. BrianBaughn macrumors 601

    BrianBaughn

    Joined:
    Feb 13, 2011
    Location:
    Baltimore, Maryland
    #25
    Thanks for the heads up on that. Working for me now.
     

Share This Page