Graphics Performance (9400M)

Discussion in 'Mac OS X Lion (10.7)' started by Gradsta, Aug 7, 2011.

  1. Gradsta macrumors newbie

    Joined:
    Aug 7, 2011
    #1
    I recently upgraded my unibody MacBook (Late 2008) to Lion and so far, am loving the experience. One gripe I have with the OS, however, is the subpar graphics performance I receive on my machine. The animations associated with Mission Control and especially Launchpad frequently stutter and are not as smooth as I would like them to be. Now, I understand that my machine is almost three years old, but I feel as though my GPU (Nvidia GeForce 9400M) should be able to handle simple OS animations. I have gleaned from elsewhere that the drivers for my particular graphics card may not have been properly optimized for Lion. Do you think that this might be the case or that my graphics card is just too old?
     
  2. marsmissions macrumors 6502

    marsmissions

    Joined:
    Jan 5, 2010
    Location:
    Washington, US
    #2
    How much ram do you have? My Unibody aluminum has 4 gigs with the same graphics... No issues here. Maybe you need more ram?
     
  3. Gradsta thread starter macrumors newbie

    Joined:
    Aug 7, 2011
    #3
    I too have 4GBs of RAM so I don't think that is the issue.
     
  4. stratokaster macrumors newbie

    Joined:
    Jul 30, 2011
    #4
    I used to have the same laptop as you. In Leopard (10.5) everything was super smooth, but once I upgraded to 10.6, all the animations began to stutter because of sub-optimal graphics drivers. Apple eventually fixed this issue in 10.6.4. I assume this is also the case with Lion.

    BTW, now I own a Mac with Intel Hd 3000 graphics. In SL, everything was super smooth, but in Lion the graphics performance is much worse. I think I'm starting to get the pattern...
     
  5. baryon macrumors 68040

    baryon

    Joined:
    Oct 3, 2009
    #5
    I have the high-end late 2008 MacBook Pro with 9400M graphics and it runs Lion's animations just fine. There are stutters, but then there were stutters in Snow Leopard as well (not in Leopard). Not a real issue for me though!
     
  6. maril1111 macrumors 68000

    maril1111

    Joined:
    Mar 14, 2010
    Location:
    Denmark
    #6
    Wat issues are you experiencing with the Intel graphics? I have the same one and it is going great graphicswise.
     

Share This Page