Grrrr...Canon Scanners...!

Discussion in 'macOS Mojave (10.14)' started by DelNW, Nov 5, 2018.

  1. DelNW macrumors newbie

    Joined:
    Nov 5, 2018
    Location:
    West Sussex, United Kingdom
    #1
    I have a Canon LiDE 700f scanner, which worked brilliantly - up to now! It ran fine on Windows Xp, Vista, 7, 10, on 32-bit and 64-bit versions ...Linux Mint 16, 17, 18 and now 19 ...it also worked fine on MacOS until I installed Mojave (10.14).

    I even downloaded and installed all the relevant Canon scanner updates for Navigator, LiDE 700f - but will the scanner work?

    Come on, Canon - GET YOUR ACT TOGETHER AND GET THE CORRECT 64-BIT DRIVERS OUT - or lose my custom from now on!

    Any ideas on a "work-around", anyone??
     
  2. fisherking macrumors 604

    fisherking

    Joined:
    Jul 16, 2010
    Location:
    ny somewhere
    #4
    good that there are software options (ie vuescan), but... that scanner's from 2009; amazing it's worked thru as many OSes as it has...
     
  3. flowrider macrumors 603

    flowrider

    Joined:
    Nov 23, 2012
    #5
    ^^^^My Microtek i800 is older than that. I got mine in 2007. Still luv it.

    Lou
     
  4. xbpr macrumors member

    Joined:
    Dec 8, 2008
    #6
    Have you tried the built-in Image Capture app? It works great with my Canon LiDE 100.
     

Share This Page

5 November 5, 2018