Guide: Install Leopard on unsupported Macs

Discussion in 'macOS' started by suneohair, Oct 18, 2007.

  1. bluestar14 macrumors newbie

    bluestar14

    Joined:
    Jul 5, 2009
    #376
    Additional Edits

    i saw another guide for resizing to SL-DVD...DON"T TRY IT, there will be a LOT more things u will have to edit in distribution;):apple:
     
  2. islandselkie macrumors newbie

    Joined:
    Aug 4, 2009
    #377
    Okay I'm new and a computer dummy - but I'm trying to figure out if I can install Leopard from my new Imac to my old gumdrop IMAC (1.25 ghz 1 gig ram) by using your method w/Disk Utility and copying the Leopard Installer disks onto my Lacie external HD - but the installer is on two disks - can I just put them both onto my Lacie, restore them into one desktop package then drag that using the firewire from my new IMAC to my old IMAC, reboot the old IMAC and try to install from the desktop package?

    Sorry if this sounds ridiculous! The old IMAC doesn't have intel.

    Thanks for any advice!

    islandselkie
     
  3. spinne1 macrumors 6502a

    spinne1

    Joined:
    Mar 12, 2005
    Location:
    Hermitage, TN USA (near Nashville)
    #378
    Leopard can be installed on either PowerPC or Intel (unless you have an Intel only version--I don't know if they exist.) Just put in your install disk and boot from it and try to install it.
     
  4. JukeJoke macrumors newbie

    Joined:
    Sep 16, 2009
  5. Mycatisbigfoot macrumors regular

    Joined:
    Jun 22, 2009
    #380
    Snow Leopard will not work on a ppc mac, as it has not been coded for that, there is no point to try it, it just wont work its like trying to put a ford parts in a gm it wont work
     
  6. dollabills macrumors newbie

    Joined:
    Jan 28, 2010
    #381
    i know this is like 2 years old so no one might reply,
    but would this work with the grey restore non-retail dvds from a new imac onto a g4?
    thanks
     
  7. schalliol macrumors regular

    Joined:
    May 7, 2002
    Location:
    Carmel, IN
    #382
    99% sure it won't let you do that. Even if you were PPC to PPC, you'd still have to have the same kind of machine.
     
  8. dollabills macrumors newbie

    Joined:
    Jan 28, 2010
    #383
    oh thanks for the quick reply,
    but so i guess even this long process doesnt get around that?
     
  9. Mr. Retrofire macrumors 603

    Mr. Retrofire

    Joined:
    Mar 2, 2010
    Location:
    www.emiliana.cl/en
    #384
    Yes. It works.

    I used it to install SL within a VM created with VMware Fusion 3.0.2. My Mid 2009 MBP install disc did not work, so i needed to modify it according to this guide. It worked flawless.
     
  10. kleong macrumors newbie

    Joined:
    Jun 20, 2010
    #385
    I have create an osinstall.mpkg according to the guide. I have change the frequency to both return true and to a figure lower. However, when I tried to install, I still get the invalid front bus frequency 660000. Any idea what more should I do?
     
  11. kabeer macrumors newbie

    Joined:
    Jul 23, 2010
    #386
    Kernel panic on install

    Okay, I have a power mac g4 sawtooth single CPU. I purchased a leopard install disk for the cheapest I could find without realising that it wasn't supported on this machine officially (I didn't get snow leopard because I knew that it only supported intel). So I inserted the disk (without modifying) and after booting to it got a kernel panic beginning with "the correct driver could not be found for this platform powermac 3,1". I then tried the open firmware hack many times and the same problem occured. I also tried this guide many times even with putting in the kexts that the guide told me to if I was getting kernel panics but to no avail. I then managed to borrow my freinds intel mac and installed it to my guid partitioned 16 gb flash drive, I then cloned it to my APM partitioned other hard disk using superduper! and when booting got the same issue, I then put in the relevant kexts from the working tiger install but again to no avail
    any advice is appreciated,
    thanks
    Kabeer
     
  12. dsilver668, Apr 28, 2011
    Last edited by a moderator: Apr 29, 2011

    dsilver668 macrumors newbie

    Joined:
    Apr 28, 2011
    #387
    Recent Update "See Comments After Original Post"

    Ok I was going through this tut! Thank you for the original post.
    I did a couple of things different. This was to install VER: 10.6.3 which with updates should put you at 10.6.6 or 10.6.7.
    Symptoms:
    I modified the original lines in his tut but it still failed. After many disks and pain and suffering I decided to put on my programmers cap and go through the ".mpkg" file.
    fist thing I did was change all false statements to equal true minus the one about unsupported systems. If your system is one of those simply remove it.
    Now scroll down a bit. Ok a lot!
    There is this little section about supported systems and you will see lines like
    'MacBookPro5,1',
    In that section be sure to add your MacBook model. If you don't know boot your system off the DVD yes I know you can't install it but you can use the system profiler and get the model number.
    Then wrap up the package again and you can then burn.
    I personally used Carbon Copy Clone otherwise known as CCC.
    I actually used it to "burn" the dmg file to a USB Hard Drive. My understanding is you can also do this to USB Flash drives as well. Imagine having a USB flash drive with all your MAC Models supported! It is awesome!!!!
    If you are in vi just do a search in the mpkg file "/'MacBookPro" and you will find it. It is the only file you need to modify. As newer models arrive, you can update your OS install drive fairly easily.

    Hope this helps!
     
  13. 2040Tech, Jun 21, 2011
    Last edited: Jun 21, 2011

    2040Tech macrumors newbie

    Joined:
    Jun 21, 2011
    #388
    Have you ever tried setting up a NetBoot Server with Mac OS X 10.5 Server I have one setup and its quick and fast also multiple machines can use it at once!!!! Try it, Apple is so smart
    Heres a picture of a Mac OS X 10.5 Unsupported Disk Image made from this guide being turned into a NetInstall Image (Imaged)
    http://cdn2.dailybooth.com/10/pictures/large/441c7639060314fb2a867b82e74335a1_16808489.jpg
     
  14. DerekMessina macrumors newbie

    Joined:
    Nov 23, 2011
    #389
    Awesome! Now I can install leopard on my Mac by myself. I hope it works. Thanks for the tip! It was a big help...
     
  15. Nanashi106 macrumors newbie

    Joined:
    Dec 23, 2011
    #390
    I've got a ver sick problem in step 3. You wrote, that there is a problem with the xar files, but terminal meant that there's everthing okay. It just doesn't work... Help me please!:confused::confused:

    P.S: I hope it's going to work in the end. :)
     
  16. minifridge1138 macrumors 65816

    Joined:
    Jun 26, 2010
    #391
    I had no problem building the image, and creating a boot-able USB drive.

    I hold option, boot from USB.

    I get the grey Apple Logo for a long time (30 minutes maybe).

    Then I get a grey screen with a beachball mouse cursor. It stays that way for 5 hours. Then I gave up and shut it down.

    Is 5 hours normal?
     
  17. Mizino macrumors newbie

    Joined:
    Mar 10, 2016
    #392
    So I'm running into a different problem... I have a quicksilver (non 2002 model) that I've thrown a 9600 into, and it works and runs fine, save for the dead drives I bought it with. I installed a new IDE 20 gig drive that I am pretty certain works, and I'm trying to get the thing to boot into the leopard install disk. But something is odd. Without the updated file from here, the machine sits at a blue screen with a moveable mouse. It never gets farther than that. Now the machine has a 1.5 gighertz proc from OWC, so normally I'd consider the machine fully capable of running Leopard. I did try using a supported Mac installing to a GUID partitioned thumb drive, then mounting the quicksilver in target mode and using CCC to make a duplicate of the thumb drive in the Apple Partition scheme. It does the same thing, or it will kernal panic, or it will sit at the grey mac screen with the little pin wheel going around and around. I'm going to try and do it this way, with the modified installer file and a key drive. But I'm not experiencing the "This system is not supported" kinda thing from the installer so I don't know if that will work.

    I have 1.2 gigs of ram, 20 gig hard drive, 1.5 gighertz g4, and a...Thats something I hadn't thought of...Maybe I don't have a DL superdrive? just a regular single, and thus it can't read the installer? Hence the hang? Maybe. I'm going to start working off the thumb drive now anyway.

    Anyone have any other ideas?
     
  18. Jack Neill macrumors 6502

    Jack Neill

    Joined:
    Sep 13, 2015
    Location:
    San Antonio Texas
    #393
    Have you tried LeopardAssist or any of the other old tools?
     
  19. Mizino macrumors newbie

    Joined:
    Mar 10, 2016
    #394
    I figured the issue out. It was the fact that I was using a ATI radeon 9600, which Mac's KEXT's have issues with. I'm going to replace it and it should work fine.
     
  20. Mizino macrumors newbie

    Joined:
    Mar 10, 2016
    #395

    I actually found out even more, that it was the way I taped up the pins 3 and 11 that was causing the problem I taped up both sides when you are supposed to only tape the back...interesting enough the card will work like that.
     

Share This Page