Windows Guild Wars 2 - mouse going crazy in Parallels 7

NMF

macrumors 6502a
Original poster
Oct 27, 2011
874
20
Before you scold me for playing a gam in Parallels, save it. I'm a power user with tons of experience with PC's and PC hardware, I know how they work and I understand that virtualization is not optimal for gaming.

Ok! Now that we have that out of the way...

I can't seem to get my G400 mouse to work correctly in Guild Wars 2. If I have the mouse "connected" via OSX, the cursor is visible in-game but even the slightest motion causes catastrophic movement, everything goes crazy like I just spun the mouse around at 700mph. If I have the mouse "connected" via Windows 7, the cursor is invisible but mouse movement is perfectly normal.

I've tried setting "smart mouse" to auto, on, off, etc... no changes at all.

Has anyone else figured out a fix for this? Thanks!
 

SlickShoes

macrumors 6502a
Jan 24, 2011
638
0
Incredible, you guys couldn't even make it through the first sentence of my original post.

I really am amazed.
I am sure someone had the same problem you are having in SWTOR but i can't for the life of me find the post or remember how they fixed it, sorry I can't be of more help!
 

Stone1269

macrumors newbie
Jul 13, 2008
11
0
I do not know if this will help, but I once had a very similar problem using Vmware Fusion. The way I solved it was to attach the USB mouse I was using directly to the VM.
 

doh123

macrumors 65816
Dec 28, 2009
1,304
1
its the "SmartMouse" setting... it is stupid :)

The only way I've been able to get the mouse to working games in Parallels is to turn SmartMouse off in Parallels. Sadly this in many games makes the mouse cursor invisible when in fullscreen, so I often have to play in a window (or maximized fullscreen-like window in games that support it).
 

Jazwire

macrumors 6502a
Jun 20, 2009
896
115
127.0.0.1
Hmm ya, I had the same problem with SWTOR (when I was playing it) and it was a SmartMouse setting that fixed it.

Think I did have to plug and unplug the mouse a time or 2 also.
 

ktuimala

macrumors newbie
Sep 3, 2012
1
0
Stone1269 had it right.
I do not know if this will help, but I once had a very similar problem using Vmware Fusion. The way I solved it was to attach the USB mouse I was using directly to the VM.
I game in Parallels all the time on my late 2011 MBP. In many games I have to connect my external mouse directly to Parallels via Devices -> USB. The only caveat here, is you will have to adjust OS X power settings to never turn off the monitor and never go to sleep. Otherwise your mac will suddenly go to sleep/turn the monitor off while you are playing. Some may seem this as inconvenient, but it works flawlessly every time. Frankly, it is a small price to pay.

Hope that gets you back in the saddle!!
 

forteanajones

macrumors newbie
Sep 4, 2012
4
0
I do not know if this will help, but I once had a very similar problem using Vmware Fusion. The way I solved it was to attach the USB mouse I was using directly to the VM.
I tried this but the mouse would no longer move, while the buttons continued to work. (Parallels 6.0.12106, W7 VM.)
 

forteanajones

macrumors newbie
Sep 4, 2012
4
0
I tried this but the mouse would no longer move, while the buttons continued to work. (Parallels 6.0.12106, W7 VM.)
Update: I upgraded to Parallels 7 after posting the above and the solution proposed works now. However, there is a drawback in that GW2 will no longer recognize keyboard input for some reason, and so you also have to connect your keyboard the same way. If you don't need to use your non-Windows stuff simultaneously while playing the game, that may not be an issue. Secondly, with these devices no longer connected to your Mac, the Mac won't realize that there is activity and will go to screensaver automatically, unless you disable that.
 

doh123

macrumors 65816
Dec 28, 2009
1,304
1
Update: I upgraded to Parallels 7 after posting the above and the solution proposed works now. However, there is a drawback in that GW2 will no longer recognize keyboard input for some reason, and so you also have to connect your keyboard the same way. If you don't need to use your non-Windows stuff simultaneously while playing the game, that may not be an issue. Secondly, with these devices no longer connected to your Mac, the Mac won't realize that there is activity and will go to screensaver automatically, unless you disable that.
you shouldn't need anything connected directly... not sure why that was said.

Also, if you just bought Parallels 7, you should ask them for a free upgrade for Parallels 8... why buy the old version?
 

forteanajones

macrumors newbie
Sep 4, 2012
4
0
you shouldn't need anything connected directly... not sure why that was said.
But it worked. What alternative are you proposing?
Also, if you just bought Parallels 7, you should ask them for a free upgrade for Parallels 8... why buy the old version?
I was given a spare license and 8 is too new to be worth the potential risks, from my perspective.
 

doh123

macrumors 65816
Dec 28, 2009
1,304
1
But it worked. What alternative are you proposing?
Alternative? I had already posted it a while back in the thread...
I've seen that same exact issue in several different games in Parallels 7... turning SmartMouse off like I said before fixed all the rest of them.
 

forteanajones

macrumors newbie
Sep 4, 2012
4
0
Alternative? I had already posted it a while back in the thread...
I've seen that same exact issue in several different games in Parallels 7... turning SmartMouse off like I said before fixed all the rest of them.
Ah, I must have missed that post, thanks for clarifying. Do you experience the same issue in Coherance mode that you mentioned was afflicting Full-screen mode?

I may stick with what is working now since I happen to be a right/left handed mouser and have no problem with keeping a second set of mouse/keyboards hooked up, but I'm curious. (I can test it myself tomorrow.)
 

doh123

macrumors 65816
Dec 28, 2009
1,304
1
Ah, I must have missed that post, thanks for clarifying. Do you experience the same issue in Coherance mode that you mentioned was afflicting Full-screen mode?

I may stick with what is working now since I happen to be a right/left handed mouser and have no problem with keeping a second set of mouse/keyboards hooked up, but I'm curious. (I can test it myself tomorrow.)
you cannot easily move the mouse back and forth easy without SmartMouse... I also never run Coherence since the whole Windows desktop in its own fullscreen desktop.. with just a 4 finger swipe back and forth... the SmartMouse off doesn't really affect it as much. I like to keep Windows apps separate...
 

blackbear219

macrumors regular
Sep 5, 2012
192
17
I got the mouse working using the tips from this thread, however I find that the performance isn't very good. Some games run great on max in Parallels, but not this one. I will just have to keep booting directly into Windows for this one. It is a beautiful game on max settings.
 

Snowtygar

macrumors newbie
Sep 22, 2012
1
0
Singapore
Solution for Parallels 7 & VMWARE Fusion 5 - Spinning Mouse

Hi, finally found how to fix this annoying mouse issue when using virtual machine software on the Mac.
VMware Fusion 5:
In VMware Fusion 5 goto the menu - VMware Fusion -> Preferences... -> General
and then select Gaming: "Always optimize mouse for games"

This will dedicate the mouse to the VM and makes the mouse act Normal - If you want to use the mouse outside the VM - use Control+Cmd to release the mouse again.
Optional: You might want to change the mouse sensitivity in Windows Control Panel to make it better playable.

Parallels 7
In Parallels 7 goto the Parallels Virtual Machines list - Right-click the windows VM - select Configure -> Options -> Advanced then select Smartmouse: Off

The mouse cursor might disappear in game, to fix this switch the screen mode to "Full-screen Windowed"

If you want to use the mouse outside the VM - use Control+Alt to release the mouse again.
Optional: You might want to change the mouse sensitivity in Windows Control Panel to make it better playable.
 

ThatGuyInLa

macrumors 6502
Oct 26, 2012
482
513
Glendale, Ca.
None of this works.

Yeah none of these solutions work. I've been trying to get the mouse to work in Parallels since version 5 and it simply doesn't.

CORRECTION...

It works as advertised with Smart Mouse on or off provided you are not moving the mouse quickly, as you would in a game. With gaming and fast mouse movements, the mouse "dances across the screen" making gaming unplayable.

So, "connect the mouse directly to Parallels." Okay so when you do this, the mouse pointer vanishes never to return; from the desktop or in a game. It has been this way since v5. Parallels has never responded to this issue.

Bootcamp it is...and I hate Parallels for making me use Windows. ;)