Guitar Pro & Snow Leopard

Discussion in 'Mac Apps and Mac App Store' started by Apocrathia, Aug 30, 2009.

  1. Apocrathia macrumors 6502

    Joined:
    Jan 6, 2009
    Location:
    University of South Alabama
    #1
    I'm wondering if anyone else is having this problem, or if I'm just doing something wrong.
    I have Guitar Pro 5.3b1 on my system, which is claimed to be snow kitty friendly. However, every time I open the application, it immediately crashes. Any ideas? I can't really think of any alternatives either, other than finale, and that's just overkill.
     
  2. Pickleman77 macrumors member

    Pickleman77

    Joined:
    Dec 26, 2007
    #2
    I'm having the exact same problem... GP5.3 worked great in Leopard, but ever since I upgraded to Snow Leopard yesterday, it seems to always crash after the splash screen :(
     
  3. SuperSnake2012 macrumors 6502a

    Joined:
    Oct 11, 2005
    Location:
    NY
    #3
    Doesn't work for me either, it crashes right after the splash screen goes away. They had to release a patch to make it Leopard friendly like two years ago, so I guess I'll just have to keep waiting. :(
     
  4. Apocrathia thread starter macrumors 6502

    Joined:
    Jan 6, 2009
    Location:
    University of South Alabama
    #4
    Here's the crash report, if anyone can make anything of it. I haven't started reading through it, so feel free to state the obvious.
    It's a bit to large to post here (by about 6000 characters) so I'm going to post it to pastie: http://pastie.org/599763
     
  5. jadedsun macrumors newbie

    Joined:
    Aug 31, 2009
    #5
    I have the same version also. You cannot use the shortcut to open the file, but for some reason if you launch guitar pro and then use File -> Open, you can get your file to load under snow leopard.
     
  6. SuperSnake2012 macrumors 6502a

    Joined:
    Oct 11, 2005
    Location:
    NY
    #6
    Ah, when I opened a .gp3/.gp4/.gp5 file by clicking the shortcut, it would crash. But if I open it from the Applications folder, it runs okay. At least I can run the program now! :D
     
  7. Loge macrumors 68020

    Loge

    Joined:
    Jun 24, 2004
    Location:
    England
    #7
    More often than not Guitar Pro is failing to open from the Applications folder under Snow Leopard - sometimes it opens, but typically it doesn't. I've logged this problem with their customer support.
     
  8. richpjr macrumors 68030

    richpjr

    Joined:
    May 9, 2006
    #8
    Ah, bless you! I was seriously bummed that this broke when I upgraded.
     
  9. LurchNC macrumors regular

    Joined:
    May 1, 2008
    #9
    I can't get guitar pro to open anything without crashing. I sent a crash report to their tech support on Monday, but haven't heard anything yet. I'm loosing a little hope. lol
     
  10. Ed91 macrumors 6502

    Joined:
    Dec 22, 2007
  11. sacredgeometry macrumors newbie

    Joined:
    Jan 29, 2009
    #11
    try tuxguitar i havent tried it but its a free alternative, im downloading now to test if it works.

    EDIT: nope not a chance sorry guys
     
  12. little-dreamer macrumors newbie

    Joined:
    Sep 5, 2009
    #12
    I'm having this problem also. This is the reply I got from Guitar Pro support when I questioned snow leopard support:

    I sent a reply back with my crash report. Hopefully this problem will be fixed soon, as a guitar teacher, this program is quite important to me.
     
  13. richiehernandez macrumors newbie

    Joined:
    Sep 5, 2009
    #13
    It's easy to get Guitar Pro working under Snow Leopard. All you have to do is right-click the Guitar Pro icon in Finder, select Get Info, and click on the "Open using Rosetta" box. Install the update when prompted, and once that finishes, Guitar Pro opens just like normal, even by clicking on a shortcut.
     
  14. LurchNC macrumors regular

    Joined:
    May 1, 2008
    #14
    I downloaded the latest from the customer area, but it's still 5.3 not 5.3.1.

    Edit:
    OK, I took a guess and got lucky. If you use their link in the customer area it reads:

    http://www.guitar-pro.com/download.php?idfile=gp53_mac

    I changed it to this:

    http://www.guitar-pro.com/download.php?idfile=gp531_mac

    and it got the 5.3.1 version. I installed it and it seems to work.

    RSE Guitars : https://www.guitar-pro.com/download.php?idfile=bk531_mac_guitars
    RSE Bass: https://www.guitar-pro.com/download.php?idfile=bk531_mac_basses
    RSE Drums: https://www.guitar-pro.com/download.php?idfile=bk531_mac_drums
     
  15. richpjr macrumors 68030

    richpjr

    Joined:
    May 9, 2006
    #15
    Excellent find! I can now open files by clicking on them! Thank you!
     
  16. little-dreamer macrumors newbie

    Joined:
    Sep 5, 2009
    #16
    Brilliant thanks! Downloading now.
     
  17. Duendito macrumors newbie

    Joined:
    Sep 8, 2009
    #17
    Thanks for the updated links. I swear, as much as I love using Guitar Pro, sometimes you gotta wonder if the people at the top are asleep!! No offense intended to the developers of this fine product.

    So, I updated to 5.3.1, but now the Tools window is transparent all the time! ARRRGGHH. Is anyone else experiencing this as well? Makes the window unusable now, which is almost as bad as the program crashing all the time.
     
  18. Duendito macrumors newbie

    Joined:
    Sep 8, 2009
    #18
    I have reverted to 5.3, and now...

    (So as mentioned in my last post, after upgrading to 5.3.1, the Tools window became transparent 100% of the time, effectively making GP useless.)

    So I reverted GP to 5.3 and following the advice of another user in this thread, I did Get Info on the app and chose "Open using Rosetta".

    Well, the program opens ... but now it is running rather slowly! There is a big drop in performance, about 1/2 the speed.

    Guitar Pro devs, you gotta do better than this. Make a patch for 10.6, and the patch needs to be patched? That's just not cool.

    EDIT SEP 9: I just remembered that you can turn off transparency in the Preferences, so I am going to try reinstalling 5.3.1

    EDIT SEP 9: the reinstall was worth it. Transparency is off and 5.3.1 is working nicely so far... :)
     
  19. glamb macrumors newbie

    Joined:
    Jul 25, 2008
    #19
    Any new of GP 6?

    They have been promising it for a while - now would be a perfect time!!
     
  20. Gnuus macrumors newbie

    Joined:
    Sep 10, 2009
    #20
    It's only working for me when I don't use RSE.

    As soon as I try to use RSE, the program quits unexpectedly.
     
  21. Sandman1969 macrumors 6502a

    Sandman1969

    Joined:
    Nov 5, 2007
    #21
    I was having Crash issues with GP5.3 (havent' updated to 5.3.1 yet.) if I just double-clicked on a GP3/4/5 file. However, if I just launched that application, and then double-clicked the same file it would work.

    Will get 5.3.1 when I get home. Thanks for the links!
     
  22. zodiac909 macrumors newbie

    Joined:
    Sep 12, 2009
    #23
    when i click on your link it says un-authorized access..

    NVM logged in on a different window and its download now :) thanks alot!!!!!
    SORRY FOR THE triple post
     
  23. big duck macrumors member

    Joined:
    Oct 16, 2007
    #24
    it seems to have the exact same problem as when I upgraded to leopard a few years back, and If I remember correctly it took them a while to sort it back then too.
     
  24. badhorsie777 macrumors member

    Joined:
    Jan 31, 2003
    #25
    Yeehaw!!!! I'm so glad you figured out to add the extra little digit. No more crashing here, and no rosetta layer!!!

    Thanks a ton!
     

Share This Page