Haptics stops working?

Discussion in 'iPhone' started by syphern, Sep 26, 2016.

  1. syphern macrumors 6502

    Joined:
    Jan 15, 2008
    #1
    Hey guys I have a iPhone 7 32gb
    I have noticed that the Taptic Engine haptics stops working throughout the system e.g. Pull up menu. I haven't disabled it from settings.

    When I restart the phone it comes back?
    Is this a hardware issue? Anyone else experiencing this?
     
  2. kuechi macrumors member

    Joined:
    Sep 13, 2016
    #2
    Just restart your phone. It happened to me, I think its a software thing
     
  3. syphern thread starter macrumors 6502

    Joined:
    Jan 15, 2008
    #3
    But every time? Happens daily then I have to restart then it works.
     
  4. kuechi macrumors member

    Joined:
    Sep 13, 2016
    #4
    You should call apple man. Maybe thats a hardware issue then.
     
  5. mjjferreira macrumors member

    Joined:
    Sep 17, 2016
    #5
    I have my system haptics disabled.
    I think that it doesn't improve the user experience, and it will only dry the battery faster and reduce the hardware lifetime. :p :p
     
  6. Leon88 macrumors member

    Joined:
    Aug 18, 2008
    Location:
    Melbourne, Australia
    #6
    Same issue here with my 7 Plus. It'll work for a day maybe then stop again until I restart the phone
     
  7. Newtons Apple Suspended

    Newtons Apple

    Joined:
    Mar 12, 2014
    Location:
    Jacksonville, Florida
    #7
    If it starts working after a reboot it is not an indication of a hardware error. More like a software error.
     
  8. kawa636r macrumors regular

    Joined:
    Feb 28, 2016
    Location:
    Spain
    #8
    also happened to me in 10.1 beta 1, i think it's totally a software issue
     
  9. jamesrick80 macrumors 68020

    jamesrick80

    Joined:
    Sep 12, 2014
    #9
    The reason why haptic feedback is unnecessary...
     
  10. DougFNJ macrumors 6502a

    DougFNJ

    Joined:
    Jan 22, 2008
    Location:
    NJ
    #10
    I had this problem with my 6s. The bigger problem with the haptics turning off was ALL vibrations didn't work including phone ringing on vibrate and email and text notifications. I always keep my phone on vibrate so always saw the missed calls. They swapped the 6s 5 times including a brand new. I also deleted the phone and started over and the problem always came back either 3 days or a week.

    Please put in support tickets to AppleCare.
     
  11. steelo3232 macrumors regular

    Joined:
    May 25, 2016
    #11
    Same thing happening to me with the 7plus.... stops working randomly restart the phone fixes it
     
  12. syphern thread starter macrumors 6502

    Joined:
    Jan 15, 2008
    #12
    Does it happen all the time and you have to reset it?

    Also who restored from new and who restored from a backup I did it from a backup of 6s plus
     
  13. rulymammoth macrumors member

    Joined:
    Jun 8, 2015
    #13
    Just started happening to me the last couple of days. The Taptic Engine clearly still works because the home button still clicks. But everything else like force touch on icons and scrolling doesn't work.
     
  14. Cvx5832 macrumors regular

    Joined:
    Nov 2, 2014
    #14
    Is this a plus thing? Because I've never experienced it on my launch day 7.
     
  15. syphern thread starter macrumors 6502

    Joined:
    Jan 15, 2008
    #15
    No I have a regular 7
     
  16. kawa636r macrumors regular

    Joined:
    Feb 28, 2016
    Location:
    Spain
    #16
    trash yourself
     
  17. LoveToMacRumors macrumors 68020

    LoveToMacRumors

    Joined:
    Feb 15, 2015
    Location:
    Canada
    #17
    Be happy, go to Apple and they'll give you a new watch.
     
  18. syphern thread starter macrumors 6502

    Joined:
    Jan 15, 2008
    #18
    Honestly I don't think it's a software issue. I'm on 10.1 beta and it's still there!?
     
  19. kawa636r macrumors regular

    Joined:
    Feb 28, 2016
    Location:
    Spain
    #19
    they replaced my device, i will let you know when it will arrive to me
     
  20. DougFNJ macrumors 6502a

    DougFNJ

    Joined:
    Jan 22, 2008
    Location:
    NJ
    #20
    5 6s devices 2 of them were brand new....all the same exact problem, and now my 7 Plus just did the same thing, it cannot possibly be hardware.

    Aside from device swapping, which be warned, in a few weeks it will happen again, anybody get any answers from Apple on this?
     
  21. syphern thread starter macrumors 6502

    Joined:
    Jan 15, 2008
    #21
    Nope I'm getting mine replaced. The genius said he wasn't aware of the issue but tested my phone and there was an issue so they are due to replace it.
     
  22. syphern thread starter macrumors 6502

    Joined:
    Jan 15, 2008
    #22
    brand new iphone and the problem has gone. I noticed it when the phone over heats with GPS and a call im using it the exact same way as i was before. its hardware mate apple finally exchanged my phone and admitted its hardware after 9 hours of telling them its not a software issue. Several resets from new later the genius said yeh maybe its the device, he testedit and it failed in front of him...
     
  23. DougFNJ macrumors 6502a

    DougFNJ

    Joined:
    Jan 22, 2008
    Location:
    NJ
    #23
    What was driving me nuts was that it would take 2 weeks with every new phone the gave me to happen. So I would think everything was good to go and then the problem would resurface.

    That last update mentioned that it fixed a problem with haptic not working. Knock wood, so far so good. I wouldn't had cared as much if the Taptic didn't link directly to the phone not vibrating for phone calls and notifications.
     
  24. warburg, Oct 31, 2016
    Last edited: Oct 31, 2016

    warburg macrumors 6502a

    Joined:
    Jul 27, 2008
    #24
    By haptic feedback, which haptics seem to be giving trouble, the home button, vibrations on ring? All haptics? I find that the haptic feedbacks on the iPhone 7 are very subtle. Perhaps some people are expecting too much.
     
  25. DougFNJ macrumors 6502a

    DougFNJ

    Joined:
    Jan 22, 2008
    Location:
    NJ
    #25
    In my case it began with the 6s. Haptics randomly stopped working. Not in a subtle way, all phone features that used a vibration in any way stopped working. The only way to get them to work was by powering off and on.

    The 7 plus seemed fine until the same thing happened. Home button worked, anything else that would vibrate didn't. Again, I wasn't missing it because it weakened, it just didn't work. I'm hoping that last update fixed it for good.
     

Share This Page