HD Locked after failed OS upgrade to high sierra

Discussion in 'macOS' started by ciaoantigua, Apr 14, 2018.

  1. ciaoantigua macrumors newbie

    Joined:
    Apr 14, 2018
    #1
    I have a mid 2010 Imac running Yosemite and yesterday I tried to upgrade to High Sierra. The download seemed to go fine but the installation did not. I go the following message
    "MacOS could not be installed on your computer. The installer resources could not be found... Quit and restarts etc.."
    Every time i try to boot normally the system tries to install the new OS via the installer I get the same message after
    I can boot into recovery and when I run disc utilities I can see the main internal HD and the virtual disc containing the new OS installer. The virtual disc is already mounted but I cannot delete it or do anything to it. The internal HD is there but cannot be mounted.
    When I try to install new OS, it seems to connect to the internet OK but the internal HD is not offered as an installation destination. The only drives it shows are the installation virtual disc and the recovery partition of the internal drive (which is locked).
    If I boot holding the option key - I can see 3 volumes listed. The virtual disc (installation), the HD and the recover partition. If I try to select the HD it says it is locked.

    I also tried booting from a target drive in another Imac. Booted up fine but still unable to mount the internal HD
    It appears to be locked and the OS installation virtual drive appears to be
     
  2. Fishrrman macrumors P6

    Fishrrman

    Joined:
    Feb 20, 2009
    #2
    "I also tried booting from a target drive in another Imac."

    What OS is running on the other iMac?

    Do you have any kind of backup for the 2010 iMac that won't boot?

    Would you be willing to completely erase the internal drive and "start from scratch"?
     
  3. jameshare macrumors newbie

    Joined:
    May 30, 2018
    #3
    I think i have the same issue since updating, I ended up erasing the internal drive and now i cant upload the OS, it states that the disc is locked....
    --- Post Merged, May 30, 2018 ---
    Can anyone help?
     

Share This Page