HDD sata150, 3.5" w/t USB ext. IDE/SATA adapter not recognised

Discussion in 'PowerPC Macs' started by basilt, Oct 4, 2016.

  1. basilt macrumors regular

    basilt

    Joined:
    Aug 15, 2016
    #1
    hello,

    i recently bought an external usb 2 IDE/SATA adapter to mount my working ok, maxtor diamondmax 10 hard drive on my PPC G5. the power supply unit of adapter states OUTPUT 5, 12V @ 2A. INPUT 0.8A.

    HDD states +5, 12V @ 1.5A

    I plugged it in, power green led works on the power supply unit, then connected the cables etc. ok. usb cable on the back usb ports of mac (are all occupied now).

    The hdd does not have any jumpers. if it is jumper issue can you advise which pins (location) to activate.

    The hdd does not spin at all, not powering up. Does not show in apple Disk utility also.
    I tried the same with a windows 7 laptop. not showing there as well.

    Anybody who can help to mount this drive externally and operate it properly ?
    I also have a digital multi-meter which dont know how to use to measure voltage, but with some help i can do it to see if current passes to the 4-colored molex DC power adaptor cable/ connector.

    Thats all. Any responses will be appreciated :-D
     
  2. for this, Oct 4, 2016
    Last edited: Oct 4, 2016

    for this macrumors regular

    Joined:
    Nov 18, 2014
    #2
    I think I've one like yours. I've used it with with a WD Blue WD6400AAKS. Are you sure the HDD is not faulty?

    Anyway, if you suspect it's the adapter, you can measure voltages from the adapter's molex pins.

    [​IMG]
    The funny thing about my unit is the pin 2 hole is all plastic, it doesn't do anything, to save cost, perhaps. If yours is the same, just use the pin 3 instead. Insert the meter's red probe into the pin 1 hole, then the black probe into the pin 3 hole. It should read about 12v (mine reads 11.85v). Then insert the red probe into pin 4 hole, now it should read about 5v (mine reads 5.4v).
     
  3. basilt, Oct 4, 2016
    Last edited: Oct 5, 2016

    basilt thread starter macrumors regular

    basilt

    Joined:
    Aug 15, 2016
    #3
    hi forthis !

    thanks for the reply.

    hdd works ok.

    my brand is powertech (chinese i presume)
    The no2 is plastic true.
    I set meter to read V~
    i have mastech my-68 model meter

    Results.

    When 1 plug the black to 12V hole reads 8.80
    if i put the black in 12V and red probe in the GND hole it reads .007

    Repeating for the 5V hole with black probe only reads 4.90
    with the black in 5V and red in GND reads .007

    any clues whats going on ?
     
  4. for this macrumors regular

    Joined:
    Nov 18, 2014
    #4
    From the way you describe it, it's not clear if you measure it right. But if you reverse the probes (red to ground—pin 3, black to power—pin 1 or 4), it should read negative voltage (about -12v or about -5v). Otherwise the power supply unit is faulty.
     
  5. basilt thread starter macrumors regular

    basilt

    Joined:
    Aug 15, 2016
    #5
    hm.... i believe the psu is faulty. i will do the negative way tomorrow for a second test.
     
  6. basilt thread starter macrumors regular

    basilt

    Joined:
    Aug 15, 2016
    #6
    well... the news are.
    Today, i tried to plug in the cable in my power supply, and Green light did not lit.
    I swaped the cable with one of my RAID unit and when connected it 'exploded' !
    Power unit of adapter smells burning, my wall mounted- earth leakage breaker
    disconnected electricity, my mac went off that time....

    And when i powered back again, mac started ok, BUT my second partition was empty
    and finder could not see any data on it at all. Date was also reset.

    I run hdd rescue utility, quick scan, which shows files for recovery.
    I performed another restart, after i run disk utility to repair disk permissions and
    when i logged in, all partitions show now correctly. Just finished my backup now.....

    So, the brand and model of the adaptor is:

    POWERTECH product code CAB-U049. USB 2 sata/ide adapter to keep an eye on it.

    Thanks for your help again. I will wait to see what the company will say about replace or
    refund. The good news is.. my data is back...
     
  7. for this macrumors regular

    Joined:
    Nov 18, 2014
    #7
    You make me afraid about mine (bought from eBay but they're all probably from the same manufacturer).

    Glad your data is safe.
     
  8. basilt thread starter macrumors regular

    basilt

    Joined:
    Aug 15, 2016
    #8
    Your diagnosis was correct !

    chinese crap for sure... but cheap and if works its good !

    If you want to be on the safe side, one thing to do before plugging it in the power socket in your house,
    is to connect the power cable 3-pin end to the input port of the adapter, then connect the rest of cables,
    and after that, plug it in the socket. This way it will not cause (possibly) any circuit damage to the power
    adapter, from what i understood with mine.

    I read on ebay, that these get burned easily and need to be replaced frequently for a reason.
    I guess you are lucky to have the device working ok, fingers crossed !

    ta.
     

Share This Page