Help! Dock magnification/menus/hot corners not working!

Discussion in 'macOS' started by kingofkolt, Jun 30, 2007.

  1. kingofkolt macrumors 6502

    Joined:
    May 2, 2007
    Location:
    Boston, MA
    #1
    Guys, I'm kinda freaked out about this. Yesterday I was using the Vista side of my 2.4Ghz 15" MBP most of the day, and then I switched over to the Mac side last night. I don't know if being in Vista for that long is what caused this -- probably not -- but I do know that I usually don't use Vista that long at once. But anyways, here's my problem:

    When I got into Mac OS X yesterday, it started getting all funky on me. First of all, my dock. When I roll my mouse over the dock, it doesn't magnify at all. I have dock magnification turned on about 1/2 of the way over, and yet it doesn't react to my mouse at all. Also, when I click on an icon to open it, it DOES magnify that icon (and the ones around it) temporarily as it "bounces" to indicate the program is opening. Then I move my mouse away, and the magnification stays there for a few seconds! So my mouse is back in the middle of the screen but the icon is still frozen as enlarged. It goes away after a few seconds, but not with the usual smooth shrinking animation (it just instantly is smaller). Lastly, the program I open from the dock does NOT come to the forefront. For example, I just opened TextEdit from the dock to remind myself of what happens, and it opened behind Firefox, not in front of it. So to actually go get TextEdit, I have to Command+Tab and get it. So those are my dock problems.

    Also, my menus are acting funny. You know how, usually, when you open a menu from the bar at the top of your screen (sorry, not sure what it's called, I haven't been a Mac user for long), and you move your mouse over the options, each individual option highlights in blue? And when you move your mouse over an option that has an arrow to its right to indicate a sub-menu, the sub-menu pops out on its own? Well, neither of those are happening anymore. In fact, when I click the option that has an arrow, the whole menu just goes away as if I had clicked away from it or something.

    Lastly, my hot corners aren't working. Simple as that. I have bottom left set for Dashboard, and bottom right for Expose, and neither respond at all.

    To recap: a lot of the very basic functions I rely on in the Mac OS X side of my computer just stopped working for me and I have absolutely no idea why. And as a side note, I had not downloaded the MacBook Pro Software Update before this started happening. When it started, I immediately downloaded the update but it didn't fix it.

    Help!! :(
     
  2. iBookG4user macrumors 604

    iBookG4user

    Joined:
    Jun 27, 2006
    Location:
    Seattle, WA
    #2
    Create another user account and log into that to see if the same things happen (make sure you replicate the system preference settings). There have been somethings the bootcamp does to the OS X side before, like resetting the time and date, so bootcamp may have something to do with it. Also, try restarting, just in case that works.
     
  3. kingofkolt thread starter macrumors 6502

    Joined:
    May 2, 2007
    Location:
    Boston, MA
    #3
    Believe me, I've restarted many times... But as for creating another user account, does that create a whole new set of folders for that user that takes up a bunch of space on the hard drive? And if so, are those folders easily removable once I delete the new user?
     
  4. iBookG4user macrumors 604

    iBookG4user

    Joined:
    Jun 27, 2006
    Location:
    Seattle, WA
    #4
    It would not take up a bunch of space on the hard drive at all and it is very easy to remove the user. Although I would suggest that you keep it for times like this, I have one and once I run into a problem I log into my second account (I don't touch it otherwise) and see if the same problem happens.
     
  5. kingofkolt thread starter macrumors 6502

    Joined:
    May 2, 2007
    Location:
    Boston, MA
    #5
    K, well, I went ahead and made a "Test user" and it's got all the same problems. Windows don't come to the forefront, dock doesn't work, hot corners not working, etc...
     
  6. kingofkolt thread starter macrumors 6502

    Joined:
    May 2, 2007
    Location:
    Boston, MA
    #6
    From my other thread about this:

    Unplugging and replugging my wireless mouse fixed the problem... Who'da thunk it? Very weird... but anyway, issue (at least temporarily) resolved. Thanks.
     
  7. cuts macrumors newbie

    Joined:
    Nov 2, 2006
    Location:
    melbourne
    #7
    thanks!!

    nice work, CrzyCanuck72.

    I've been having the exact same problems for a while. Now it's fixed! Ya gotta love these forums...

    thanks again!
     
  8. MaTiCeK macrumors member

    Joined:
    Apr 15, 2006
    #8
    Sorry to revive an old topic. I had the exactly same problem on Leopard. Unplugged my Mouse and it worked again!

    Thx!
     
  9. Aflascter macrumors newbie

    Joined:
    Jan 19, 2008
    #9
    Yesss !!! Brillant

    I had exactly that same problem, but after installing microsoft office 2008. So I was pulling my hair and cursing microsoft until i came across that thread, and did what was oddly suggested : unplug and replug my wireless mouse . AND IT WORKS !!!!

    this deserves a mention in the best 2008 discoveries. I am sure other people have/will have that same problem so allow me to bump that thread to make it visible to others it happens this way...
     
  10. yoda138 macrumors newbie

    yoda138

    Joined:
    Feb 7, 2008
    Location:
    Hong Kong
    #10
    Sorry but hot corners not working and no external mouse

    Please help, besides this cannot seem to shut down apart from pressing the Power Key for a couple of seconds...what's wrong with my Macbook Pro?
     
  11. Rustman macrumors regular

    Rustman

    Joined:
    Aug 7, 2007
    Location:
    England
    #11
    Many, many thanks for this.

    I noticed the same behaviour today and started to panic that something was dying in OSX.

    I've recently installed the 10.5.3 update and Parallels 3 Build 5600 and assumed it was odd behaviour caused by one of these. As it turns out, it doesn't appear so.

    I have a Wireless Logitech MX1000 Laser mouse that up until now has been just fine thanks to Controllermate configuration.

    This fixed the issue and I was getting ready to reinstall OSX which wasn't something I was relishing the idea of.

    Here's some keywords for those searching for the same problem.

    "Dock not working" "Hot corners not working" "Dock magnification".

    Hopefully this behaviour is just a glitch that won't keep happening. I like my wireless mouse.
     
  12. jal002 macrumors newbie

    Joined:
    Jun 21, 2006
    #12
    It's Bluetooth

    I ran with this thread because I was having the same problem, but the thing is that I don't have a wireless mouse, I am using my trackpad, so, trying to figure out the things in common with my problem, I turn off my bluetooth, (I'm using a aluminum wireless keyboard) and it started to work inmediatly... Kind of odd, but, when I turn the bluetooth off my dock and hot corners work just fine.... kind of odd... :eek:
     
  13. michaeltherrien macrumors newbie

    Joined:
    Apr 2, 2008
    Location:
    Shelburne, VT
    #13
    Fix For This Issue:

    Hello All,
    I hope this can help someone in the future. If you are having this problem, it is because the Dock is hanging ("Dock" consisting of the Dock itself, Dashboard, and Expose). It is more than likely a Widget that is hanging. Don't waste your time with the recommendations above.

    To fix this immediately, follow these steps:

    1. Hit Apple (Command) + Space (Spotlight)
    2. Type Terminal
    3. Hit return
    4. Type "ps -ax | grep Dock" (without the quotes)
    5. Find the number (aptly referred to as 'PID#') at the beginning of the line that contains "/System/Library/CoreServices/Dock.app/Contents/MacOS/Dock -psn_#_#######" (Where # is any number)
    6. Type "kill PID#" (without the quotes)

    Your Dock will go away, reload the Dock, Dashboard, and Expose, and you'll be good. If the Dock doesn't disappear after Step 6, Type "kill -9 PID#" (without the quotes) and it will forcibly quite the Dock process.

    Mike Therrien
     
  14. zager Guest

    #14
    Simple

    Or simply hit Activity Monitor (eg. by Spotlight) and Quit "Dock" there! Yeah :)
     
  15. ixokai macrumors newbie

    Joined:
    Oct 5, 2009
    #15
    Actually, I had done that on my own. Both the unmodified kill and kill -9; neither worked. Only then did I go googling and found this, and removing and re-inserting the USB plug of my wireless trackball is what immediately fixed it.
     
  16. sweet160 macrumors regular

    sweet160

    Joined:
    Oct 2, 2006
    Location:
    Ecuador
    #16
    Had the same problem, was freaked out

    calm now
    everthing under control

    thanks to this thread.

    Thanks!
     
  17. ebony macrumors regular

    Joined:
    Mar 22, 2007
  18. jnjewlz macrumors newbie

    jnjewlz

    Joined:
    May 25, 2010
    Location:
    Florida
    #18
    Zager... You da man.

    Thanks!

     
  19. basslovr7 macrumors newbie

    Joined:
    Jun 7, 2010
    #19
    Worked for me! Thanksamuch!!!
     
  20. yossim macrumors regular

    yossim

    Joined:
    Mar 24, 2009
    Location:
    Pacific Northwest
  21. maxpower491 macrumors newbie

    Joined:
    Sep 14, 2010
    #21
    I think you're going to get a kick out of this. I feel like the problem that I'm having is the same problem that alot of people are having, and even though the unplugging the mouse didn't work for me, I think I realized what it might've been linked to.


    After I unplugged the mouse I realized that my dock did infact magnify and work as it was supposed to, but after I plugged my mouse back in the problem came right back. It was at that point I started looking into the hardware and realized it was a pretty stupid fix. The button on the left of my mouse had some gunk on it which was keeping the mouse button held in. I simply removed it and BLAMMO back to normal. The dock functions like a sticky when one of the 2 left or right buttons on a 4 button mouse is held down.

    Don't believe me? Give it a shot, it functions just like the problem =p.

    Glad I could help if anyone had this simple fix =p. It would explain the plugging / unplugging simply moving the mouse to get the button to unstick.
     
  22. ken1958 macrumors newbie

    Joined:
    Mar 10, 2009
    #22
    Mouse did the trick...

    Thanks for the tip. Yes, I just did that and my dock is reacting properly. I had done a whole utility check and all I needed to do was simply unplug and plug back in. Thanks. :)
     
  23. gcoghill macrumors member

    gcoghill

    Joined:
    Sep 14, 2008
    Location:
    Ohio
    #23
    I'm seeing the same issues as everyone else here, however I do not have a USB mouse. Currently my setup is a Magic Trackpad and a Wacom Intuos4 graphics tablet.

    Oddly, the Dock magnification and the menu highlight on mouseover works fine with the Wacom, but not with the Magic Trackpad. I also have a Magic Mouse, and I do recall seeing the same issues. Turning off/on the MTrackpad does not fix anything. Unplugging the Wacom and replugging it in does not fix things.

    A reboot will always fix it, but it's a huge pain in the neck. It does seem to have something to do with the system going to some sort of standby mode or something, however I do not sleep my Mac Pro since I run things constantly. I do however set the displays to sleep.

    Turning Bluetooth off and back on (as well as doing so again for the MTrackpad) does not help.
     
  24. chsnyder macrumors newbie

    Joined:
    Nov 14, 2010
    #24
    Mouse unplug works!

    Who would have thought? After running all kinds of diagnostics and cleaning, the mouse unplug fixed the problem. Thanks
     
  25. kraftwerk macrumors newbie

    kraftwerk

    Joined:
    Oct 29, 2006
    Location:
    London, UK
    #25
    Phew!
     

Share This Page