HELP! NO Internet connection after using Terminal (DNS Disabled? / mDNSResponder)

Discussion in 'Mac Basics and Help' started by mystic08, Sep 9, 2013.

  1. mystic08, Sep 9, 2013
    Last edited: Sep 9, 2013

    mystic08 macrumors newbie

    Joined:
    Sep 9, 2013
    #1
    Somebody please help and I will seriously send you cookies or a donation.

    I have a new mac mini (purchased around janaury, 2013) - it is running 10.7.5

    Earlier today I was fiddling with Terminal trying to do a few things like clearing the DNS cache/flush, sudo killall -HUP mDNSResponder (which didn't seem to work) then I tried to unload then load the /System/Library/LaunchDaemons/com.apple.mDNSResponder.plist -- anyways I believe I have disabled my DNS because my WIFI symbol at the top is connected but when I open the web browser I get nothing and my other computers and devices work fine. I think I have to re-enable the DNS but canno't find a solution ANYWHERE on the dang internet. Everything I try in Terminal will give me permission denied and I really don't have any idea what I'm doing. ANY help would be greatly appreciated. I don't know how to go about resolving this :(:(:(:(:(:(

    Mike.
     
  2. opinio, Sep 9, 2013
    Last edited: Sep 9, 2013

    opinio macrumors 65816

    Joined:
    Mar 23, 2013
    #2
    Find your primary and secondary DNS from your ISP and check it is in your router settings. If not, input the numbers.

    Also you can add the DNS settings in your network settings.
     
  3. philipma1957 macrumors 603

    philipma1957

    Joined:
    Apr 13, 2010
    Location:
    Howell, New Jersey
    #3
    once you fix it buy yourself a cheap hdd and clone a backup
     
  4. mystic08 thread starter macrumors newbie

    Joined:
    Sep 9, 2013
    #4
    Guys, thank you both for the advice but still no luck. I strongly believe the way to fix it is to re-enable the DNS from Terminal which is broken down into two steps. First I need to find a way on how to go about fixing the "permission denied" problem on Terminal, once I figure that out I believe all I must do is type the bottom line of code into Terminal and things should be working again.

    sudo launchctl load -w /System/Library/LaunchDaemons/com.apple.mDNSResponder.plist


    ...Also, It seems as so this guy is having the exact same problem? I can't believe there's no way to fix this?.. :(
    http://forums.macrumors.com/showthread.php?t=1370465
     
  5. opinio macrumors 65816

    Joined:
    Mar 23, 2013
    #5
    Can't you just go to:

    System Preferences --> Network --> Click on relevant network link --> Advanced --> DNS

    Then under DNS servers put either your Router IP or try your ISP/RSP primary and secondary DNS addresses.

    Did you try this or not?
     
  6. mystic08 thread starter macrumors newbie

    Joined:
    Sep 9, 2013
    #6
    Yes, that was unsuccessful as well! Fortunately, I did a time machine back up (which took hours) and then restarted with CMD + R and reinstalled without swiping the drive. All in all 5-6 hours but all my files were intact and everything is working again. :) thnx for all your suggestions
     
  7. snberk103 macrumors 603

    Joined:
    Oct 22, 2007
    Location:
    An Island in the Salish Sea
    #7
    Note the text I bolded above....

    Shrink says it better than I ever could....
     
  8. satcomer macrumors 603

    satcomer

    Joined:
    Feb 19, 2008
    Location:
    The Finger Lakes Region
    #8
  9. mystic08 thread starter macrumors newbie

    Joined:
    Sep 9, 2013

Share This Page