Help unjailbreaking tethered 4.3.5 (I've read and tried everything)

Discussion in 'Jailbreaks and iOS Hacks' started by jpmerz, Oct 12, 2011.

  1. jpmerz macrumors newbie

    Joined:
    Oct 12, 2011
    #1
    iPhone 4
    4.3.5 tethered jailbreak using 4.3.4 ipsw and redsnow 0.9.8b4

    So I attempted to restore my iPhone 4 earlier so that I could upgrade to iOS 5. However, iTunes would not let me upgrade, saying that I was ineligible. I've tried to restore via DFU mode with 4.3.5, 4.3.4, etc. with no avail. Now my iPhone is essentially bricked; I cannot get past the recovery screen. I tried rejailbreaking it, but redsnow hangs at about 75% of the little pineapple screen that pops up on the iPhone screen (pwnagetool?). The closest I can come to getting it functional again is about 75% of the restore process to 4.3.5, at which point itunes hangs up and give me either error 1013 or 3004. I have edited my host file in efforts to circumvent eligibility. I have scoured the internet for solutions to my problem, which seems to be somewhat unique at this time. I would sincerely appreciate any help you might offer.

    Edit: One minute after posting, I have successfully restored to 4.3.5! I can't quite remember what I did differently this time, as I have tried several permutations of different solutions. I think I pointed itunes to a modified 4.3.5 ipsw from DFU mode.
     
  2. jav6454 macrumors P6

    jav6454

    Joined:
    Nov 14, 2007
    Location:
    1 Geostationary Tower Plaza
    #2
    Try the following. Don't do anything but click the Restore button in iTunes. However, try this later today (in other words in two hours). Servers at Apple are being hammered so that might also be a reason why the update hangs. No, you can't stay at iPhone OS 4 anymore.

    Also, reboot your computer before keep trying.
     
  3. scusumano macrumors newbie

    Joined:
    Oct 12, 2011
    #3
    I'm having exactly the same issue. I jailbroke my iPhone 4 with the tethered redsn0w 4.3.5 route.

    I cannot update to 5.0, nor can I restore to unjailbroken 4.3.5.

    Please help! I really want to upgrade to iOS 5. :(

    Do I need to wait until Pwnagetool is updated for iOS 5?
     
  4. scusumano macrumors newbie

    Joined:
    Oct 12, 2011
    #4
    I was able to fix mine. :D

    I chose "restore" in iTunes instead of "update". That made all of the difference. It seems that I needed to restore the iPhone to factory settings before making the upgrade (makes total sense). Also, I deleted the extra lines from my hosts file that I'd edited for use with Tiny Umbrella.

    I hope this helps!
     
  5. caodapengtj, Oct 12, 2011
    Last edited: Oct 12, 2011

    caodapengtj macrumors member

    Joined:
    Jun 25, 2007
    #5
    Hi would you mind tell us what you did in your hosts file?
    I tried Tiny Umbrella, it doesn't work for me.
    Now I am not getting "not eligible to upgrade" error, I get "internal error" instead.
    Thank you!
     
  6. nhanda macrumors newbie

    Joined:
    Oct 12, 2011
    #6
    could you try to restore in DFU mode after TU "uncheck" option. I did the same thing and it worked for me.
     
  7. caodapengtj macrumors member

    Joined:
    Jun 25, 2007
    #7
    Yes. The DFU+TU method works. Thank you!!:D
     
  8. AlphaBetaJacob macrumors newbie

    Joined:
    Oct 14, 2011
    #8
    i am having this problem still with my 3gs, what worked best?
     

Share This Page