Help! Updated to macOS 10.12.4, MBP randomly shuts off

Discussion in 'macOS Sierra (10.12)' started by mokhan23, Mar 30, 2017.

  1. mokhan23 macrumors newbie

    Joined:
    Jul 31, 2014
    #1
    I have a 2013 15" MBPR and recently updated to the latest software 10.12.4. Prior to updating, everything was working fine. But now after the update.. I'll be browsing the web or using an app, then suddenly the screen will turn black, the fan will run pretty high, and then the computer will turn off. I already tried doing a NVRAM/SMC Reset, tried re-installing macOS Sierra (not a clean install). I also did boot in safe mode, in safe mode the computer doesn't turn off, but when I restart and log into my normal account it'll completely turn off at random times. I don't use any 3rd party applications, nor do I have any log in items at startup.

    I did run a first aid on my hard drive and that came back with no issues or bad sectors. I ran the activity monitor and don't see any unusual activity that take up a lot of CPU.

    What can be the issue?
     
  2. johns4949 macrumors newbie

    Joined:
    Jul 21, 2011
    #2
    apparently there are many problems associated with 10.14.2 Safari freezes have to force quit numerous programs have to restart MacBook to get safari to work have to force quit chrome also
     
  3. mokhan23 thread starter macrumors newbie

    Joined:
    Jul 31, 2014
    #3
    Yes, not even with safari. It'll turn off randomly even if I'm not doing anything.
     
  4. Goatllama macrumors 6502a

    Goatllama

    Joined:
    Jun 24, 2015
    Location:
    Mountaintop Lair
    #4
    Perhaps we should take a look at any warnings in the Console application. Any ideas, @DeltaMac ?
     
  5. DeltaMac macrumors 604

    DeltaMac

    Joined:
    Jul 30, 2003
    Location:
    Delaware
    #5
    Console/system.log may report a shutdown reason. You can check in the console, the logs will be listed by date and time.
    Note the time when you get a shutdown, then after a restart, check the logs, come back here with questions about that...

    But "screen will turn black, the fan will run pretty high, and then the computer will turn off..."
    My first thought is that your MBPro is overheating, and getting pulled down very quickly.
    Watch your Activity Monitor - make sure that is set to show "All Processes", and not just "My Processes"
    Another tip is to download and install an app that will monitor and report your temps - just to see if your temps are suddenly spiking
    (??) I use HWSensors for that, but there's others out there, too.
     
  6. mokhan23 thread starter macrumors newbie

    Joined:
    Jul 31, 2014
    #6
    Update:
    Computer did a random shutdown in Safe Boot as well. Starting to think it could be a hardware issue as well.

    MBpro is well ventilated and is not overheating, no dust or anything blocking vent ports causing it to shut down. I'm using very light apps like safari or opening up simple documents. I did time when it shuts down, the quickest was at 3 minutes in, another 8 minutes, and twice it shut down exactly at 12 minutes

    Nothing out of ordinary in the activity monitor that is causing excessive CPU Usage.

    Any other ideas? I really don't want to do a fresh install and have all my information deleted, like iMessages threads, safari bookmarks, etc.

    Had safari open with multiple tabs , and within 19 seconds the computer shut down from starting up.
    --- Post Merged, Mar 30, 2017 ---
    (com.apple.xpc.launchd.domain.user.loginwindow.111.4294967295): Service sets EnableTransactions=false and EnablePressuredExit=true, which makes no sense. Enabling Transactions.

    Mar 30 17:09:37 Mos-MacBook-Pro com.apple.xpc.launchd[1] (com.apple.inputswitcher.running): The HideUntilCheckIn property is an architectural performance issue. Please transition away from it.

    Mar 30 17:11:44 Mos-MacBook-Pro cloudd[320]: notify name "com.apple.cloudkit.pcs.flushCaches" has been registered 40 times - this may be a leak

    (com.apple.imfoundation.IMRemoteURLConnectionAgent): Unknown key for integer: _DirtyJetsamMemoryLimit
    Mar 30 17:11:34 --- last message repeated 2 times ---

    Mar 30 17:09:53 Mos-MacBook-Pro com.apple.xpc.launchd[1] (com.apple.imfoundation.IMRemoteURLConnectionAgent): Unknown key for integer: _DirtyJetsamMemoryLimit
    Mar 30 17:09:54 Mos-MacBook-Pro Console[328]: BUG in libdispatch client: kevent[EVFILT_MACHPORT] monitored resource vanished before the source cancel handler was invoked

    These are the errors I found that are repeated multiple times especially the _DirtyJrtsamMemoryLimit.
     
  7. jerry008 macrumors newbie

    Joined:
    Apr 7, 2017
    #7
    Experiencing the same issue, starting from April 4, 2017.

    Description of the issue:
    My MacBook's screen randomly turns black, then I can hear fans for about 10 seconds, then it shuts down. I was not able to find any significant patterns for when this is occurring, but usually it takes about 5-15 minutes after restart for this to happen. This usually repeats for about 8 times, then it works again for a day or so.

    Console output:
    Didn't find anything relevant.

    Recent changes/updates:
    Command Line Tools (macOS Sierra version 10.12) for XCode installed on April 2 (before the first unexpected restart).
    macOS Sierra Update (10.12.4) installed on April 4 (after the first unexpected restart).

    What I already tried:
    NVRAM/SMC Reset.

    EtreCheck:

    EtreCheck version: 3.1.5 (343)

    Report generated 2017-04-07 04:37:41

    Download EtreCheck from https://etrecheck.com

    Runtime 2:01

    Performance: Excellent



    Click the [Support] links for help with non-Apple products.

    Click the [Details] links for more information about that line.



    Problem: Computer is restarting

    Description:

    Randomly (usually after 5-15 minutes), the computer screen turns black, I can hear the fans for 10 seconds, then the computer turns off.



    Hardware Information:

    MacBook Pro (Retina, 15-inch, Late 2013)

    [Technical Specifications] - [User Guide] - [Warranty & Service]

    MacBook Pro - model: MacBookPro11,3

    1 2.6 GHz Intel Core i7 (i7-4960HQ) CPU: 4-core

    16 GB RAM Not upgradeable

    BANK 0/DIMM0

    8 GB DDR3 1600 MHz ok

    BANK 1/DIMM0

    8 GB DDR3 1600 MHz ok

    Bluetooth: Good - Handoff/Airdrop2 supported

    Wireless: en0: 802.11 a/b/g/n/ac

    Battery: Health = Normal - Cycle count = 113


    Video Information:

    Intel Iris Pro

    Color LCD 3360 x 2100

    NVIDIA GeForce GT 750M - VRAM: 2048 MB


    System Software:

    macOS Sierra 10.12.4 (16E195) - Time since boot: less than an hour


    Disk Information:

    APPLE SSD SM0512F disk0 : (500.28 GB) (Solid State - TRIM: Yes)

    [Show SMART report]

    EFI (disk0s1) <not mounted> : 210 MB

    Recovery HD (disk0s3) <not mounted> [Recovery]: 650 MB

    Macintosh HD (disk1) / [Startup]: 499.08 GB (100.77 GB free)

    Encrypted AES-XTS Unlocked

    Core Storage: disk0s2 499.42 GB Online


    USB Information:

    Apple Inc. Apple Internal Keyboard / Trackpad

    Apple Inc. BRCM20702 Hub

    Apple Inc. Bluetooth USB Host Controller

    Western Digital Elements 1023


    Thunderbolt Information:

    Apple Inc. thunderbolt_bus


    Configuration files:

    /etc/sysctl.conf - File exists but not expected

    /etc/hosts - Count: 9


    Gatekeeper:

    Mac App Store and identified developers


    Unknown Files:

    ~/Library/LaunchAgents/com.postgresapp.Postgres2LoginHelper.plist

    /Applications/Postgres.app/Contents/Library/LoginItems/PostgresLoginHelper.app/Contents/MacOS/PostgresLoginHelper

    One unknown file found. [Check files]


    Kernel Extensions:

    /Applications/Screenflick.app

    [loaded] com.Cycling74.driver.Soundflower (1.6.2 - SDK 10.6 - 2016-10-27) [Support]



    /Applications/Tunnelblick.app

    [not loaded] net.tunnelblick.tap (20141104 (Tunnelblick build 4270.4395) Unsigned - 2015-09-19) [Support]

    [not loaded] net.tunnelblick.tun (20141104 (Tunnelblick build 4270.4395) Unsigned - 2015-09-19) [Support]



    /Applications/zoom.us.app

    [not loaded] zoom.us.ZoomAudioDevice (1.1 - SDK 10.8 - 2017-02-22) [Support]



    /Library/Application Support/VirtualBox

    [loaded] org.virtualbox.kext.VBoxDrv (5.0.10 - 2015-12-11) [Support]

    [loaded] org.virtualbox.kext.VBoxNetAdp (5.0.10 - 2015-12-11) [Support]

    [loaded] org.virtualbox.kext.VBoxNetFlt (5.0.10 - 2015-12-11) [Support]

    [loaded] org.virtualbox.kext.VBoxUSB (5.0.10 - 2015-12-11) [Support]



    /System/Library/Extensions

    [loaded] com.intel.kext.intelhaxm (1.1.1 - SDK 10.9 - 2017-04-04) [Support]



    ~/Downloads/Chrome/Greatdy Computer Audio Device.app

    [loaded] com.Greatdy.driver.SystemAudioCapture (1.0.0 - SDK 10.9 - 2014-09-13) [Support]



    ~/Library/Application Support/Sparkle/Transmit/Transmit 4.1.9 Update/Transmit.app

    [not loaded] com.panic.TransmitDisk.transmitdiskfs (4.0.0 - SDK 10.5 - 2012-05-25) [Support]



    System Launch Agents:

    [not loaded] 6 Apple tasks

    [loaded] 176 Apple tasks

    [running] 100 Apple tasks


    System Launch Daemons:

    [loaded] com.intel.haxm.plist (2014-10-31) [Support]

    [not loaded] 41 Apple tasks

    [loaded] 170 Apple tasks

    [running] 108 Apple tasks


    Launch Agents:

    [not loaded] com.adobe.AAM.Updater-1.0.plist (2017-01-29) [Support]

    [failed] com.adobe.ARMDCHelper.cc24aef4a1b90ed56a725c38014c95072f92651fb65e1bf9c8e43c37a23d420d.plist (2017-01-11) [Support]

    [loaded] com.adobe.AdobeCreativeCloud.plist (2016-10-29) [Support]

    [loaded] com.binaryage.asepsis.updater.plist (2015-02-21) [Support]

    [loaded] com.google.keystone.agent.plist (2017-01-13) [Support]

    [loaded] com.oracle.java.Java-Updater.plist (2017-03-25) [Support]

    [loaded] org.macosforge.xquartz.startx.plist (2014-08-11) [Support]


    Launch Daemons:

    [loaded] com.adobe.ARMDC.Communicator.plist (2017-01-11) [Support]

    [loaded] com.adobe.ARMDC.SMJobBlessHelper.plist (2017-01-11) [Support]

    [loaded] com.adobe.SwitchBoard.plist (2014-12-29) [Support]

    [running] com.adobe.adobeupdatedaemon.plist (2016-10-29) [Support]

    [running] com.adobe.agsservice.plist (2017-03-11) [Support]

    [loaded] com.adobe.fpsaud.plist (2016-04-15) [Support]

    [running] com.docker.vmnetd.plist (2017-03-02) [Support]

    [running] com.fitbit.galileod.plist (2014-10-29) [Support]

    [loaded] com.google.keystone.daemon.plist (2017-01-25) [Support]

    [loaded] com.microsoft.autoupdate.helpertool.plist (2015-10-04) [Support]

    [loaded] com.microsoft.office.licensingV2.helper.plist (2015-08-07) [Support]

    [loaded] com.oracle.java.Helper-Tool.plist (2016-12-12) [Support]

    [loaded] com.oracle.oss.mysql.mysqld.plist (2015-07-30) [Support]

    [loaded] net.tunnelblick.tunnelblick.tunnelblickd.plist (2015-10-05) [Support]

    [loaded] org.macosforge.xquartz.privileged_startx.plist (2014-08-11) [Support]

    [not loaded] org.virtualbox.startup.plist (2015-12-11) [Support]


    User Launch Agents:

    [loaded] com.adobe.AAM.Updater-1.0.plist (2016-08-30) [Support]

    [loaded] com.adobe.ARM.[...].plist (2017-01-29) [Support]

    [loaded] com.adobe.ARM.[...].plist (2015-10-15) [Support]

    [loaded] com.citrixonline.GoToMeeting.G2MUpdate.plist (2017-02-08) [Support]

    [loaded] com.github.facebook.watchman.plist (2015-03-29) [Support]

    [running] com.oculusvr.ovrserver.plist (2016-02-07) [Support]

    [loaded] com.postgresapp.Postgres2LoginHelper.plist (2017-02-25) [Support]

    [running] com.spotify.webhelper.plist (2017-04-07) [Support]

    [loaded] com.valvesoftware.steamclean.plist (2016-10-29) [Support]

    [loaded] net.tunnelblick.tunnelblick.LaunchAtLogin.plist (2015-09-19) [Support]

    [not loaded] org.virtualbox.vboxwebsrv.plist (2015-12-11) [Support]


    User Login Items:

    BetterTouchTool Application

    (/Applications/BetterTouchTool.app)

    Zone Application Hidden

    (/Applications/Zone.app)

    LittleIpsum Application Hidden

    (/Applications/LittleIpsum.app)

    EvernoteHelper Application (2016-12-09)

    (/Applications/Evernote.app/Contents/Library/LoginItems/EvernoteHelper.app)

    Sketch DevTools Assistant Application

    (/Applications/Sketch DevTools Assistant.app)

    Google Drive Application

    (/Applications/Google Drive.app)

    Spotify Application Hidden

    (/Applications/Spotify.app)

    com.adobe.SwitchBoard.monitor.plist MachInit

    (/etc/mach_init_per_user.d/com.adobe.SwitchBoard.monitor.plist)

    Mach Init items are deprecated


    Internet Plug-ins:

    AdobeAAMDetect: 3.0.0.0 - SDK 10.9 (2016-10-29) [Support]

    FlashPlayer-10.6: 21.0.0.226 - SDK 10.6 (2016-04-22) [Support]

    QuickTime Plugin: 7.7.3 (2017-04-04)

    AdobePDFViewerNPAPI: 15.023.20056 - SDK 10.11 (2017-01-25) [Support]

    AdobePDFViewer: 15.023.20056 - SDK 10.11 (2017-01-25) [Support]

    Flash Player: 21.0.0.226 - SDK 10.6 (2016-04-22) Outdated! Update

    o1dbrowserplugin: 5.41.3.0 - SDK 10.8 (2015-12-14) [Support]

    googletalkbrowserplugin: 5.41.3.0 - SDK 10.8 (2015-12-11) [Support]

    Silverlight: 5.1.30514.0 - SDK 10.6 (2014-08-09) [Support]

    Unity Web Player: UnityPlayer version 4.5.5f1 - SDK 10.6 (2014-10-08) [Support]

    JavaAppletPlugin: Java 8 Update 121 build 13 (2017-03-25) Check version



    User internet Plug-ins:

    RingCentralMeetings: ZoomBundleVersionNumber - SDK 10.11 (2016-08-29) [Support]

    WebEx64: 1.0 - SDK 10.10 (2015-11-06) [Support]

    CitrixOnlineWebDeploymentPlugin: 1.0.105 (2013-04-25) [Support]

    ZoomUsPlugIn: 4.0.22259.0125 - SDK 10.11 (2017-02-22) [Support]



    3rd Party Preference Panes:

    BTTPrefs (2012-04-25) [Support]

    Flash Player (2016-04-15) [Support]

    Java (2017-03-25) [Support]

    LaunchRocket (2014-09-19) [Support]

    MySQL (2015-07-14) [Support]


    Time Machine:

    Skip System Files: NO

    Auto backup: YES

    Volumes being backed up:

    Macintosh HD: Disk size: 499.08 GB Disk used: 398.31 GB

    Destinations:

    Lyria Backup [Local]

    Total size: 499.39 GB

    Total number of backups: 7

    Oldest backup: 4/6/17, 10:27 PM

    Last backup: 4/7/17, 3:44 AM

    Size of backup disk: Too small

    Backup size 499.39 GB < (Disk used 398.31 GB X 3)


    Top Processes by CPU:

    153% Google Chrome Helper(32)

    15% Google Chrome

    12% WindowServer

    10% kernel_task

    6% quicklookd


    Top Processes by Memory:

    4.56 GB Google Chrome Helper(31)

    1.26 GB kernel_task

    770 MB Slack Helper(9)

    655 MB WindowServer

    360 MB Sublime Text


    Virtual Memory Information:

    3.47 GB Available RAM

    121 MB Free RAM

    12.53 GB Used RAM

    3.35 GB Cached files

    768 KB Swap Used


    Diagnostics Information:

    Apr 7, 2017, 04:22:28 AM Self test - passed

    Apr 6, 2017, 11:40:25 PM /Library/Logs/DiagnosticReports/backupd_2017-04-06-234025_[redacted].cpu_resource.diag [Details]

    /System/Library/CoreServices/backupd.bundle/Contents/Resources/backupd

    Apr 6, 2017, 08:19:45 PM /Library/Logs/DiagnosticReports/backupd_2017-04-06-201945_[redacted].cpu_resource.diag [Details]

    Apr 6, 2017, 09:58:20 AM ~/Library/Logs/DiagnosticReports/node_2017-04-06-095820_[redacted].crash

    /Users/[redacted]/*/node

    Apr 6, 2017, 05:01:23 AM ~/Library/Logs/DiagnosticReports/Disk Utility_2017-04-06-050123_[redacted].crash

    com.apple.DiskUtility - /Applications/Utilities/Disk Utility.app/Contents/MacOS/Disk Utility

    Apr 6, 2017, 04:30:07 AM ~/Library/Logs/DiagnosticReports/Trash_2017-04-06-043007_[redacted].crash

    /System/Library/PrivateFrameworks/StorageManagement.framework/PlugIns/Trash.appex/Contents/MacOS/Trash

    Apr 5, 2017, 11:43:33 AM ~/Library/Logs/DiagnosticReports/Slack Helper_2017-04-05-114333_[redacted].crash

    com.tinyspeck.slackmacgap.helper - /Applications/Slack.app/Contents/Frameworks/Slack Helper.app/Contents/MacOS/Slack Helper

    Apr 5, 2017, 11:43:25 AM ~/Library/Logs/DiagnosticReports/Slack Helper_2017-04-05-114325_[redacted].crash

    Apr 5, 2017, 11:42:42 AM ~/Library/Logs/DiagnosticReports/Slack Helper_2017-04-05-114242_[redacted].crash

    Apr 5, 2017, 12:55:45 AM ~/Library/Logs/DiagnosticReports/CraftManager_2017-04-05-005545_[redacted].crash

    com.invisionlabs.CraftManager - /Volumes/VOLUME/*/CraftInstaller 2.app/Contents/Resources/CraftManager.app/Contents/MacOS/CraftManager

    Apr 4, 2017, 11:28:21 PM ~/Library/Logs/DiagnosticReports/Slack Helper_2017-04-04-232821_[redacted].crash

    Apr 4, 2017, 02:05:32 PM ~/Library/Logs/DiagnosticReports/Activity Monitor_2017-04-04-140532_[redacted].crash

    com.apple.ActivityMonitor - /Applications/Utilities/Activity Monitor.app/Contents/MacOS/Activity Monitor

    Apr 4, 2017, 11:43:09 AM ~/Library/Logs/DiagnosticReports/Slack Helper_2017-04-04-114309_[redacted].crash

    Apr 4, 2017, 11:43:03 AM ~/Library/Logs/DiagnosticReports/Slack Helper_2017-04-04-114303_[redacted].crash

    Apr 4, 2017, 11:42:58 AM ~/Library/Logs/DiagnosticReports/Slack Helper_2017-04-04-114258_[redacted].crash

    Apr 4, 2017, 11:42:52 AM ~/Library/Logs/DiagnosticReports/Slack Helper_2017-04-04-114252_[redacted].crash

    Apr 4, 2017, 11:42:48 AM ~/Library/Logs/DiagnosticReports/Slack Helper_2017-04-04-114248_[redacted].crash

    Apr 4, 2017, 11:35:41 AM ~/Library/Logs/DiagnosticReports/Slack Helper_2017-04-04-113541_[redacted].crash

    Apr 4, 2017, 11:35:28 AM ~/Library/Logs/DiagnosticReports/Slack Helper_2017-04-04-113528_[redacted].crash

    Apr 4, 2017, 09:58:44 AM /Library/Logs/DiagnosticReports/mdworker_2017-04-04-095844_[redacted].cpu_resource.diag [Details]

    /System/Library/Frameworks/CoreServices.framework/Frameworks/Metadata.framework/Versions/A/Support/mdworker



     
  8. melov macrumors newbie

    melov

    Joined:
    Apr 9, 2017
    #8
    Hi, guy's! I have the same problem.
    Random shutdown, dark screen, then fan noise. My macbook looked in two services, no one knows what the problem is.
    Also tried to install the captain, the same problem.

    MacBook Pro (Retina, 15-inch, Mid 2014)
    2.5 GHz Intel Core i7
    16 GB 1600 MHz DDR3
    Intel Iris Pro 1536 MB
    Sierra 10.12.4 (16E195)


    Last logs:

    Apr 10 02:22:48 Dmitrys-MacBook-Pro Notes[293]: BUG in libdispatch client: kevent[EVFILT_MACHPORT] monitored resource vanished before the source cancel handler was invoked
    Apr 10 02:23:25 Dmitrys-MacBook-Pro com.apple.xpc.launchd[1] (com.apple.imfoundation.IMRemoteURLConnectionAgent): Unknown key for integer: _DirtyJetsamMemoryLimit
    Apr 10 02:23:25 Dmitrys-MacBook-Pro com.apple.xpc.launchd[1] (com.apple.imtranscoding.IMTranscoderAgent): Unknown key for integer: _DirtyJetsamPriority
    Apr 10 02:23:25 Dmitrys-MacBook-Pro com.apple.xpc.launchd[1] (com.apple.imtranscoding.IMTranscoderAgent): Unknown key for integer: _DirtyJetsamMemoryLimit
    Apr 10 02:23:25 Dmitrys-MacBook-Pro com.apple.xpc.launchd[1] (com.apple.imdmessageservices.IMDMessageServicesAgent): Unknown key for integer: _DirtyJetsamMemoryLimit
    Apr 10 02:24:12 Dmitrys-MacBook-Pro com.apple.xpc.launchd[1] (com.apple.imfoundation.IMRemoteURLConnectionAgent): Unknown key for integer: _DirtyJetsamMemoryLimit
    Apr 10 02:24:40 localhost bootlog[0]: BOOT_TIME 1491780280 0


    Apr 10 02:20:54 --- last message repeated 10 times ---
    Apr 10 02:20:54 Dmitrys-MacBook-Pro diagnosticd[446]: System mode client started - Console (445) - mode: 0x8
    Apr 10 02:21:00 Dmitrys-MacBook-Pro Console[445]: BUG in libdispatch client: kevent[EVFILT_VNODE] monitored resource vanished before the source cancel handler was invoked
    Apr 10 02:21:10 Dmitrys-MacBook-Pro hidd[100]: BUG in libdispatch client: kevent[EVFILT_MACHPORT] monitored resource vanished before the source cancel handler was invoked
    Apr 10 02:22:12 localhost bootlog[0]: BOOT_TIME 1491780132 0
     
  9. mokhan23 thread starter macrumors newbie

    Joined:
    Jul 31, 2014
    #9
    Took my MacBook to Apple and they sent it out for repair. Replaced the whole logic board as well as the display just in case. Haven't experienced the problem since.



     
  10. melov macrumors newbie

    melov

    Joined:
    Apr 9, 2017
    #10
    Oh, bad story.
    How much for replace motherboard?
     
  11. mokhan23 thread starter macrumors newbie

    Joined:
    Jul 31, 2014
    #11
    I had AppleCare so it didn't cost me anything.
     
  12. melov macrumors newbie

    melov

    Joined:
    Apr 9, 2017
    #12
    Thanks for the answer!
    And what exactly is the reason, they said?
     
  13. one more macrumors 6502a

    one more

    Joined:
    Aug 6, 2015
    Location:
    Earth
    #13
    Same thing here, MacBook Pro 13" running macOS 10.12.4. The problem started just after the update to 10.12.4, so it does not seem to be hardware-related. The OP solution of replacing the motherboard & screen might have worked if it had also been accompanied by the clean macOS 10.12.4? Was this the case? Has anybody reported it as a bug to Apple yet, with all the logs posted here earlier? I am still 99% sure it is a macOS bug.
     
  14. jerry008, Apr 14, 2017
    Last edited: Apr 14, 2017

    jerry008 macrumors newbie

    Joined:
    Apr 7, 2017
    #14
    Just an update, I've taken my MBP to Apple Store. They ran an extensive diagnostics test (their own, you can't do it yourself) and found nothing wrong with my hardware. They think it's a software issue, so they recommended creating a new user, but the same thing happened with a brand new user as well. I haven't experienced a shutdown in a guest mode yet (I have an encrypted password so I'm using the guest mode from recovery), but I haven't spent too much time in it either.
     
  15. Dale-D, Apr 14, 2017
    Last edited: Apr 14, 2017

    Dale-D macrumors newbie

    Dale-D

    Joined:
    Sep 17, 2012
    #15
    Since upgrading to macOS 10.12.4 I've been experiencing issues with the mouse locking up (not moving) for half a second or so, so much so that the whole system gets choppy and doesn't respond well. I've tried everything, including stopping apps that run on startup. The whole problem IS heat... my system idol temp (cpu proximity) should be around 32-33 degrees Celsius, but have been anywhere between 38-42. My system is a Mid-2012 rMBP and I have had to take the heat pipe off and put new thermal compound on before. I tried that this time with no luck in reducing temps, then bought a new heat pipe thinking that was somehow faulty. Temps are a little better, but are still way too high. I think something in 10.12.4 is broken and causing temps to be much higher than normal. When playing games the temps spike so high I'm afraid of the CPU desoldering itself (I know... NOT likely).

    I haven't tried wiping the system and installing completely fresh because I'm not convinced that will solve the issue. I either have to wait until 10.12.5 is released or go back to 10.12.3. l
     
  16. mokhan23 thread starter macrumors newbie

    Joined:
    Jul 31, 2014
    #16
    Didn't say anything whether it was hardware or software. But after Apple replacing the logic board, my MacBook runs with no issues. Also, when I got my laptop back from Apple, my information was still there, so i am assuming they did not do a fresh install..
     
  17. serr macrumors regular

    Joined:
    Mar 8, 2010
    #17
    Has anyone been able to switch between an older OSX install and 10.12 and demonstrate the shut down issue clearly following the 10.12 install? (To rule out anyone with a genuine hardware issue coincidentally hitting after the 10.12 install.)

    I notice that 10.12 in general likes to shut the machine down when it has problems. Verified boot disc corruption for example as opposed to some mystery. Where an older OSX install would kernel panic or give you the circle and slash, 10.12 will shut the machine down.

    So I'm curious if anyone has been able to absolutely demonstrate this being a fault in 10.12 while an old system performs flawlessly on the same hardware. There are certainly some other bugs that can be clearly demonstrated to be faults in 10.12.
     
  18. jerry008 macrumors newbie

    Joined:
    Apr 7, 2017
    #18
    I have restored my MacBook from TimeMachine backup - did not help.
    I have reinstalled Sierra while keeping the data - did not help.
    I have wiped the hard drive, installed Sierra from scratch and manually copied a few files from backup - did not help.

    Next up I'm either going to install an older version of macOS or give up.
     
  19. Weylin macrumors newbie

    Joined:
    Apr 19, 2017
    #19
    I've been working this issue for a while. It happens to me from a fresh restart, without starting any programs, and with shutting down all login items that start at boot. And it still crashes. I have not tried safe mode.

    I've wiped and reinstalled, and it still crashes.

    I've done Wi-Fi and usb tethering, and it crashes. Interestingly - if I shut off my Wi-Fi and attach wired Ethernet, it's rock-solid.

    I've examined my console, there were no crashdump files or shutdown cause.

    I agree that this seems like a thermal event, but ive installed a thermal monitoring app that stays on top of all other windows, and all thermal sensors stay below 40c.

    I work at a university, the it help center employs certified Apple care specialists... who can't find anything.

    Current suspicion is this is an Apple bug in 10.12.4. I have not tried reinstalling with an older version.

    10.12.5 beta 3 is out, I have to believe it'll go release soon with a fix for this. "Hope" is all I really have left.

    Weylin
     
  20. serr macrumors regular

    Joined:
    Mar 8, 2010
    #20
    Can you guys just boot from an old system to rule out the hardware? Then there will be more of a definitive answer and quickly.
     
  21. tywebb13 macrumors 68020

    Joined:
    Apr 21, 2012
    #21
    You can run it yourself.

    It is called Apple Service Diagnostics.

    There are many different versions of this and you have to be sure that you get the right one for your computer.

    The particular one you need for your computer is ASD 3S162.
     
  22. jerry008 macrumors newbie

    Joined:
    Apr 7, 2017
    #22
    I've reinstalled to 10.11.6 and copied all files (manually because Time Machine backup is not compatible anymore) in the morning.

    I've experienced first freeze/restart around noon as soon as I plugged in an external monitor via HDMI.
    I've experienced another freeze/restart in the evening while doing nothing, just browsing the web.

    :(

    Doesn't seem like 10.12.4 was at fault here, at least in my case.
     
  23. Sparticle macrumors newbie

    Joined:
    Apr 23, 2017
    #23
    This happend to my 2014 15" MBPR two days ago as well: Screen randomly turns black shortly after startup, short period of fan noise and then it shuts down.

    I've tried a full Time Machine reinstall (still to 10.12.4, though), but the problem persists...
     
  24. jerry008 macrumors newbie

    Joined:
    Apr 7, 2017
    #24
    Not sure if anyone's still reading, but thanks to this issue I've discovered a whole new part of me. A quality I never thought I had: superstition.

    Early on I discovered that my laptop is less likely to shut down if Spotlight indexing is running (which could run for hours). Interestingly, turning off Spotlight made the issue even worse, so I kept Spotlight running and thought it had nothing to do with it. I thought I tried everything.

    My MacBook could easily restart 10-20 times/day and it was super annoying. On April 20 I noticed that my laptop never shut down while I was watching a video on YouTube. Despite all the common sense, in the morning of April 21, I found myself a long 10-hour YouTube video. I was desperate. I chose a calming recording of rain. No restart that day. I was both furious and speechless. I was in awe. I felt hope. I was becoming superstitious. Countless times I was imagining the last flight of my MacBook on a sunny day. Thankfully, there was a calming rain playing in the background. Over the next 3 days I experienced 4 shut downs in total.

    On April 23, in the morning, I decided it's time for some heavy guns. I left the safe harbor of a calming rain and ran a script with an infinite loop in the terminal. Over the next 5 days I experienced 3 shut downs. 2 of which were within 5 minutes of booting up because I forgot to run the script.

    My MacBook is not shutting down anymore. My MacBook lasts 2 hours on a battery. I have no explanation for this. Someone please confirm I'm not crazy. Run `while do done` in Terminal and let me know if it helped. (Btw I'm still running 10.11 because I'm too scared of changing anything, I'll try to upgrade to Sierra over the weekend.)

    tl;dr no shut downs if there's something utilizing the cpu, wtf
     
  25. serr macrumors regular

    Joined:
    Mar 8, 2010
    #25
    Jerry008, that's an interesting data point for sure and certainly points more to software than hardware (or it was one heck of a coincidence after coincidence there!).

    I don't have extensive use/knowledge of 10.11 (I kind of skipped it). I thought the bit where OSX now shuts off the system instead of giving you the gray screen message to shut it down yourself after a kernel panic was new to 10.12. Did 10.11 also do this?

    If it were me, I would clone a 10.10 or 10.9 system to the machine and see what happens.

    PS. If you aren't already doing this, start making clones of your OS installs so you can just copy whichever one you want back to your main drive. You don't want to be fussing around manually installing! That takes hours of work. Cloning takes minutes of not very much work or thinking. Treat your OS install like a resume. Make copies.

    PPS. Especially for the purpose of eliminating variables here, you only want to clone a known working system or do a clean install. Absolutely no update style OS install!
     

Share This Page