Help! USB to Ethernet adaptor for MacBook Air Problems

Discussion in 'MacBook Air' started by MilkMan4, Sep 21, 2012.

  1. MilkMan4 macrumors regular

    Jun 22, 2011
    So I just purchased a USB to ethernet adaptor (Model KY-LANRD9700) for my MBA 2011, running mountain lion. I opened up the package and it had a driver installation CD. Now since the MBA doesn't have a cd drive, I used remote disc with my other windows laptop. There was a folder named setup, but the only thing in that folder was a .exe extension, and i'm not runnin any windows on my MBA. THe other files were in a fold called USB.LAN,RD9700 Driver.... and I installed the drivers that were in the Mac folder. After restarting my computer like it said, i connected it up to the modem and my MBA, and turned off wi-fi, and nothing was working. Did i Do anything wrong? Do i need to get the drivers elsewhere? Do I somehow have to enable a LAN on my MBA?

  2. macneubie macrumors regular

    Aug 8, 2011
    Is it the original Apple USB to Ethernet Adapter?
  3. J&JPolangin macrumors 68030

    Jul 5, 2008
    Thule GL @ the TOW
    I have a generic USB to ethernet adapter from (paid ~$6 USD for it) and I just plugged it in and it worked...go to your network settings and see if the MBA didn't just auto detect it before you try and load any software?

    Good luck!
  4. Jaaay macrumors member

    Aug 8, 2010
    I have the same problem. Someone please help! *bump*
  5. knuro macrumors newbie

    Sep 9, 2009
    It just should plug in and work.. no need to load any software.

    Mine always does. Also bought a Thunderbolt to ethernet cable and it works fine out of the box also.
  6. allanchou macrumors newbie

    Dec 13, 2011
    You can consider using ASIX's USB to LAN controllers inside dongles with the latest Mac OSX driver supporting ( .
  7. wolfpuppies3 macrumors 6502

    Jun 26, 2012
    Virginia, USA
    I bought mine from Apple. There is no software to install. Works fine.
  8. thomaskelly427 macrumors member

    Oct 3, 2012
    Brewster, New York
    I would say you should stick to getting your adapters from places that have a track record of making good products or sticking with first party items if it is a business critical need.

    Return it and get an Apple one.
  9. TheRealDamager macrumors 65816

    Jan 5, 2011
    Agreed with the previous poster. It just isn't worth trying to save $5-$10 and buy yourself a bunch of hassle with drivers. Monoprice is a well respected alternative, or just buy the Apple brand. Your time is worth money.
  10. weckart macrumors 601

    Nov 7, 2004
    No need to send it back. Google the info on the dongle to determine what the chip is. Visit the chipmaker's website (almost certainly ASIX) and grab the most up to date driver. The ones on the CD are possibly out of date.
  11. jedreg macrumors newbie

    Jan 16, 2013
    The KY-LANRD9700 works fine on MBA 2012 using RD9700 drivers from attached CD - simply installed from pkg, rebooted, dongle plugged in and voila, network setting automatically added and do recognize when dongle attached, ethernet connection works fine. No need to overpay genuine gadgets unless you are an Apple purist or need gigabit ethernet (over thunderbolt or usb3)

  12. krravi macrumors 65816

    Nov 30, 2010
    The driver for the Apple version is already built in. I noticed this when I was doing bootcamp and while driver installation saw the "USB -> ethernet " driver being installed in Windows.

    In Mac OS, they are already there. So if you bought it from a third party and still intend to use it, go online to their support website and see if they have drivers for it.
  13. solo118 macrumors 65816

    May 16, 2011
  14. krravi macrumors 65816

    Nov 30, 2010
  15. solo118 macrumors 65816

    May 16, 2011
    I took a shot with it, as my cousin claims he got it to work and has the drivers.

    He is out of the country now and can't get me the link for a few days so curious if anyone else knew how to obtain it.
  16. Mrbobb macrumors 601

    Aug 27, 2012

    Is he in the middle of the Asian jungle without Internet access or something? ;)

    Googling probly gives u faster response, *If* ur cousin wasn't fast and loose. Listen to the guy who says "look at chipset."

    What are u guys doing with USB adapters anyway. Don't u know you are restricting yourselves to USB2 speed?
  17. solo118 macrumors 65816

    May 16, 2011
    I dont want to be a wise guy, but seriously why would you say that?

    He is on vacation and does not want to be bothered with my requests nor does he want to go online he just wants to relax. So please spare me with such remarks.

    He told me about it weeks ago and I just got the adapter a couple of days ago.

    Anyways I saw this thread and thought I would find an answer from someone here, and i did not even open a new thread.

    But OK. I will check google when I get home and have access to my laptop and adapter.
  18. TheRealDamager macrumors 65816

    Jan 5, 2011
    Yes, that was a bit abrupt.

    I keep saying it - buy the Apple one or the Monoprice one. There is no reason to be having to search the web for some obscure drivers.
  19. mag01 macrumors regular

    Apr 10, 2011
    Most of these adapters are based on ASIX chips. ASIX offers their drivers for download from their website.

    USB 2.0 to 100Mbps Ethernet adapters are usually based on some variant of AX88772 (AX88772A, AX88772B... - they all use the same drivers):;71;101
    just drivers:

    USB 3.0 to 1Gbps Ethernet adapters are usually based on the AX88179:;71;112
    just drivers:
  20. skoczen macrumors newbie

    Jan 7, 2015
    Solution for the OP, and RD9700 Chipset adapters

    Note that the OP has an RD9700 chipset, so the ASIX drivers won't help, and the drivers off the CD stopped working on Mavericks.

    Here's how to get it working if you've got an RD9700 adapter, and you're on 10.10:

    Bonus irony points, for the thread: This was actually figured out in the middle of the Asian jungle, so that I could have internet access. :)
  21. michellegzx macrumors newbie

    Mar 29, 2015
    usb ethernet adaptor

    I bought a generic ethernet adaptor too (JP1081B) and managed to get the driver downloaded. However according to the manual im supposed to add "Ethernet" in the network panel under system preferences and there is no such option as my macbook is a 2014 version. Is there anything i can do?:(

  22. skoczen macrumors newbie

    Jan 7, 2015
    Yep - see my link above :)
  23. michellegzx macrumors newbie

    Mar 29, 2015
    thanks! but i got this message for the second input into the terminal..
    /System/Library/Extensions/USBCDCEthernet.kext failed to load - (libkern/kext) not loadable (reason unspecified); check the system/kernel logs for errors or try kextutil(8).
    vlan-2638-10-16-159-210:~ MICH$
    what went wrong?
  24. michellegzx macrumors newbie

    Mar 29, 2015
    Oh nvm my bad, it works now! Thanks a lot skoczen:D
  25. ecschwarz macrumors 65816


    Jun 28, 2010

Share This Page

26 September 21, 2012