Help with Running SW:TOR

Discussion in 'Mac and PC Games' started by NeoSlashX, Feb 3, 2012.

  1. NeoSlashX macrumors newbie

    Joined:
    Feb 3, 2012
    #1
    Hey everyone,

    I recently purchased The Old Republic (may be regretting it) and I"m having trouble getting it to run on my Imac. I have the one from mid 2010 with the ATI Radeon HD 4670 and 3.06GHz Intel Core i3.

    I just recently reinstalled bootcamp and been having trouble with my drivers so I'm not sure if thats the issue. Once I installed bootcamp, I inserted the Mac OSX disc to install the drivers. However, the comp. restarts and all I get is a black screen but I"m able to hear the chimes of me clicking onthe mouse.

    I found some fix on the internet with a USB and Win7 drivers that load up when you install Windows. I'm no longer getting the black screen when the Windows loads up but the game is unplayable. I have everything set to low and the resolution is set to the lowest possible.

    Before I bought the game, I read that people were running it with a worse setup then me. However, I'm not exactly tech savy when it comes to computer gaming so maybe my mac has finally met its match?

    Thank you for the help in advance.
     
  2. Nightarchaon macrumors 65816

    Nightarchaon

    Joined:
    Sep 1, 2010
    #2
    Get windows installed under bootcamp,

    Then install the Bootcamp drivers...if you have upgraded to lion, you'll need to make the new bootcamp driver install using the bootcamp wizard in Mac os and have a USB key handy to put them on...

    then install the game

    then :

    Turn shadows, anti aliasing and bloom off.. and pick the lowest resolution your comfortable with.
     
  3. Huntn macrumors G5

    Huntn

    Joined:
    May 5, 2008
    Location:
    The Misty Mountains
    #3
    Welcome to the MacRumor Forums! :):)

    In all cases you should be printing out the Bootcamp instructions beforehand because it can be difficult IDing what needs to be run on what based on your memory such as which partition is the right one under Windows that needs reformatting and what driver program needs to be run off the MacOSX DVD. Find the Bootcamp Install Guide at the link.

    If you are running Snow Leopard, the process is:

    1. Run BootCamp- Partitions Drive into FAT32.
    2. Launch the Windows Installer, off the Windows Install DVD, but before installing windows use Windows to reformat the Windows partition (you just created) over to NTFS.
    3. Install Windows.
    4. While running Windows, install the Bootcamp Drivers off the MacOS DVD.
    5. Let Windows update itself, which could be a lengthy process.

    Now if you have Lion (considering there is no MacOSX Install DVD) do as what the previous reply said to do.
     
  4. NeoSlashX thread starter macrumors newbie

    Joined:
    Feb 3, 2012
    #4
    Thank you guys.

    So I did a reinstall of Windows and followed what you guys said. However, now I"m getting that black screen with no display. When I was installing the drivers off my MAC OSX disc, my screen resolution went from 1920x1080 to 800x600. Something is going on with my graphic driver but I'm clueless on how to fix it.

    I'm trying to run Windows 7 32x. The frustrating thing is that I had Bootcamp working perfectly but I didn't give myself enough space so I did a reformat of it and now I keep running into this problem.
     
  5. Huntn macrumors G5

    Huntn

    Joined:
    May 5, 2008
    Location:
    The Misty Mountains
    #5
    First Bold- You were doing this while running Windows, right?

    Second Bold- How did you reformat it? You might want to start from scratch by using Disk Utility (Mac program on your Mac) erase the Windows partition and start over at the beginning, except I don't know how it will respond to an NTFS partition... Will Bootcamp allow you to eradicate the partition? I don't know. The goal would be to start over clean.
     
  6. NeoSlashX thread starter macrumors newbie

    Joined:
    Feb 3, 2012
    #6
    Yes, I ran the MAC OSX disc after I installed Windows. I found a solution on the internet to get the Windows partition out of that black display problem by accessing my HDD through my Mac and deleting the atikmdag.sys file.

    After I did that, I was able to get back on my Windows partition and ran Apple Software Update which allowed me to switch back to 1920x1080.

    I thought I had it fixed but when I went to test out a game, Mass Effect, it is still not allowing me to run that game in 1920x1080. The highest resolution I'm allowed is 1400x1000.

    I was able to max this game out before on this same computer. I am currently running Window Update to see if that will fix any driver issues.

    I'm hoping this will fix it, if not then I'll be posting again :(. On the issue of reinstalling clean, I tried that about a dozen times and still wouldn't allow me to play any PC game in my monitor's native resolution.
     
  7. NeoSlashX thread starter macrumors newbie

    Joined:
    Feb 3, 2012
    #7
    Windows update just finished and it installed all but two of the 48 updates. The two happen to be the ones related to my graphics card. One is a driver update and the other is a display update.
     
  8. MattA macrumors 6502

    MattA

    Joined:
    May 15, 2006
    Location:
    Orlando, FL
    #8
    Don't use the drivers that came with the bootcamp CD for your video card. Use the proper ATI/AMD drivers from their site. The supplied apple drivers are awful. Download and install the latest catalyst, and you'll see much better performance.

    Also, experiment with the graphics settings in game. The 4670 should be able to run at native resolution with some of the pretties turned up.
     
  9. NeoSlashX thread starter macrumors newbie

    Joined:
    Feb 3, 2012
    #9
    Wow, I"m just a freaken idiot. Apparently, there was a scroll bar on the settings in Mass Effect that allow you to see more resolution options.

    I tested out TOR too and that seems to be working. I'm sorry to bother you guys and I should be ashamed :confused:
     

Share This Page