Help with RX470 set up

Discussion in 'Mac Pro' started by Jackdown_101, Mar 8, 2017.

  1. Jackdown_101, Mar 8, 2017
    Last edited: Mar 8, 2017

    Jackdown_101 macrumors newbie

    Joined:
    Feb 28, 2017
    #1
    Mac Pro 4,1 with 5,1 upgrade
    2 x 2.26 GHz
    24GB RAM
    10.12.3

    I've just made my first attempt to install an RX470 into my machine and have met with partial success.... I was able to try out a Sapphire Rx470 8GB like this one. It is installed in Slot 1 and powered by a dual six pin to 8 pin adapter.

    I am currently typing this from the mac with the 470 installed but I am finding that I have no acceleration. I have tried to do this following the guides that Fl0rian, The ITsage and others have laid out previously. Editing the Info.plist in the AMDRadeonX4100.kext updating everything with kext utility and then looking to activate all 32 cores with iHex and the code provided by Fl0rian in another thread on this site. Finding and replacing the lines in AMDRadeonX4100 replacing the file in the MacOS folder and running KextUtility again. I've not yet looked to update the name of the card in System Info.

    PRAM and SMC Reset

    Clearly though I have done something wrong somewhere as at present my mac will boot, hang on a white screen at login, although respond to me entering my password and boot up to the desktop. However as I have said there appears to be no acceleration and the fans are constantly running pretty fast. Also possibly of note the LED's etc on the card are not active. Have I missed a step somewhere for 10.12.3?

    I have attached a screenshot of my info.plist as well as the readings from Luxmark (where the card appears to not be recognised) and openglex (again not recognised) which as you can see are very slow and does not show metal support.

    Thanks again for all the help everyone is providing here
    --- Post Merged, Mar 8, 2017 ---
    I have just seen that I have possibly put the 0x67DF1002 code in the wrong place on the line as I missed that in the picture I was looking at the Fury chain was also added. Would this make a major difference?
     

    Attached Files:

  2. Jackdown_101 thread starter macrumors newbie

    Joined:
    Feb 28, 2017
    #2
    Have changed the kext so that 0x67DF1002 is first in the list. No Change

    Thanks again for any advice
     

    Attached Files:

  3. theitsage macrumors 6502a

    Joined:
    Aug 28, 2005
    #3
    If you can see screen output through this RX 470, it's a compatible GPU. Try running Kext Utility again and restart.
     
  4. Jackdown_101 thread starter macrumors newbie

    Joined:
    Feb 28, 2017
    #4
    Thanks for the response. So far as far as acceleration goes I've lost it, had it, lost it again.

    I'm using the latest kext utility (2.6.6 I think).

    I removed the rx470 and ran the kext update a couple of times having just added the new info playlist to a clean install of 10.12.3 and had no improvement.

    So I removed the card again, ran kext utility again and then ran it specifically on the AMD4100 kext by dragging it onto the kext utility window. The utility created a backup of the kext and then readded it to the extensions folder. This worked and the 470 booted with acceleration and ran great. No fans etc.

    Having got it to this point I thought I'd add the cu update into the OS folder too. So removed 470 added updated hex and ran kext utility. Lost acceleration again. Removed card ran kext utility on the AMD4100 kext again and got the backup but now it's saying 'cant save/copy file' and not replacing the kext back in the extensions folder so no acceleration again.

    So near and yet so far. Thanks again.
     
  5. Jackdown_101, Mar 9, 2017
    Last edited: Mar 9, 2017

    Jackdown_101 thread starter macrumors newbie

    Joined:
    Feb 28, 2017
    #5
    Much trial and error later.......

    So I made all the changes following the guides, so thanks to everyone involved in them, okrasit, Fl0r!an, and goalque and itsage, using iHex and Kext Utility with the success and failure documented above. Eventually I found that in order to get it working I had to use Kext Wizard to search for the AMD4100.kext (which it showed to be loaded) and then get it to reload just that kext, repair permissions and restart in order to get it to stick.

    But it appears to have done.

    Occasional PCIe Fan and PSU fan speed issues on boot, as documented with other unsupported cards but other than that seems fairly stable so far.

    Now I just need to have a play with it and see how it works in my applications to decide if I'm going to do it to my working drive too.......

    And then find that Apple break it all again with their next update.

    Thanks again to everyone who has offered help and advice. I expect I'll be back with more things that I've managed to break shortly!!



    EDIT: I have just noticed that now it's all working in the system report the PCIe Lane Width has gone down from being reported as 16x when unaccelerated to 8x now its accelerated. Any thoughts? Assume it's because the 460 is only 8x?
     

    Attached Files:

Share This Page