high kernel task, upto 300%

Discussion in 'MacBook Air' started by saumitra369, Jul 6, 2017.

  1. saumitra369 macrumors newbie

    Joined:
    Jul 6, 2017
    #1
    Hello everyone,



    I am having some issues with my MBA for past couple of months. Problem is high kernel task upto 300% with high fan speed (audible while working). Sometimes it gets fixed automatically. When I normally shutdown my mac, it gets started automatically. Unable to boot in safe mode. Unable to boot in recovery mode.

    I have tried all the solutions available over the internet. And also formatted my MBA completely, updated it to new OS X, but the problem still remain.

    Please find the EtreCheck report below.

    EtreCheck version: 3.3.3 (397)

    Report generated 2017-06-11 15:28:30

    Download EtreCheck from https://etrecheck.com

    Runtime: 12:51

    Performance: Poor



    Click the [Lookup] links for more information from Apple Support Communities.

    Click the [Details] links for more information about that line.



    Problem: Computer is too slow



    Hardware Information:

    MacBook Air (13-inch, Early 2014)

    [Technical Specifications] - [User Guide] - [Warranty & Service]

    MacBook Air - model: MacBookAir6,2

    1 1.4 GHz Intel Core i5 (i5-4260U) CPU: 2-core

    4 GB RAM Not upgradeable

    BANK 0/DIMM0

    2 GB DDR3 1600 MHz ok

    BANK 1/DIMM0

    2 GB DDR3 1600 MHz ok

    Bluetooth: Good - Handoff/Airdrop2 supported

    Wireless: en0: 802.11 a/b/g/n/ac

    Battery: Health = Normal - Cycle count = 194



    Video Information:

    Intel HD Graphics 5000 - VRAM: 1536 MB

    Color LCD 1440 x 900



    System Software:

    macOS Sierra 10.12.5 (16F73) - Time since boot: less than an hour



    Disk Information:

    APPLE SSD SD0128F disk0 : (121.33 GB) (Solid State - TRIM: Yes)

    [Show SMART report]

    EFI (disk0s1 - MS-DOS FAT32) <not mounted> : 210 MB

    Recovery HD (disk0s3 - Journaled HFS+) <not mounted> [Recovery]: 650 MB

    Macintosh HD (disk1 - Journaled HFS+) / [Startup]: 120.12 GB (51.43 GB free)

    Core Storage: disk0s2 120.47 GB Online



    USB Information:

    USB30Bus

    Apple Inc. BRCM20702 Hub

    Apple Inc. Bluetooth USB Host Controller



    Thunderbolt Information:

    Apple Inc. thunderbolt_bus



    Gatekeeper:

    Mac App Store and identified developers



    Kernel Extensions:

    /Library/Extensions

    [loaded] com.paragon-software.filesystems.ntfs (14.2.288 - SDK 10.5) [Lookup]



    System Launch Agents:

    [not loaded] 7 Apple tasks

    [loaded] 191 Apple tasks

    [running] 84 Apple tasks



    System Launch Daemons:

    [not loaded] 41 Apple tasks

    [loaded] 176 Apple tasks

    [running] 100 Apple tasks



    Launch Agents:

    [failed] com.adobe.ARMDCHelper.cc24aef4a1b90ed56a725c38014c95072f92651fb65e1bf9c8e43c37a2 3d420d.plist (Adobe Systems, Inc. - installed 2017-05-22) [Lookup]

    [loaded] com.oracle.java.Java-Updater.plist (? 9bfa8183 be93c7fb - installed 2017-03-23) [Lookup]

    [running] com.paragon-software.NTFS.fsnotify.agent.plist (? dcda45f4 848b1897 - installed 2017-03-04) [Lookup]

    [loaded] com.paragon-software.facebook.agent.plist (? 95fb0bd4 e9648c48 - installed 2017-03-04) [Lookup]



    Launch Daemons:

    [running] com.aaa.windscribe.OVPNHelper.plist (Windscribe Limited - installed 2017-05-24) [Lookup]

    [loaded] com.adobe.ARMDC.Communicator.plist (Adobe Systems, Inc. - installed 2017-05-22) [Lookup]

    [loaded] com.adobe.ARMDC.SMJobBlessHelper.plist (Adobe Systems, Inc. - installed 2017-05-22) [Lookup]

    [loaded] com.adobe.fpsaud.plist (? 2afb3af7 77ec3a65 - installed 2017-04-27) [Lookup]

    [loaded] com.microsoft.office.licensing.helper.plist (? 6d8cb30e afb3bef0 - installed 2010-08-25) [Lookup]

    [loaded] com.oracle.java.Helper-Tool.plist (Shell Script e3fefdd2 - installed 2017-03-23) [Lookup]

    [loaded] com.oracle.oss.mysql.mysqld.plist (Oracle America, Inc. - installed 2017-05-24) [Lookup]

    [running] com.paragon-software.NTFS.fsnotify.daemon.plist (? 66744841 b1cb5590 - installed 2016-08-29) [Lookup]

    [loaded] com.paragon.NTFS.launch.plist (Apple, Inc. - installed 2017-04-29)

    [loaded] com.teamviewer.Helper.plist (TeamViewer GmbH - installed 2017-03-14) [Lookup]



    User Launch Agents:

    [loaded] com.google.keystone.agent.plist (Google, Inc. - installed 2017-03-29) [Lookup]

    [loaded] com.skype.skype.shareagent.plist (Skype Communications S.a.r.l - installed 2017-05-20) [Lookup]



    User Login Items:

    iTunesHelper Application (Apple, Inc. - installed 2017-05-23)

    (/Applications/iTunes.app/Contents/MacOS/iTunesHelper.app)

    Android File Transfer Agent Application

    (~/Library/Application Support/Google/Android File Transfer/Android File Transfer Agent.app)



    Internet Plug-ins:

    FlashPlayer-10.6: 25.0.0.171 (installed 2017-05-10) [Lookup]

    QuickTime Plugin: 7.7.3 (installed 2017-04-29)

    AdobePDFViewerNPAPI: 17.009.20044 (installed 2017-04-05) [Lookup]

    AdobePDFViewer: 17.009.20044 (installed 2017-04-05) [Lookup]

    Flash Player: 25.0.0.171 (installed 2017-05-10) [Lookup]

    SharePointBrowserPlugin: 14.0.0 (installed 2010-08-25) [Lookup]

    JavaAppletPlugin: Java 8 Update 121 build 13 (installed 2017-03-23) Check version



    3rd Party Preference Panes:

    Flash Player (installed 2017-04-27) [Lookup]

    Java (installed 2016-12-13) [Lookup]

    MySQL (installed 2017-03-18) [Lookup]

    Paragon NTFS for Mac® (installed 2017-03-04) [Lookup]

    Kiosk (installed 2016-06-01) [Lookup]



    Time Machine:

    Mobile backups: OFF

    Auto backup: NO - Auto backup turned off

    Volumes being backed up:

    Destinations:

    SEAGATE EXP [Local]

    Total size: 0 B

    Total number of backups: 0

    Oldest backup: -

    Last backup: -

    Size of backup disk: Excellent

    Backup size 0 B > (Disk size 0 B X 3)



    Top Processes by CPU:

    24% kernel_task

    10% Activity Monitor

    9% WindowServer -daemon

    1% sysmond

    1% ps -raxcww -o %mem, [and 3 more arguments]



    Top Processes by Memory:

    448 MB kernel_task

    98 MB Spotlight

    90 MB assistantd

    82 MB mds_stores

    82 MB WindowServer -daemon



    Top Processes by Network Use:

    Input Output Process name

    21 KB 42 KB apsd

    28 KB 34 KB mDNSResponder

    6 KB 3 KB assistantd

    522 B 354 B netbiosd

    336 B 336 B ntp.drift



    Top Processes by Energy Use:

    8.54 WindowServer -daemon

    5.48 Activity Monitor

    1.46 sysmond

    0.26 launchd



    Virtual Memory Information:

    2.18 GB Available RAM

    295 MB Free RAM

    1.82 GB Used RAM

    1.89 GB Cached files

    0 B Swap Used



    Diagnostics Information:

    2017-06-08 23:14:35 /Library/Logs/DiagnosticReports/photoanalysisd_2017-06-08-231435_[redacted].cpu _resource.diag [Details]

    /System/Library/PrivateFrameworks/PhotoAnalysis.framework/Versions/A/Support/ph otoanalysisd



    Files deleted by EtreCheck:

    2017-06-06 22:52:57 - /Library/LaunchAgents/com.teamviewer.teamviewer.plist - Unknown

    2017-06-06 22:52:57 - /Library/LaunchAgents/com.teamviewer.teamviewer_desktop.plist - Unknown

    2017-06-06 22:52:57 - /Library/LaunchDaemons/com.teamviewer.teamviewer_service.plist - Unknown


    Please help guys.
     
  2. ZapNZs macrumors 68000

    ZapNZs

    Joined:
    Jan 23, 2017
    #2
    When you shut the Mac down, are you saying that it restarts on its own?
    When you did the reinstall, what method did you use if you were unable to boot into recovery mode? A USB installer I am guessing?
    Are you able to access Apple Diagnostics?
     
  3. saumitra369 thread starter macrumors newbie

    Joined:
    Jul 6, 2017
    #3
    Hello and thanks for response.
    Yes it restarts on its own.
    Using USB and an apple guy did it.
    Not able to login using safe mode or recovery mode.
    Apple diagnostics is also not accessible.
     
  4. saumitra369 thread starter macrumors newbie

    Joined:
    Jul 6, 2017
    #4
    Is there any other way I can log into safe mode using terminal.
    I have already tried -
    "sudo nvram boot-args=kext-dev-mode=1" but it won't work in macOS Sierra.
    For Sierra, safe boot is through recovery mode in which I can't login.
    Please guys help !!!.
     
  5. kohlson macrumors 6502a

    Joined:
    Apr 23, 2010
    #5
    You should be able to shut down this mac (as with most laptops) by holding down the power key for about 5-10 seconds. From there, you should be able to start up in safe mode.
     
  6. saumitra369 thread starter macrumors newbie

    Joined:
    Jul 6, 2017
    #6
    --- Post Merged, Jul 18, 2017 ---
    I have tried but unable to login into safe mode as infact I think no key combinations are working at startup. So is there any option in mac which tells OS to perform key combination at boot time ?
     
  7. ApfelKuchen macrumors 68030

    Joined:
    Aug 28, 2012
    Location:
    Between the coasts
    #7
    Saying you've "...tried all the solutions available over the internet" doesn't tell us what you have tried.

    There's not a way to tell the OS to perform key combinations at boot time - key combinations are entered before the OS boots. Behavior at boot is affected by the System Management Controller (SMC) and NVRAM. I'd imagine you've already tried resetting both of those, if you tried everything on the internet, but maybe you haven't.

    Do you have any external devices connected to the Mac?

    Not true. Safe Boot and Recovery are two separate boot modes.

    Just when are you pressing the key combinations for Safe Boot, Recovery, etc.? They have to be pressed right after the startup sound begins (startup sound indicates that the Power On Self Test is done), but before the OS starts loading (Apple logo). It may be that you're just missing the window of opportunity.
     
  8. saumitra369 thread starter macrumors newbie

    Joined:
    Jul 6, 2017
    #8
    Thanks for replying !!
    I have tried SMC and PRAM reset but I think only SMC is done(by observing the LED light on charger). Tried resetting PRAM but no success as it should reboot one more time after successful PRAM reset.
    I am pressing keys just after pressing the power button.
    I have also tried updating my mac, complete formating macbook.
    No external devices connected to mac.
    Please tell, if I am missing something or update if doing something incorrectly.
     
  9. alembic macrumors regular

    Joined:
    Oct 13, 2005
    #9
    When the Apple person installed Sierra via USB, was it an update or a clean install? If the latter, did the problem begin after you added third party launch daemons and agents?

    Do you have access to an external drive with a clean install of Sierra from which you can boot?
     
  10. ApfelKuchen macrumors 68030

    Joined:
    Aug 28, 2012
    Location:
    Between the coasts
    #10
    If you can hear the startup sound, wait until then to press the buttons. While newer Macs complete the POST (power-on self-test) almost immediately, older Macs may need several seconds to complete POST. Pressing the key combinations before the completion of POST will mean the key combinations are not recognized.

    The newest Macs complete POST so quickly that Apple eliminated the startup sound from the boot sequence (and modified support articles to reflect that new reality). For an early 2014 like yours... If you do not normally hear a startup sound, the audio volume setting stored in NVRAM may be preventing you from hearing it. Instead of pressing the key combinations right after pressing power, try waiting 2-3 seconds before pressing the keys. I'd try the NVRAM reset first - if you're successful, the problem with hearing the startup sound will be fixed in the process.
     
  11. saumitra369 thread starter macrumors newbie

    Joined:
    Jul 6, 2017
    #11
    Okay will try that and update my findings.
    Thanks.
    --- Post Merged, Jul 18, 2017 ---
    Not it was a clean install and no the problem was still there. After clean install I checked my mac at workshop, there it was working fine after clean install but when I reached home then again it happened.:mad::mad:

    No currently I do not access to an external drive with a clean install of Sierra.
     
  12. chrfr macrumors 603

    Joined:
    Jul 11, 2009
    #12
    Was something ever spilled on the computer?
     
  13. saumitra369 thread starter macrumors newbie

    Joined:
    Jul 6, 2017
    #13
    No
     
  14. saumitra369 thread starter macrumors newbie

    Joined:
    Jul 6, 2017
    #14
    Hello guys, just wanted to know something about clean install.

    As booting into recovery mode is not working and neither any of the key combinations, so I am thinking to erase my disk using Disk Utility available in normal boot. First thing :
    1) will it work ? and if its worked then
    2) plugging in a bootable USB with macOS for clean installing of OS will work right ?
     
  15. ApfelKuchen, Jul 19, 2017
    Last edited: Jul 20, 2017

    ApfelKuchen macrumors 68030

    Joined:
    Aug 28, 2012
    Location:
    Between the coasts
    #15
    #1 will not work. You cannot erase a partition when you have booted from that same partition (that would be equivalent to burning a bridge while you're still standing on it).

    #2 will work. If you're booted to an external USB drive, you'd be able to erase the internal drive.

    If none of the key combinations are working, the easiest way to boot to the external disk is to boot normally, open System Preferences > Startup Disk, and select that external bootable drive for the next startup. There's a Restart... button right there.
     
  16. saumitra369 thread starter macrumors newbie

    Joined:
    Jul 6, 2017
    #16
    Ok thanks, lets see if that work one more time :D:apple:
     
  17. saumitra369 thread starter macrumors newbie

    Joined:
    Jul 6, 2017
    #17
    Hello guys,
    So for some reason my keyboard is not working at bootup time, but other than that it is working fine. So I attached a USB keyboard with it. Now my all the keys are working fine at boot up. So I have now access to recovery mode, diagnostics mode and safe mode (problem still remains in safe mode). I have done resetting NVRAM and its successfully achieved and also done the SCM reset but still the problem remains. Today I will be doing clean install and hope it will be resolved.

    Lets just say the problem remain, then I just wanted to know that if that can be any hardware issue.??
     
  18. alembic macrumors regular

    Joined:
    Oct 13, 2005
    #18
    Please let us know if the problem exists after a clean install (before installing third party stuff). If it does, you can check the logs in Console to see if some process is generating errors.
    --- Post Merged, Jul 26, 2017 ---
    BTW, have you ever removed the bottom panel and checked for dust build up in the fan(s)?
     
  19. jerwin macrumors 65816

    Joined:
    Jun 13, 2015
    #19
    Why did you originally install teamviewer?
     
  20. chrfr macrumors 603

    Joined:
    Jul 11, 2009
    #20
    This can be a hardware problem, and it's why I asked if the computer had ever had liquid spilled on it. Sometimes a damaged or faulty top case/keyboard can cause high CPU usage in Macs.
     
  21. saumitra369 thread starter macrumors newbie

    Joined:
    Jul 6, 2017
    #21
    Hello guys
    I clean installed my mac today but the results are the same.Thank you all guys for providing inputs to my issue .
    Now I am giving it to Apple Service center. Lets just hope nothing serious comes up. But before giving it, I will try to install MacOS on USB stick and then boot using USB, lets see if the problem remains.
     
  22. alembic macrumors regular

    Joined:
    Oct 13, 2005
    #22
    Does the kernel task ramp up immediately after a cold boot? or does it take some time before that occurs?

    Were you able to have a quick peak at the fans to see if they're clean?
     
  23. saumitra369 thread starter macrumors newbie

    Joined:
    Jul 6, 2017
    #23
    When boot progress bar appears then I can hear fan speed, so I guess kernel task are high at the time of boot.
    No I was not able to look at fans, as I have to unscrew macbook air to do so.
     
  24. alembic macrumors regular

    Joined:
    Oct 13, 2005
    #24
    Please confirm the kernel task in Activity Monitor on cold boot.

    Also, what is the ambient temperature over there?
     

Share This Page