High Sierra System Files eating up 400gb of space ... what gives??

Discussion in 'macOS High Sierra (10.13)' started by mandy030702, Jun 21, 2017.

  1. mandy030702 macrumors newbie

    Joined:
    Sep 7, 2015
    #1
    So I downloaded High Sierra and all was going well for a week (as well as to be expected I guess ... plenty of bugs but nothing in comparison to what I'm now going through. I woke up the other morning to a warning that I only had 5gb space left on my 500gb MacBook Pro that had 170gb remaining the day before. I cannot seem to find the culprit.

    I looked at the manage space area to try to find what was causing the problem. I thought I found it at first because I saw about 119 gb of iTunes files. My music is in the cloud so I didn't think it should've been downloaded onto the computer so I went ahead and deleted those files. I couldn't find a concrete answer as to how to delete those files without deleting them from the cloud so I just deleted the whole iTunes app altogether and the 119 gb of files afterwards. Next I went on to deleting the cache files. After that, I took the additional step of deleting my Dropbox folder and all of it's files. Altogether I estimate I took off about 150 gigs of files on my computer after getting that warning.

    None of that even seemed to register and give me anything back. It's still showing me about around 5 gb no matter what I seem to delete. I looked and saw that the system files appear to be taking up 420 gb of space. That doesn't seem like that can be right. I also saw where there was a beta update to the OS today and tried to download it. I wasn't able to because I didn't have enough space. I'm at a loss of what to do. Anyone have any problems like this or any advice? I'm desperate to reclaim my space!!

    Thanks!!
     
  2. T'hain Esh Kelch macrumors 601

    T'hain Esh Kelch

    Joined:
    Aug 5, 2001
    Location:
    Denmark
    #2
    Reinstall the system, format the drive if need be.
     
  3. dsemf macrumors 6502

    Joined:
    Jul 26, 2014
    #3
    I would use a couple of terminal commands.

    I would start with:
    Code:
    df
    Code:
    Filesystem    512-blocks      Used Available Capacity iused      ifree %iused  Mounted on
    
    /dev/disk1     487882752 193737536 293633216    40% 1519531 4293447748    0%   /
    devfs                363       363         0   100%     628          0  100%   /dev
    map -hosts             0         0         0   100%       0          0  100%   /net
    map auto_home          0         0         0   100%       0          0  100%   /home
    
    The second phase is a detailed report. As an admin user:
    Code:
    sudo du -d 1 -x -c -g /
    
    Code:
    1    /.DocumentRevisions-V100
    1    /.fseventsd
    0    /.PKInstallSandboxManager-SystemSoftware
    2    /.Spotlight-V100
    0    /.vol
    9    /Applications
    1    /bin
    0    /cores
    1    /dev
    1    /home
    4    /Library
    1    /net
    0    /Network
    7    /private
    1    /sbin
    10    /System
    73    /Users
    1    /usr
    1    /Volumes
    104    /
    104    total
    
    From here I can drill down looking at suspicious locations. For example, replace the / with /Users.

    DS
     
  4. hsotnicam8002 macrumors 6502

    hsotnicam8002

    Joined:
    Mar 13, 2008
    Location:
    United Kingdom
    #4
    Just restart again and a lot of unwanted files will be in the trash. I did and recovered the capacity. It was a little alarming to see all of the files disappearing from the trash though.
     
  5. mandy030702 thread starter macrumors newbie

    Joined:
    Sep 7, 2015
    #5
    Thank you everyone for all the responses. I really do appreciate it.

    DSMEF... I tried to get you the information you requested but by the time I saw your response I was at a critically low stage on the computer and I was afraid to even save a screenshot to save the information because I was waiting on a callback from Apple Support who had been helping me out since morning.

    HSOTNICAM8002 ... thank you but believe me I tried restarting and I've done that and emptied the trash as well as deleted files more times than I can count. The really strange thing is the more files I remove, the more space it shows used!! Apple Support was stumped by that today. They had me uninstall a few applications and asked me how much space I had then and were confused when I told them I had less space than before I uninstalled the apps!

    T'HAIN ESH KELCH..... Tried that too... unfortunately that option currently isn't available. It won't let me reinstall. Not enough space and it won't let me erase and reformat the drive.

    I ended up on the phone with Apple 5-6 times today because each call had to be interrupted or resulted in needing a callback after trying something. End result is that I'm taking the MacBook into the Apple Store tomorrow morning and trying to do a walk-in for support. It went as low as 50MB of space today and fluctuated throughout the day but never got any better than 2gb of space. With the help of a senior adviser at Apple, we tried reformatting the hard drive, reinstalling to factory state through internet recovery and everything else you could possibly think of. Still showing 499 gb space used and currently the only files on the computer that are mine are about 45gb. Support truly tried to help even though they were under no obligation to do so since it was a beta version. Will update after my trip to the Apple Store tomorrow. Thanks again to everyone!!
     
  6. oatman13 macrumors regular

    Joined:
    Feb 14, 2013
    #6
    Try this and report back.
    sudo tmutil thinLocalSnapshots / 10000000000 4

    If this doesn't work please open terminal and type:
    sudo sysdiagnose

    Then file a bug report and attach the sysdiagnose to: https://bugreport.apple.com
     
  7. mandy030702 thread starter macrumors newbie

    Joined:
    Sep 7, 2015
    #7

    Unfortunately I can't.... after the last steps they had me do, I can't even get that far to get into terminal now. Now all I see is a file folder on a black screen when I turn on the computer. It flashes a few times and then screen goes blank. I don't get anywhere near terminal now :( I'm leaving here in 15 minutes to take the hour trek to the Apple Store so I can be there 30 minutes before they open. Crossing my fingers they'll be able to get to me on a walk-in basis since I'll be there before they open. Don't really care if I have to wait all day as long as they see me.
     
  8. iMacDragon macrumors 65816

    iMacDragon

    Joined:
    Oct 18, 2008
    Location:
    UK
    #8
    Noticed that deleting files not freeing up space too, currently about 80gb of 'hidden' system files, tried cleaning up snapshots but no seeming difference so far.
     
  9. mandy030702 thread starter macrumors newbie

    Joined:
    Sep 7, 2015
    #9

    I'll let you know what I find out .... I'm at Apple now. My problem just kept getting worse and worse. You should try the steps the others suggested while you still can. Unfortunately I was too late (too little space and then already erased portions so it won't boot now).
     
  10. bradhs macrumors member

    Joined:
    Jun 5, 2010
    #10
    Please open a ticket at https://bugreport.apple.com. Many of us are having the same problem, it cannot be fixed without a solution from Apple. It's going to keep getting worse until you end up with no disk space. What I did was get a USB-C SSD drive, format it with HFS and a GUID scheme, used Carbon Copy Cloner to clone everything over to it and used that drive until Apple fixes it. Beta 2 does not fix it. Open a ticket ASAP and send a sysdiagnose log.
     
  11. bradhs macrumors member

    Joined:
    Jun 5, 2010
    #11

    FYI -- This is resolved in Beta 3.
     
  12. mariusignorello macrumors 65816

    Joined:
    Jun 9, 2013
    #12
    Hmmm... I bet it is log files. Those can get pretty big. iOS behaves like this too.
     
  13. Zab Abbey macrumors newbie

    Joined:
    Aug 31, 2015
    #13
    Bigger than log files. I'm watching my High Sierra drive fill up with "hidden space".....currently 61 gig of a 500 gig SSD....hope they fix it in the next update.
     
  14. GoodHealthIT macrumors member

    Joined:
    Nov 10, 2017
    Location:
    Adelaide
    #14
    I've experienced massive storage loss with a 2013 Mac Pro running Server. Whenever I enable Time Machine on that Mac, I end up losing around 5GB per minute until both the backup disk and Mac fill up and crash. Turn off TM and the increase stops. There is a file in the Mail system of server that grows - at one stage it was reporting itself as 48TB in size! And it doesn't matter if it isn't TM, any backup system results in the same activity.

    I've been working with Apple engineers for the past 4 weeks to find a resolution but to no avail. They believe it is an issue with APFS and Time Machine but are at a loss as to what is causing it. Not much help to me when I've got a server with no effective backup...
     
  15. straygoatwritingservices macrumors newbie

    straygoatwritingservices

    Joined:
    Mar 3, 2018
    Location:
    Chesterfield, England
    #15
    I had this problem and it has gone away now (but might come back, so no guarantees with what I'm going to say next). I tried deleting time machine local files, went through loads of different things with support, but found some help through another forum. It turned out that in my Volumes, there were two Volumes that were no longer connected to the computer, but were still showing up. I deleted those through terminal and my system files are back to normal size now.

    What I had to do was - find out how to display hidden folders (Googled it), look in Volumes for any Volumes that were not connected. Then use terminal to delete them... sudo rm -rf /Volumes/ followed by the name of the volume, for example, sudo rm -rf /Volumes/Untitled

    I'm sure this isn't a cure-all, but if you are experiencing problems and the timemachine-related answers aren't working, this is another option. Worked for me. More details are here: https://forums.macrumors.com/threads/hard-drive-filled-up-after-high-sierra-upgrade-on-macpro.2076400/page-2#post-25864058
     
  16. oatman13 macrumors regular

    Joined:
    Feb 14, 2013
    #16
    Do not do this!
    Do this instead.
    diskutil unmount /Volumes/Untitled.
     
  17. straygoatwritingservices macrumors newbie

    straygoatwritingservices

    Joined:
    Mar 3, 2018
    Location:
    Chesterfield, England
    #17

    Sounds like a better way to be honest! But it isn't what I did, and the problem has gone for me.
     
  18. ribbo1939 macrumors newbie

    Joined:
    Feb 8, 2009
    Location:
    Australia
    #18
    I had a similar problem only early last week - my available storage went from 1.21TB down to 858GB overnight. T/Machine backups disappeared also. Called Apple Care and after trying various options was left with the only course of action was to completely erase the h/drive and then using T/M do a re-install. Took several hours - much longer than I thought it should - to install, but eventually succeeded
     
  19. straygoatwritingservices macrumors newbie

    straygoatwritingservices

    Joined:
    Mar 3, 2018
    Location:
    Chesterfield, England
    #19
    That's exactly what I wanted to avoid and I resisted all of support's suggestions to go down that route. So glad I waited and found the delete volume approach.
     
  20. zlloyd1, Aug 5, 2018
    Last edited by a moderator: Aug 5, 2018

    zlloyd1 macrumors newbie

    zlloyd1

    Joined:
    Oct 23, 2016
    #20
    I know that I am pulling a necro here, but I am noticing a very similar issue with my High Sierra, that the System is using in excess of 400gb, and I have no clue how.... o_O:eek:o_O


    Screen Shot 2018-08-05 at 2.58.47 AM.png



    Someone explain this to me please, and Thanks in advance!! :apple:


    I have attempted to get help from Support, but they are closed, and so-called '24/7' Chat, is also not available....:mad:
     
  21. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #21
    Try running the command below in Terminal and tell us the output.

    Code:
    sudo du -d 1 -x -c -g /
     
  22. FredT2 macrumors 6502a

    Joined:
    Mar 18, 2009
    #22
    I had collected several hundred gigabytes of temporary video files in Trash, and when I emptied this morning didn't get back nearly what I expected. I ran DaisyDisk and it shows 310 GB of hidden space, 290 of which is "Still Hidden" space that DaisyDisk is unable to locate. I tried Disk First Aid, but it showed no problems. DaisyDisk suggests running fsck_apfs. Should I do that, and if so what parameters?

    I ran the sudo du command above but don't know what to report.
     
  23. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #23
    That command should put out some text like shown in this post. Copy that text and paste it in a post here.
     
  24. FredT2 macrumors 6502a

    Joined:
    Mar 18, 2009
    #24
    0 /untitled folder
    1 /home
    104 /Video
    1 /usr
    1 /.Spotlight-V100
    1 /net
    0 /.PKInstallSandboxManager
    0 /.PKInstallSandboxManager-SystemSoftware
    1 /bin
    8 /Bench Files
    0 /Network
    1 /sbin
    8 /Library
    0 /.Trashes
    12 /System
    1 /.fseventsd
    du: /private/var/db/ConfigurationProfiles/Store: Operation not permitted
    du: /private/var/folders/sq/59fnkq6s2rl1r0gqpjwg2s280000gp/0/SafariFamily: Operation not permitted
    du: /private/var/folders/sq/59fnkq6s2rl1r0gqpjwg2s280000gp/0/com.apple.LaunchServices.dv: Operation not permitted
    du: /private/var/folders/sq/59fnkq6s2rl1r0gqpjwg2s280000gp/0/com.apple.nsurlsessiond: Operation not permitted
    du: /private/var/folders/sq/59fnkq6s2rl1r0gqpjwg2s280000gp/0/com.apple.routined: Operation not permitted
    du: /private/var/folders/zz/zyxvpxvq6csfxvn_n00000y800007k/0/com.apple.nsurlsessiond: Operation not permitted
    du: /private/var/folders/zz/zyxvpxvq6csfxvn_n00000z000007r/0/com.apple.nsurlsessiond: Operation not permitted
    du: /private/var/folders/zz/zyxvpxvq6csfxvn_n00000z000007r/0/com.apple.routined: Operation not permitted
    du: /private/var/folders/hs/3738hwfs3kbbg0tfsrjb48880000gn/0/SafariFamily: Operation not permitted
    du: /private/var/folders/hs/3738hwfs3kbbg0tfsrjb48880000gn/0/com.apple.LaunchServices.dv: Operation not permitted
    du: /private/var/folders/hs/3738hwfs3kbbg0tfsrjb48880000gn/0/com.apple.nsurlsessiond: Operation not permitted
    du: /private/var/folders/hs/3738hwfs3kbbg0tfsrjb48880000gn/0/com.apple.routined: Operation not permitted
    5 /private
    1 /.DocumentRevisions-V100
    0 /.vol
    445 /Users
    24 /Applications
    1 /dev
    0 /Volumes
    0 /.TemporaryItems
    671 /Photos
    0 /cores
    1274 /
    1274 total

    It shows 1274 total, but it is a 2TB drive and I have only 319GB available.

    Screen Shot 2018-08-05 at 9.40.55 AM.png
     
  25. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #25
    Do you have Time Machine backups turned on?

    If you do, run this command in Terminal to remove local snapshots then check again.

    Code:
    tmutil  listlocalsnapshotdates / |grep 20|while read f; do tmutil deletelocalsnapshots $f; done
    You showing 445GB in your users folder and another 671GB in a separate photos folder. Do those sound about right?

    445 /Users

    671 /Photos
     

Share This Page