High Sierra System Files eating up 400gb of space ... what gives??

Discussion in 'macOS High Sierra (10.13)' started by mandy030702, Jun 21, 2017.

  1. FredT2 macrumors 6502a

    Joined:
    Mar 18, 2009
    #26
    I don't use Time Machine. Users and Photos are about right.
     
  2. zlloyd1, Aug 5, 2018
    Last edited: Aug 5, 2018

    zlloyd1 macrumors newbie

    zlloyd1

    Joined:
    Oct 23, 2016
    #27
    Did it, and this came out....
    1 /.abackblaze
    1 /.bzvol
    223 /.cleverfiles
    1 /.DocumentRevisions-V100
    1 /.fseventsd
    0 /.PKInstallSandboxManager
    1 /.PKInstallSandboxManager-SystemSoftware
    1 /.Spotlight-V100
    0 /.Trashes
    0 /.vol
    ech120 /Applications
    o1 /bin
    0 /cores
    1 /dev
    1 /Developer
    1 /home


    Not certain what this means, but my System is taking up closer to 620gb this morning.
    I am getting sick of Macintrash now, and am starting to feel like I have to be a computer programmer to use a Macos, so I almost wish I had a Windows machine that actually had a competent file system!!
     
  3. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #28
    Try running this in Terminal to reindex Spotlight. That is where that space used data comes from, and if the index is corrupted it can cause this. Give it 20-30 minutes to complete.

    Code:
    sudo mdutil -E /
    You have something here using 223GB of space in a hidden folder. It looks like recovered data from when you ran Disk Drill?

    If you don't want the data, you can delete the folder with this command.

    Code:
    sudo rm -rf /.cleverfiles
    It also looks like you did not wait long enough for the command to finish.
     
  4. FredT2, Aug 5, 2018
    Last edited: Aug 6, 2018

    FredT2 macrumors 6502a

    Joined:
    Mar 18, 2009
    #29
    That didn't work. I decided to give fsck a try, but booting in single user mode I never get the root prompt to enter the command. It's an iMac Pro.

    I ran a CCC backup before trying the fsck, and it didn't copy the extra space. It's starting to look like I'll need to do a wipe and reinstall.

    Update: A simple OS reinstall fixed it. I didn't have to wipe the drive thankfully.
     
  5. MIKX macrumors 6502a

    MIKX

    Joined:
    Dec 16, 2004
    Location:
    Japan
    #30
    Don't use iCloud :p

    By the way, iPhoto 9.6.1 works in High Sierra 10.13.6 = I don't like Photos.
     
  6. CynicMike macrumors newbie

    Joined:
    Sep 24, 2018
    #31
    I had same issue and think I have found a fix, after a month of going back and forth with Apple support. The problem was that no matter how much data I deleted from my Macbook pro hard drive, the available space did not drop by nearly as much (e.g. I deleted a folder containing 250 Gb of data and the available hard drive space only went up from 20 Mb to 14.5 Gb). Then the available hard drive space slowly drops until again I have only MB available. My system folder size kept rising from 300 gb to over 700 Gb (found by checking 'about this Mac, storage, manage) eventually, even though when checking hard drive contents (using DaisyDisk, Grand perspective etc) they listed System folder size as only 8 Gb. As a result my MacBook Pro has been unusable - I get constant messages about lack of available space and not even enough space to re-install a new version of High Sierra.
    If you have Carbon Copy Cloner installed on APFS volume formatted disk, might be the Carbon Copy Cloner snapshot feature. Even though I had snapshot collection turned off, when I went into CCC and checked the disk involved (my macbook pro) by checking on this volume (bottom left pane) and then going to snapshots (top right pane) there was a single snapshot listed, with a file size of only MBs (my system folder size had bloated to over 700 Gb). The date of this snapshot was around the time that I first noticed this problem (5 weeks ago!!). I deleted it, said there was a problem, deleted again and miraculously I now have 686Gb free space!! I did this by having the MacBook pro mounted in target disk mode on my iMac. Not sure whether you would be able to do directly from within CCC on the problem drive.
     
  7. tri-x macrumors newbie

    Joined:
    Feb 23, 2013
    Location:
    Melbourne
    #32
    Thank you so much. This solved my free space issue. I would trash GBs of files and nothing would budge. Finally turned this off from within CCC and deleted ALL the snapshots. There were about a dozen, at most a few hundred MBs each, but deleting them restored about 100GB of free space on the computer.
     
  8. CynicMike macrumors newbie

    Joined:
    Sep 24, 2018
    #33
    So glad it worked! There are also occasionally issues with Time Machine snapshots clogging up the system folder, as I have discovered.
     
  9. Mundo9 macrumors newbie

    Mundo9

    Joined:
    Mar 10, 2019
    #34
    --- Post Merged, Mar 12, 2019 ---
    Hello. I have been looking in vain to find the terminal command(s) to erase the cores. They keep coming up with more and more 3gb cores. This has been happening for the last six month and I had a source from a discussion thread where someone laid out the commands but like a not smart person I just figured I could Google it again if needed again. Those commands would be appreciated.
     
  10. Takeapunt macrumors newbie

    Joined:
    Dec 11, 2015
    #35
    This solved it for me too. I had been using an old version of CCC. Installed the new version, and even though snapshots were turned off, there was a 355GB snapshot there (as well as the expected local TM backups). Deleted the CCC one, and my 400+GB system is now 40GB. :) Thanks CynicMike.
     

Share This Page