Higher battery drain with XenForo

Discussion in 'Site and Forum Feedback' started by Coupz, Jun 15, 2015.

  1. Coupz macrumors regular

    Joined:
    Dec 24, 2013
    #1
    Dear mac rumors team,

    would it be possible to install a default and less JavaScript bloated theme?
    Since the change from vB to XenForo, my iPhone gets really quick pretty warm. Like in under 2 minutes, it gets warm. After 15 minutes of Facebook app (which is really a battery hog) my phone is ice old.

    I'm reading a lot on macrumors but don't like that my iPhone 6 gets that warm while reading on this forum. I've tried for several days to disable JavaScript and my phone was ice cold, how it should be. But without JavaScript, this forum is not really usable.

    And please don't give me advices to reset my settings or things like that. It's only macrumors forum where this happens. And if you read a lot on this forum, you'll notice it.

    Thanks in advance.
     
  2. C DM macrumors Westmere

    Joined:
    Oct 17, 2011
    #2
    Odd, usually not experiencing this on my iPhone 6 even after longer times (more than half an hour for example).
     
  3. arn macrumors god

    arn

    Staff Member

    Joined:
    Apr 9, 2001
    #3
    It seems strange to think that MacRumors Javascript alone is causing your iPhone to get warm. Anyone else noticed something like this?

    arn
     
  4. SandboxGeneral Moderator

    SandboxGeneral

    Staff Member

    Joined:
    Sep 8, 2010
    Location:
    Orbiting a G-type Main Sequence Star
    #4
    I do a fair amount of browsing, not too much posting, on the iPhone 5S and I haven't noticed any impact on the battery or heat with the new platform.
     
  5. Coupz thread starter macrumors regular

    Joined:
    Dec 24, 2013
    #5
    I know, but mr is the only site that I visit with XenForo and it's known that XF uses a lot of JavaScript.
    I'll try another reset all settings and see if it gets better. Unfortunately mr isn't usable with Tapatalk for me, there was a pretty bad update from TT and it's just bloated and confusing to use Tapatalk.

    Will report back if it gets better after resetting all settings on my iPhone 6.
     
  6. Newtons Apple macrumors Pentium

    Newtons Apple

    Joined:
    Mar 12, 2014
    Location:
    Jacksonville, Florida
    #6

    It id fine on my end and I do a good bit of this site on my 6+. Overall this is way better than what we had before. Thanks for your efforts .
     
  7. JDee macrumors 6502a

    Joined:
    Aug 31, 2008
    Location:
    Ireland
    #7
    Don't know if it's XenForo but mine is noticeably warmer also
     
  8. m4v3r1ck macrumors 68020

    m4v3r1ck

    Joined:
    Nov 2, 2011
    Location:
    The Netherlands
    #8
    I only use TapaTalk on my iPhone 6+, but will test it in Safari/Chrome anyway!

    Cheers
     
  9. Coupz thread starter macrumors regular

    Joined:
    Dec 24, 2013
    #9
    Don't know how you guys can use tapatalk. There is zero overview in this app. Deleted right after that update and tested it last week for one day. Nothing has changed in terms of overview.

    @arn I've resettled all my settings. It's not getting that warm like before, but still getting noticeable warmer then surfing on other sites or reading for longer time on the main page.

    Maybe it's not due to XenForo but more due to ads?
     
  10. m4v3r1ck macrumors 68020

    m4v3r1ck

    Joined:
    Nov 2, 2011
    Location:
    The Netherlands

Share This Page