Home sharing (to Apple TV, iPhone, etc.) no longer works

Thefirethief

macrumors newbie
Original poster
Dec 28, 2019
7
3
NL
So this causes me such a headache, I actually upgraded myself from lurker to registered user here...

I use my Apple TV 3 to stream the media I have in my iTunes (now Apple TV) library to my living room. Occasionally, I stream some media to my I-devices. Everything used to work fine, even with the upgrade to Catalina.

Since a month or so, I have a Synology NAS (a DS418). I transferred all my media to that, made a new library there, and that was working fine as well. I have my Mac Mini turned on with Apple TV (the app) running, my actual media files on the NAS and that streamed just fine to my Apple TV (the device. I really hate the name for the new app).

But since a few days, that’s no longer working. Whenever I start up my Apple TV (device) and want to connect to the Mac, it gives me the yellow triangle and the message that my library couldn’t be located in the network. It’s the same on my iPhone and iPad. When I tap ‘Home sharing’ in my Apple TV app, it says ‘Connection unsuccessful‘.

I’ve tried a lot. Rebooted every device in the network, signed out and signed in on every device and I also checked the settings on my NAS. I think everything’s fine there: the media folder is set to sharing with nearly everything and everyone.

You might’ve guessed what’s coming now: please help me. I‘m stumped for new ideas, so I hope someone here know what to do.
 
Last edited:

cmaier

macrumors Core
Jul 25, 2007
19,328
19,167
California
So this causes me such a headache, I actually upgraded myself from lurker to registered user here...

I use my Apple TV 3 to stream the media I have in my iTunes (now Apple TV) library to my living room. Occasionally, I stream some media to my I-devices. Everything used to work fine, even with the upgrade to Catalina.

Since a month or so, I have a Synology NAS (a DS418). I transferred all my media to that, made a new library there, and that was working fine as well. I have my Mac Mini turned on with Apple TV (the app) running, my actual media files on the NAS and that streamed just fine to my Apple TV (the device. I really hate the name for the new app).

But since a few days, that’s no longer working. Whenever I start up my Apple TV (device) and want to connect to the Mac, it gives me the yellow triangle and the message that my library couldn’t be located in the network. It’s the same on my iPhone and iPad. When I tap ‘Home sharing’ in my Apple TV app, it says ‘Connection unsuccessful‘.

I’ve tried a lot. Rebooted every device in the network, signed out and signed in on every device and I also checked the settings on my NAS. I think everything’s fine there: the media folder is set to sharing with nearly everything and everyone.

You might’ve guessed what’s coming now: please help me. I‘m stumped for new ideas, so I hope someone here know what to do.
i have a similar setup to you. Only difference is the library (not the media) is kept on the Mac. Maybe try that?
 

sdp77

macrumors member
Nov 10, 2019
99
31
I have five 8tb hard drives attached to my Mac mini and have the same issue. I have both 3rd and 4th generation Apple TVs and, for the most part, the 3rd generatin devices work when the 4th generation “cannot find the library”.
For the most part, rebooting the mini solves the issue temporarily.
I have no idea whether it’s connected or not but, when this happens, my computer also has problems keeping the Bluetooth keyboard and trackpad connected.
 

Photoshopper

macrumors regular
Mar 24, 2010
154
19
Idaho
This is a widespread issue since iOS 13. I've an ATV4 and can no longer see my large photo collection stored on my Mojave ‘19 Mini. Ive tried countless fixes from every end with no success as is the same story on the Apple Help forums. The “computer” on ATV no longer shows my folder of hi-res photos, just the crap on my iPhone, though it plays my music and home video libraries. Beyond frustrating because this photo sharing was one of the main reasons I got an ATV in the first place years ago. :mad:
 

Thefirethief

macrumors newbie
Original poster
Dec 28, 2019
7
3
NL
Apologies for the late reply cmaier, wrapping up the holidays took some time. SAdly, this also didn't work. Yes, I only set it up for SMB and not for AFP.

I even went to a certified Apple reseller, but all they could suggest was that I 'turn everything off and back on again'. Like I haven't tried that a hundred times. This is all terribly disappointing, but I guess I'll go the Plex route then. Not as pretty, but at least I can watch my media :/
 

mac&cheesey

macrumors 6502
Dec 21, 2008
293
6
I was having this issue. Was getting very frustrated and decided to completely reset the Apple TVs and set them up from "new". This worked for me. I did one at a time and had the "sync home screen" (or whatever it's called) on. This way the apps populate and in the same order on each Apple TV. My issue has been resolved for about 3 or 4 weeks now. Good luck.
m&c
 

VaZ

macrumors regular
Aug 31, 2012
233
69
Anyone else notice iOS 13.6 broke Home Sharing music? It loads the 2 Home Sharing Playlists i've created on 2 separate Macs and Music app on iPhone 13.6 crashes at the end of loading the libraries, on both playlist!
Tested with 3 iPhones total and prior to 13.6 everything worked fine.
Home Sharing works from Mac to Mac, but not from an iPhone 13.6 anymore. I've logged out and back in on all my devices and reset the router too. Soo Annoying what can i try!?
 
Last edited:
  • Like
Reactions: TJG

SketchyClown

macrumors regular
So this causes me such a headache, I actually upgraded myself from lurker to registered user here...

I use my Apple TV 3 to stream the media I have in my iTunes (now Apple TV) library to my living room. Occasionally, I stream some media to my I-devices. Everything used to work fine, even with the upgrade to Catalina.

Since a month or so, I have a Synology NAS (a DS418). I transferred all my media to that, made a new library there, and that was working fine as well. I have my Mac Mini turned on with Apple TV (the app) running, my actual media files on the NAS and that streamed just fine to my Apple TV (the device. I really hate the name for the new app).

But since a few days, that’s no longer working. Whenever I start up my Apple TV (device) and want to connect to the Mac, it gives me the yellow triangle and the message that my library couldn’t be located in the network. It’s the same on my iPhone and iPad. When I tap ‘Home sharing’ in my Apple TV app, it says ‘Connection unsuccessful‘.

I’ve tried a lot. Rebooted every device in the network, signed out and signed in on every device and I also checked the settings on my NAS. I think everything’s fine there: the media folder is set to sharing with nearly everything and everyone.

You might’ve guessed what’s coming now: please help me. I‘m stumped for new ideas, so I hope someone here know what to do.
Have you tried opening the "Computers" app on the Apple TV (device) to see if your content is listed there?

If so, are you able to play it?

I have "Media Sharing" enabled on my iMac so that I can play my iTunes (Music) Library through the ATV (device).

For me, that's the only way to play my music easily through the ATV device.

The Music App does not show my personal Library, it only shows the one album I ever purchased through iTunes.

Possibly it would if I subscribe to Apple Music, I don't know.

Maybe they have restricted content that will appear in the ATV+ app to purchased content?

I'm fully guessing here, but with Music that seems to be the way they have gone.
 

TJG

macrumors newbie
Jul 28, 2020
3
2
Anyone else notice iOS 13.6 broke Home Sharing music? It loads the 2 Home Sharing Playlists i've created on 2 Macs and Music app crashes at the end of loading the libraries, on both playlist. Home Sharing works from Mac to Mac, but not from an iPhone anymore. I've logged out and back in on all my devices and reset the router too. Soo Annoying what can i try!?
Yep. Same thing here. Pulling what’s left of my hair out! 13.6 is a problem, and it is consistent in every angle fix I have tried
 
  • Like
Reactions: VaZ

Mattyman

macrumors regular
Nov 2, 2019
119
19
Same here. I’m not sure if Apple is aware. It works on my old gen 2 Apple TV though!
 
  • Like
Reactions: TJG

TJG

macrumors newbie
Jul 28, 2020
3
2
Same here. I’m not sure if Apple is aware. It works on my old gen 2 Apple TV though!
Maybe we should begin a new thread for 13.6 iOS. I am frustrated with two new iPad Pro's and now the iPhones don't work with Home Sharing, either. Ever since 13.6, and the iOS is painstaking to downgrade.
 

Mattyman

macrumors regular
Nov 2, 2019
119
19
Did you have problems with the previous iOS version? I had problems with purchased Films, but music and home videos worked. Hope it’s just a bug in the iOS.
 

TJG

macrumors newbie
Jul 28, 2020
3
2
Did you have problems with the previous iOS version? I had problems with purchased Films, but music and home videos worked. Hope it’s just a bug in the iOS.
Only after the 13.6 upgrade. Home Sharing resulted in finding the library and promptly closing the Music App. It simply stopped working. Checked all the tips and tricks, but without a fix. It must be an iOS bug. But I could be wrong.
 
  • Like
Reactions: VaZ

VaZ

macrumors regular
Aug 31, 2012
233
69
Only after the 13.6 upgrade. Home Sharing resulted in finding the library and promptly closing the Music App. It simply stopped working. Checked all the tips and tricks, but without a fix. It must be an iOS bug. But I could be wrong.
Yes thats Exactly whats happening to me. The Music app crashes out on iPhone 13.6 after loading a home sharing playlist off a Mac.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.