HomePod Homepod incompatible WiFi

Discussion in 'HomeKit, HomePod, CarPlay, Home & Auto Technology' started by Newbie67, Feb 9, 2018.

  1. Newbie67 macrumors member

    Newbie67

    Joined:
    Apr 9, 2015
    #1
    my iPhone X won’t connect during setup and I get an error that says incompatible WiFi must be on WPA/WPA2. Which it is. It’s a starry WiFi and it’s excellent. My iPad will connect to it and setup but although the home settings get rolled over to the X. It won’t play with the HomePod. Very frustrated !! Any tips?
     

    Attached Files:

  2. 8CoreWhore macrumors 68020

    8CoreWhore

    Joined:
    Jan 17, 2008
    Location:
    Big D
  3. Newbie67 thread starter macrumors member

    Newbie67

    Joined:
    Apr 9, 2015
  4. unclepc macrumors newbie

    Joined:
    Feb 9, 2018
    #4

    I am having the same issue with my iphone 8. I also have an iphone 6s and I was able to get homepod setup using the iphone 6s. The iphone 6s & 8 connects to the same wi-fi, which is wpa2 network.
     
  5. Newbie67 thread starter macrumors member

    Newbie67

    Joined:
    Apr 9, 2015
    #5
    Thanks for replying. After you connected via your 6s was your 8 able to connect with full functionality?
     
  6. burgman macrumors 68000

    burgman

    Joined:
    Sep 24, 2013
    #6
    Is your router set to wpa2 or wpa/wpa2, a dual band 5G or 2.4, are both phones connected to same band, the specs for home pod doesn’t specify bands.
     
  7. litigator macrumors newbie

    Joined:
    Feb 9, 2018
    #7
    Having the same problem. Changed wifi to wpa/wpa2 personal. iPhone X giving exact same error message. Reset router, etc.
     
  8. .animal macrumors newbie

    .animal

    Joined:
    Apr 14, 2011
    Location:
    New Jersey
  9. davesmall macrumors newbie

    Joined:
    Jan 7, 2007
    #9
    I'm having the same problem setting up HomePod. The message is: Incompatible WiFi, must be WPA2. My router is furnished by AT&T and is WPA2 Personal. I have rebooted the HomePod, Modem, and my iPhone X. What to do???
     
  10. litigator macrumors newbie

    Joined:
    Feb 9, 2018
    #10
    Got it to work. I have a guest wifi network at home. Once I logged into the guest wifi network on my phone it synced with that network through the iPhone X.
     
  11. .animal macrumors newbie

    .animal

    Joined:
    Apr 14, 2011
    Location:
    New Jersey
    #11
    i just got it to work by using my ipad pro. worked flawlessly. didnt make any changes to network, etc. iphone x was bring up the error. ipad worked.
     
  12. Patriot24 macrumors 68030

    Patriot24

    Joined:
    Dec 29, 2010
    Location:
    California
    #12
    I suspect that they're enforcing some more-strict-than-usual security standards with respect to Wi-Fi networks due to the nature of the product (always-on microphone, HomeKit access, etc).
     
  13. nathanwburke macrumors newbie

    nathanwburke

    Joined:
    Feb 9, 2018
    Location:
    Cape Cod
    #13
    Having the same issue myself with my Eero wifi setup. It uses WPA2 Personal, but I'm getting the same 'incompatible wi-fi" error that won't let me set up the HomePod. Super frustrating and I've tried with an iPhone 7+, an iPhone 7 and two iPads. No luck. Talked with Eero support to make sure I wasn't missing anything, and they assured me they're using WPA2 Personal.


    I've also tried all the tricks people are using on the apple thread on the issue (restart, try using a guest network, etc.), but nothing works. Was really looking forward to this being a great sounding product So far, it's a nice paperweight!
     
  14. samrobert4 macrumors newbie

    Joined:
    Dec 19, 2017
    #14
    Had to use my iPad Pro. iPhone 7 plus was giving the wifi error.
     
  15. Chuck SaaS macrumors newbie

    Chuck SaaS

    Joined:
    Oct 3, 2017
    #15
    Having the same issue. iPhone X and iPad Pro (both running latest betas) can't setup homepod. I've got a standard configured Google Wifi unit with WPA2 Personal
     
  16. markbyrn macrumors member

    markbyrn

    Joined:
    May 1, 2010
    #16
    Same problem and even using AirPort Time Capsule :(
     
  17. Newbie67 thread starter macrumors member

    Newbie67

    Joined:
    Apr 9, 2015
    #17
    Does you’re X have full HomePod functionality after setting up via the IPP?
     
  18. markbyrn macrumors member

    markbyrn

    Joined:
    May 1, 2010
    #18
    Okay, got it work by unplugging HomePod, changing the Wi-Fi settings to to disable both auto-join and auto login, plugged the HomePod back in, and wella, no more Wi-Fi incompatibility.
     
  19. Chuck SaaS macrumors newbie

    Chuck SaaS

    Joined:
    Oct 3, 2017
    #19
    Worked for me as well!
     
  20. jrunyan01 macrumors newbie

    Joined:
    Feb 9, 2018
    #20
    I had this same problem. This fix worked for me too. Thanks!
     
  21. arizonajorl macrumors newbie

    arizonajorl

    Joined:
    Feb 9, 2018
    #21
    And for me too. Oddly enough, my girlfriends phone was able to get past this part of the setup. Same phone and version (iPhone X latest OS)
     
  22. exquisitecvboy macrumors newbie

    exquisitecvboy

    Joined:
    Feb 9, 2018
    Location:
    Holbrook, Ma
    #22
    Was just on apple support for a couple hours and the solution for me was to add it as an accessory through the home app. i tried changing wifi settings and all and it didnt work, but adding it as an accessory through the the app allowed it to finally pass through the set up portion.
     
  23. Newbie67 thread starter macrumors member

    Newbie67

    Joined:
    Apr 9, 2015
    #23
    Almost two hours on the phone with Apple. No fix. Furthermore the wifi on my X no longer works. Apple will call back tomorrow afternoon. Meanwhile I have to wipe and reinstall from backup. This is painful!
     
  24. exquisitecvboy macrumors newbie

    exquisitecvboy

    Joined:
    Feb 9, 2018
    Location:
    Holbrook, Ma
    #24
    did you try the method i suggested by going through the home app?
     
  25. Newbie67 thread starter macrumors member

    Newbie67

    Joined:
    Apr 9, 2015
    #25
    Not yet but will give it a go and get back thanks
     

Share This Page