Horrible battery life with 2.0

Discussion in 'Apple Watch' started by megalaser, Oct 7, 2015.

  1. megalaser macrumors 6502

    megalaser

    Joined:
    Nov 17, 2009
    #1
    Hi, With the old OS I used to get around 36 hours of use, now with 2.0 I am at the 10% low power mode within 10 hours . . . I've tried unpairing and repairing but it's not helping - has anyone found a solution please? Thanks
     
  2. greytmom macrumors 68040

    greytmom

    Joined:
    Jun 23, 2010
  3. megalaser thread starter macrumors 6502

    megalaser

    Joined:
    Nov 17, 2009
  4. MartyCan macrumors 65816

    MartyCan

    Joined:
    Oct 31, 2012
    Location:
    Near Toronto, ON
    #4
    The unpair/pair thing may have or may not have worked for me. I did see people who tried more than once before it "took."

    I suspected there is a bunch of background re-indexing or writing of data that happens on day 1. How long ago did you upgrade? My first day was really bad and after that it went back to normal. My wife experienced the same.

    I'm down to 13% tonight but it was on my wrist at 6 AM. I played hockey at 7 for an hour and recorder the workout with it. Used it through the day. Went Mountain Biking for 2 hours this evening and recorded that work out. Now nearly time for bed and still on full power. Less active days I would get much more time before a charge was required.
     
  5. bestshoppee macrumors newbie

    Joined:
    Jul 21, 2015
    #5
    If you are facing software side of the Apple Watch battery issues, another quick fix is to factory reset it.

    Restart your connected iPhone.
    Open Apple Watch app on the iPhone.
    Go to General > Reset and Erase All Content.
    Set up Watch all over again.https://www.bestshoppee.com
     
  6. Kyle4 macrumors 6502

    Joined:
    Aug 14, 2010
    Location:
    Canada
    #6
    I bought my new Watch with OS2 already installed (upgraded from a sport) and have had random battery drain for no apparent reason at all. I literally took it off the charger an hour ago and have done nothing but check the time and it's gone down 10% already. Yesterday, it only drained 30% in 13 hours with average use so I know it has to be a glitch somewhere (my first watch did this too). Super frustrating.
     
  7. greytmom macrumors 68040

    greytmom

    Joined:
    Jun 23, 2010
    #7
    My battery life wasn't terrible after upgrading, but it wasn't as good as it was prior to upgrade. So, I did the unpair/ repair thing, restoring from the newest backup. Today, I'm doing great. 10:38pm, still at 43%, and here's my usage:

    image.jpeg
     
  8. greytmom macrumors 68040

    greytmom

    Joined:
    Jun 23, 2010
  9. nalk7 macrumors regular

    Joined:
    Jul 11, 2008
    #9
    I've been having a similar experience, I re-paired the watch and it solved the problem for a couple days, yesterday however the drain was back, I simply turned it off and on again and that seemed to fix it for now. Both times its happened the watch has been on the charger for longer than usual, I wonder if that has anything to do with it.
     
  10. greytmom macrumors 68040

    greytmom

    Joined:
    Jun 23, 2010
    #10
    I ended up having to take my dog to the e-vet tonight - fever and abdominal pain; diagnosed with UTI so she will be fine, thank goodness! It's 1:27am and I finally took watch off and put on charger, with it still at 33%. I'm seriously pleased with battery life.

    image.jpeg
     

Share This Page