How can I disable autoplay when headphones connected?

Spyrule

macrumors newbie
Original poster
Apr 12, 2017
13
0
Ottawa, Canada
Hello,

I use a set of headphones on my iphone periodically, ONLY for telephone conversations.

Is there a way to disable headphone autoplay when the headphone is plugged in?

This is on an iPhone 6 10.3.2
 

C DM

macrumors Sandy Bridge
Oct 17, 2011
47,537
16,038
Have you tried making sure your music apps are closed before plugging in?
 

Spyrule

macrumors newbie
Original poster
Apr 12, 2017
13
0
Ottawa, Canada
Have you tried making sure your music apps are closed before plugging in?
Thats just it, i literally almost NEVER play music from my phone, and I'm a little retentive about closing my apps in the background (as I close them, I double tap and close them).
 

C DM

macrumors Sandy Bridge
Oct 17, 2011
47,537
16,038
Thats just it, i literally almost NEVER play music from my phone, and I'm a little retentive about closing my apps in the background (as I close them, I double tap and close them).
Not really sure what would be behind that then given that I use headphones fairly often and rarely play music from my phone and haven't experienced this auto play behavior.
 

Spyrule

macrumors newbie
Original poster
Apr 12, 2017
13
0
Ottawa, Canada
I've come to suspect its my headphone jack. I've only got 8 months until its time to switch, so I'll just hold off replacing it until then.
 

hiyawathadan

macrumors newbie
Nov 21, 2017
1
0
I've come to suspect its my headphone jack. I've only got 8 months until its time to switch, so I'll just hold off replacing it until then.
Nope, this is Apple thinking it's smarter than you are and that you really want your phone to be two steps ahead of you. I've been trying to disable this functionality for years and I suspect that support people are told this functionality doesn't exist or else they are told it does but also taught how to pretend it doesn't exist. There is apparently a bunch of things you can enable and subsequently disable, like 13 different setting changes, that will ultimately prevent this but it also disables a ton of other functionality.

Yeah, these are features not bugs, because there are enough people out there that will be "shock and awe'd" by this that they have no reason to disable it. It's like the app drawer, none of the instructions I have found to make them so I that I'm not constantly hitting the emoji button in my text line. They all say they do, but they don't. And it's not my handset, I've had 3 different 5S models that all do it, my 5 didn't and none of the others before it did.
 

eskimo heel

macrumors newbie
Aug 20, 2015
2
0
Santa Clara, CA USA
Pretty lightweight iPhone user but I think I solved the problem. In my case, what really snagged my wagger was then I plug a headset in for a GoToMeeting conference call and without fail, the phone started playing music. What worked for me, based on a post at http://osxdaily.com/2017/07/29/stop-autoplaying-music-iphone-car-bluetooth/

Specifically, what worked for me as their option 3"
----
Option 3: Disable Cellular Usage of Music App to Stop Autoplay
If the music app that is auto-playing is streaming over a cellular connection, you can disable that apps ability to use cellular data to prevent it from streaming any music and thus disable auto-play of music from that app.

Go to the “Settings” app and then to “Cellular” and scroll down until you find the app(s) in question that are auto-playing music in the car from your iPhone. Turn the switch to the “OFF” position to stop them from using cellular data.
----
So far (two calls) it's solved the problem.