How Can I Turn The Predictive Text Off?


jemeinc

macrumors 6502a
Feb 14, 2004
771
0
South Jersey
what don't you like about the corrective text? There are some timesthat I guess it can get annoying, but overall it seems to be much more a positive than a negative- for me anyway..
 

adammusic

macrumors 6502
Original poster
Jun 6, 2007
364
81
it finishes the word im typing with a word im not going for.

i just did the ziphone THANK YOU!
 

adammusic

macrumors 6502
Original poster
Jun 6, 2007
364
81
just tried to install two games and im getting error failed? any idea why?
 

Small White Car

macrumors G4
Aug 29, 2006
10,888
1,125
Washington DC
it finishes the word im typing with a word im not going for.
I don't own an iPhone, but I THOUGHT it let you finish no matter what.

So, for a made-up example, pretend I want to type "catsup."

I type "cat" and it changes it to "caterpillar." I then just hit "s" and it changes to "cats" and I just go on from there.

In other words, it doen't get in my way at all.

Ok, like I said, I don't own one, so I could be wrong. Is this NOT how it works?
 

mikelong622

macrumors 6502
Sep 29, 2006
435
1
St. Paul, Minnesota
I don't own an iPhone, but I THOUGHT it let you finish no matter what.

So, for a made-up example, pretend I want to type "catsup."

I type "cat" and it changes it to "caterpillar." I then just hit "s" and it changes to "cats" and I just go on from there.

In other words, it doen't get in my way at all.

Ok, like I said, I don't own one, so I could be wrong. Is this NOT how it works?
You would be correct. That is how it goes. Plus, if you don't like what the suggestion mad was, you can always just tap the suggested word and it'll make it go away, thus after awhile remembering your preferences.

For example. If you type lol ever, the phone automatically changes it to LOL which to me seems like yelling. Anyways after I've hit the "x" on the suggestion a few times it remembers it and doesn't change it anymore.
 
  • Like
Reactions: appledAgain

bigaug

macrumors newbie
Mar 5, 2008
25
0
I hate the predictive text. It comes up with the most insane, off the wall predictions about what I'm typing. The feature itself isn't annoying, but the vocabulary its working with surely is.
 

Rootus

macrumors 6502
Mar 22, 2008
376
24
Portland, OR
I don't own an iPhone, but I THOUGHT it let you finish no matter what.

So, for a made-up example, pretend I want to type "catsup."

I type "cat" and it changes it to "caterpillar." I then just hit "s" and it changes to "cats" and I just go on from there.

In other words, it doen't get in my way at all.

Ok, like I said, I don't own one, so I could be wrong. Is this NOT how it works?
That's mostly how it works. For a more on-point example, type iphone. It will suggest iPhone, but since you're not typing any further letters to cancel the suggestion, it'll take it as soon as you hit return (or /, or space). This one has gotten me in URL's. Same for .xml, it changes it to .XML. Most URL's are case sensitive, so this is annoying.
 

ajpegg

macrumors newbie
Feb 10, 2008
24
0
Remember that you can tap the selected word if it isn't the one you want, or if the word you are entering is not going to be in the dictionary, and you can tap space anytime once you see the correct word being suggested to accept it.
 

richimages

macrumors regular
Mar 20, 2008
125
0
Southeastern US
it finishes the word im typing with a word im not going for.

i just did the ziphone THANK YOU!
Well ... you could take the time to hit the actual word with the "X" following that word ... spell it correctly the way you like, and that word will float upward in the priority with a modification to the phones default dictionary ...

This is the way you train the predicitive text to go for things YOU normally type! You really should view this as a plus ... you only have to do it once for each custom word you want in your dictionary ...

BE CAREFUL ... to date their seems to be no way to edit a custom entry added to the default dictionary short of deleting the whole thing and starting over under Settings->General->Reset.

Hope that helps.
 

imac9556

macrumors 6502a
Jul 12, 2004
539
7
Please follow the images instruction I have provided.

go to setting -> general -> keyboard -> turn "Enable Autocorrection" off
That is so weird, I do not have the "enable autocorrection" setting either. I followed your steps shown in your pictures. Ver: 1.1.4 (4A102), 4.04.05g