how do i fix error code-0?

Discussion in 'Mac Basics and Help' started by LeorD, Aug 28, 2008.

  1. LeorD macrumors member

    Joined:
    Jul 29, 2008
    #1
    its really pissing my off!, i want to transfer a 7.87GB to an external hard drive and i get error code -0 plus i have two external hd and it happend on both!.
    btw i tried doing that on a windows with the same drives and it worked perfectly!
    is it possible that mac can only transfer 4GB of data onto an external hd?
    tnx leor!
     
  2. alphaod macrumors Core

    alphaod

    Joined:
    Feb 9, 2008
    Location:
    NYC
  3. LeorD thread starter macrumors member

    Joined:
    Jul 29, 2008
  4. vuMac macrumors newbie

    Joined:
    May 31, 2008
    #4
    i got the exact same problem. however i was able to back it up to external with time machine, but along with it comes all my other computer crap. it would be nice to copy just what i want. :(
     
  5. LeorD thread starter macrumors member

    Joined:
    Jul 29, 2008
    #5
    this reall sucks!, what pisses me off as a mac fan is that on windows it works fine!, it can't be were thee only ones with that problem!..
    there must be some kind of a solution..
     
  6. calculus Guest

    calculus

    Joined:
    Dec 12, 2005
    #6
    Yes if it's formatted in FAT32 stylee...
     
  7. acearchie macrumors 68040

    acearchie

    Joined:
    Jan 15, 2006
    #7
    Yes youll find that finder will limit how much you can copy to your hard drive if it is FAT32 formatted. I think the cut off is around 4GB.

    If it something like a tv show copy half the episodes then the other half. If it is a large single file get a copy of split and concat which will cut the file into however many pieces you require!

    Hope this helps!
     
  8. LeorD thread starter macrumors member

    Joined:
    Jul 29, 2008
    #8
    what is FAT32? how can i find out if my HD is FAT32? and how can i change it?, or maybe use another application to transfer the files?
    do you know any mkv splitters? but not like hjsplit.. literally to cut the video to 2 separate videos like cd-1 and cd-2 i want to plug the usb drive to my ps3 and watch the movie..
    tnx!
     
  9. la-diver macrumors newbie

    Joined:
    Oct 23, 2008
    #9
    Firewire 800 is the answer

    Had the same problem with 2 drives. They are USB and Firewire 400.

    However it transfered just fine when I used the Firewire 800 cable.
     
  10. i.shaun macrumors 6502a

    i.shaun

    Joined:
    May 1, 2008
    Location:
    Canada
    #10
    I wouldn't think it's a FAt32 limit if it's a folder of files totaling about 8 GB. I transfered my entire iTunes library (18GB) just fine (although it took a while).


    Does it contain a single file that is over 4GB?


    If so, the file may have to be split, or you will have to format the drive to something else.


    Right click, or command+click the drive in finder, and "get info" it should tell you the file system.



    FAT32 - Windows Format. This is universal, and works on macs, Pcs, and other devices like Sat receivers, Ps3s, etc... It is an old file system that has size limits on the files it can hold (4GB)

    NTFS - Windows NT File System. More advanced and secure file system read by windows NT, 2000, XP & Vista. This can be Read by the mac, but you cannot write to the drive unless you install third party programs like "NTFS for mac". It also will not be read by other devices like Sat receivers, or Ps3s.

    You can also choose to format it for mac if you wish only to use it on macs.



    HDD/Applications/Utilities/Disk Utility.app
     
  11. shoppy macrumors 6502a

    Joined:
    Mar 4, 2007
    Location:
    Hants
    #11
    I had this problem transferring a 53 gb steam folder. So I just moved the files within teh folder one at a time average 5.93-6.8gb files.
     
  12. justindthomas macrumors newbie

    Joined:
    Jan 2, 2009
    #12
    Path Finder

    Give Path Finder a try. I just ran into this problem with Finder and a large HD video file (14GB) and luckily had Path Finder (from CocoaTech) handy. It transferred it with no trouble.

    I'd had enough trouble with Apple's Finder over the years that I'd purchased Path Finder some time back. It's come in handy on numerous occasions.

    Of course, it'd be nice if Apple would just fix their product so that I didn't have to spend the money, but I suppose that's the way it goes. ;)
     
  13. i.shaun macrumors 6502a

    i.shaun

    Joined:
    May 1, 2008
    Location:
    Canada
    #13
    Does the mac move anything (any small file) to the drive?

    It would appear that it is FAT32 based on the description, but if it works on a PC, then it can't be a FAT32 drive. That file system itself limits the size of the files on it.
     
  14. MackOfAllMacs macrumors newbie

    Joined:
    Mar 16, 2009
    #14
    thanks for the info on this one :) I was getting seriously annoyed for a second.
     
  15. markl181 macrumors newbie

    Joined:
    Apr 4, 2009
    #15
    I tried the Pathfinder option, and it just deleted all my files that were over 4GB... permanently. I would stay away from this if possible.
     
  16. prosta112 macrumors newbie

    Joined:
    Apr 15, 2009
    #16
    Disk Utility - erase - Mac OS extended(Journaled)
    This will fix the problem.
     
  17. tritchls macrumors newbie

    Joined:
    May 22, 2009
    #17
    aim

    i know this sounds really dumb but I transferred it via aim to my windows machine and it worked fine:apple:
     
  18. OutSpoken macrumors 6502a

    Joined:
    Jun 9, 2009
    Location:
    UK
    #18
    Is it then easy to reformat back to FAT32? if so how is it done.
     
  19. Jisuo macrumors 6502

    Joined:
    Dec 4, 2008
    Location:
    Sweden
    #19
    Just do the same thing, but choose fat32 instead of Mac OS extended(Journaled).
     
  20. Grunj macrumors newbie

    Joined:
    Sep 15, 2009
    Location:
    Los Angeles
    #20
    Hi, having the same problem but the above doesn't work. Keeps telling me "Volume Erase failed with the error: Could not unmount disk"

    All the content on the disk remains unchanged.

    I've downlaoded and installed the most recent Mac drivers from Western Digital (included on the drive was 2-24, I downloaded 2-25). The disk in question is a brand new Western Digital 2 TB My Book Home Edition. My system is a 2 X 2.66 Ghz Dual Core with 7 Gig RAM running OS 10.6. But not running it very well. Motion, Final Cut, and Compressor crash on me with far more regularity than is acceptable. Considering a system wipe. Yay!

    Any other ideas before I do that?

    EDIT: Oh yeah, and Disk Warrior says : Directory cannot be rebuilt, the file system is unsupported. This disk is not a Macintosh disk. This disk does not appear on the desktop. This disk is 1.82 TB is size.

    Which is interesting because the disk certainly does appear on the desktop and I'm able to transfer small files to it. But for backing up my HD footage shot on a P2 it's completely and totally the most expensive paperweight I've ever bought.
     
  21. Grunj macrumors newbie

    Joined:
    Sep 15, 2009
    Location:
    Los Angeles
    #21
    OK. I just hooked it up to my girlfriend's old G4, copied a file onto it (600 Mb) then copied same file off onto mine. Then ejected it in the finder. On a lark, since Disk Utility said it couldn't erase because it couldn't eject the disk, I went to Utility and set it to Erase (Mac OS Extended Journaled). Lo and behold it seems to have worked. Shrug. Gotta love twitchy Leopard.
     
  22. Willravel macrumors newbie

    Joined:
    Dec 21, 2008
    #22
    Empty the drive otherwise your files will be erased.

    Applications>Utilities>Disk Utility

    Click on the drive on the left, and then click on the "Erase" option. Here you will be asked what format you'd like to use, along with whatever name you choose. Choose Mac OS Extended (Journaled) and then hit "Erase...". This will change the formatting from FAT32 (called "MS-DOS (FAT)" on Mac) to a Mac-friendly format that can take any size file you want. Since I did this with my external 1TB drive, I now have 10GB Garageband files and 15GB 1080p movie files on the drive without breaking a sweat.
     
  23. memo90061 macrumors 6502

    Joined:
    Jan 2, 2008
    Location:
    Los Angeles, CA
  24. 17Patty macrumors newbie

    17Patty

    Joined:
    Dec 22, 2009
    #24
    YES. YES. YES.


    I created an account right now JUST to say ****ing yes. This worked 100%, and I than you :D
     
  25. Hydrostatic macrumors newbie

    Joined:
    Jan 26, 2010
    #25
    Yup, I'll give another kudos to this one. Path Finder 5 is transferring a 6.8GB file from a network drive to my FAT-32 Boot Camp partition no problem. Thanks for the find guys!

    Fully functional for the 30-day demo period too. Sweet.
    http://www.cocoatech.com/

    EDIT

    Nope, nevermind, file never appeared in Windows. Apparently the 4GB limit is a limitation of the FAT32 format itself, and no file in the system can be larger than 4GB if the drive is formatted as such.
     

Share This Page