Become a MacRumors Supporter for $50/year with no ads, ability to filter front page stories, and private forums.

Defie22

macrumors member
Original poster
Oct 3, 2015
31
4
Hello.

I'm uploading files from my Windows 10 PC to my external HDD connected to Mac Mini (model 2012 - OSX 10.13.2).

After the upload (sometimes) I don't have read & write rights on the Mac Mini. So I have to choose the files and set correct rights for my user name (get file info/+ user/ set privilege)

Is there a way how to get the read & write right for all the new files automatically? I don't want to change rights on my PC or Mac Mini after every new upload.

Thank you for your help. I'm really desperate :/

Mac mini, macOS High Sierra (10.13.2)
 

mossy

macrumors regular
Sep 11, 2013
157
47
Ireland
I think if you 'right-click' on the external HDD icon and then go to 'get info' and open it----down at the bottom is 'Sharing & Permissions' --> click on the little pad-lock and enter you password when asked --> and then set the privileges to read and write. There is a 'gear' icon that can toggle down --> you can then set to apply to enclosed items which should do the trick for you.
 

IHelpId10t5

macrumors 6502
Nov 28, 2014
486
348
Try right-clicking the drive on the Mac, choose "Get Info", expand "Sharing & Permissions", and then at the bottom enable the "Ignore ownership on this volume" option.

I'm not sure if that option is available for Fat32 or exFat volumes though. It's definitely the way to go if the HDD was formatted HFS+ for a Mac.
 

Defie22

macrumors member
Original poster
Oct 3, 2015
31
4
I think if you 'right-click' on the external HDD icon and then go to 'get info' and open it----down at the bottom is 'Sharing & Permissions' --> click on the little pad-lock and enter you password when asked --> and then set the privileges to read and write. There is a 'gear' icon that can toggle down --> you can then set to apply to enclosed items which should do the trick for you.

Yes, that works but with every new file I have to do that again. Im looking for permanent solution. But thank you.
[doublepost=1513757758][/doublepost]
Try right-clicking the drive on the Mac, choose "Get Info", expand "Sharing & Permissions", and then at the bottom enable the "Ignore ownership on this volume" option.

I'm not sure if that option is available for Fat32 or exFat volumes though. It's definitely the way to go if the HDD was formatted HFS+ for a Mac.

Thank you. I already tried that, but I didnt check the file system. So if it will not work, I will try to format the hdd to HFS+ (6TB - so 3 days of backuping restoring)
 

BrianBaughn

macrumors G3
Feb 13, 2011
9,700
2,451
Baltimore, Maryland
I'm not sure if the above suggestion will work but hopefully it will.

One thing I thought of was creating a "Folder Action" with Automator on the Mini that runs a script changing the permissions of files added to the folder. Do I know how to construct this? Heck no! Might have been done by someone already, though.
 

mossy

macrumors regular
Sep 11, 2013
157
47
Ireland
I'm not sure if that option is available for Fat32 or exFat volumes though. It's definitely the way to go if the HDD was formatted HFS+ for a Mac.


Yes - this sense. Windows will still write to the drive and no more problems with Mac.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.