How to disable Authentication when moving files/folders on my mac

Discussion in 'Mac Basics and Help' started by bionica8, Jun 21, 2010.

  1. bionica8 macrumors newbie

    Jun 21, 2010

    I am using mac OS X Snow Leopard and having an issue with excessive authentication prompts! Every time I move or copy a file/folder my mac opens the authentication window :eek:

    I am the only user on my computer and do not want to authenticate every single time I move a file! Please help :confused:
  2. calderone macrumors 68040


    Aug 28, 2009
    You are clearly moving files to places that require authentication. Being an admin doesn't mean you get unlimited access to the everything on the machine without question.

    Where are you moving files to and why? If you are moving them to a place that wouldn't normally require authentication, then there may be a permission issue, but I don't think that is the case.
  3. bionica8 thread starter macrumors newbie

    Jun 21, 2010
    After reviewing some previous threads I think I might have a better idea of what my problem is?

    I had a clone HD put onto my new computer and it seems that it has become an authentication nightmare. I'm moving files that shouldn't regularly require authentication.

    For example: download images from email and create a folder on desktop. To move the files/folder I have to copy them elsewhere authenticate. I can't just drag files/folders. Then since I had to make a duplicate folder instead of just moving it I have to delete the original on the desktop and have to authenticate to delete it in the trash.

    The above mentioned thread offers a solution but I don't know how to use terminal? HELP! :(
  4. angelwatt Moderator emeritus


    Aug 16, 2005
    Terminal is not that scary. Open Terminal and type the following

    sudo chown -R [B]YourShortName[/B] .
    Replace YourShortName with your username, which is generally the same as what is written on the home folder in Finder in the sidebar. Usually has a house icon. Then enter a space afterward and a dot. The dot represents the current directory you are in, which will be your home folder.

    After entering the command, it will ask for your password. As you enter it in, there will be no feedback, no asterisks, just keep typing and hit enter when it's in. it'll take a little time to run depending how many files are there.

    If any errors come up, copy and paste them into a post here. the command itself changes the owner of the files (ch=change, own=owner). The -R means it's recursive so everything in your home folder will have its owner property changed to your username.
  5. bionica8 thread starter macrumors newbie

    Jun 21, 2010

    Ok that is what terminal looks like when I open it. Should I enter the code below the existing text? Or should I erase the existing text in the terminal and replace it with the one you mentioned?
  6. angelwatt Moderator emeritus


    Aug 16, 2005
    That's just the prompt. You won't be able to delete it anyways.
  7. LittleRedRiding macrumors newbie

    Feb 8, 2010
    I did this and now I don't permission to do ANYTHING!

    If I even try to save a word document it tells me I don't have permission.

    What the hell do I do?!?!!
  8. Flynnstone macrumors 65816


    Feb 25, 2003
    Cold beer land
    Come on people.

    If someone is not comfortable or used to using the terminal, Don't recommend using commands with "-r". The side effects are way too nasty!

    I consider "rEmOVE -Recursively" the command that should not be discussed. Its almost equivalent to taking a hammer to your hard drive!
  9. angelwatt, Jul 31, 2011
    Last edited: Jul 31, 2011

    angelwatt Moderator emeritus


    Aug 16, 2005
    Run Disk Utility, select your drive, then hit the Repair Permissions button. It might also be helpful to know what folder you're having issues with. Using suggestions that were meant for other people's situation can be problematic if you don't fully understand the steps involved.
  10. krash4882, Oct 28, 2011
    Last edited: Oct 28, 2011

    krash4882 macrumors newbie

    Aug 25, 2009
    Authentication Issue/Terminal Fix

    Like an idiot, I copied/pasted the instructions for the Terminal fix and then entered my password and hit enter without changing the name to my hard drive name. I re-pasted the instructions in and correctly entered my info, put a space in after the period, and entered my password correctly The response I got was "mycomputer:~ myname$ sudo chown -R MYHARDDRIVENAME .
    Password: chown: .: Operation not permitted".

    I ran the repair permissions under the disk utility and this is the response I got:

    "Warning: SUID file "System/Library/CoreS...has been modified and will not be repaired."

    Same goes if I try to run a verify permissions.

    Is my only recourse a system restore?
  11. Jolly Jimmy macrumors 65816

    Jolly Jimmy

    Dec 13, 2007
  12. chown33 macrumors 604

    Aug 9, 2009
    Sailing beyond the sunset
    The other thing you failed to do is read the instructions properly. You aren't supposed to enter a HARD DRIVE NAME. You're supposed to enter a SHORT USER NAME.

    I mention this not so much for your benefit, but for the possible benefit of others who come after you and may think they're supposed to enter a hard drive name.
  13. krash4882 macrumors newbie

    Aug 25, 2009
    I need clarification on "short user name." From the instructions I read, I assumed I had to put in the name that appears under the main file folder at the top right corner of my desktop.


    I can ignore the error, but I'm trying to fix the fact that I can't drag/drop a file from my desktop into my main hard drive file folder. It asks me for authentication (which it's never done before), and when I click "authenticate" the box just disappears (doesn't let me enter my password) and the file remains on the desktop.

    I ran "verify disk" on the disk utility and got this message:

    Invalid directory item count. (it should be 1209 instead of 1210)
    Invalid directory item count (It should be 197 instead of 196)
    The volume was corrupt and needs to be repaired.

    It recommends I put my OS X cd in and start the computer up with it, then use disk utility to repair the disk.

    All of this crap stemming from trying to get a Western Digital My Passport to work properly so I could transfer files from my WD MyBook to the My Passport. Obviously somewhere in there I changed something I shouldn't have.

    Thanks for all your advice.
  14. chown33, Oct 29, 2011
    Last edited: Oct 29, 2011

    chown33 macrumors 604

    Aug 9, 2009
    Sailing beyond the sunset
    Where did you read that?

    The instructions posted with the command-line were:
    Replace YourShortName with your username, which is generally the same as what is written on the home folder in Finder in the sidebar. Usually has a house icon. Then enter a space afterward and a dot. The dot represents the current directory you are in, which will be your home folder. ((Underline added))
    You must also take into account when that was written: 2010. Before Lion. So if you're running Lion, it may look different.

    If you're unsure of what your short username really is, or you think you might accidentally cause more damage, then post the output from this Terminal command line:
    Copy and paste the output into a post, exactly as Terminal shows it.

    Have you done that?

    Your disk has damage that needs to be repaired. If you continue making changes to the disk before doing repairs, the damage may get worse. You could lose data.

    If you expect someone to help with that, you'll first have to explain what you did. You should also explain what the My Passport was doing that was improper, which lead you to do something to make it work properly.

    We can't read your mind. We can't see what you've already done, because we weren't there. We can't see your files or your disks. All we know of your problem is what you tell us.
  15. mariomariado macrumors newbie

    May 5, 2011
    It's simpler than you might think!

    Just go to your "Macintosh HD" icon, hit Command + I (to show info) and down below you can see a "Sharing & Permissions" Tab.

    Click the lock icon on the lower right corner and enter your password to be able to make changes and then hit the "+" icon on the lower left.

    Select your account/username from the list and click "Select". Once included there, change the settings to "Read & Write" for your account (the one you just added).

    The next part is very important. If you skip this step, what you just did would be pretty much useless:
    Click on the settings (gear icon on the lower left corner, close to the "+" sign you just used) and select "Apply to enclosed items…" from the pop-up menu.
    This will apply this changes to all your folders, which are contained in the "Macintosh HD" drive, so when you try to move them or delete them: No authentication required.

    Hope this helps.

  16. SeanChandler macrumors newbie


    Apr 14, 2004
    Calgary, Alberta Canada
    solution worked for me

    I followed the steps as described - took about 3-4 minutes to finish on my 512GB SSD drive - works fine now - Thanks mariomariado :D
  17. de01 macrumors newbie

    Dec 8, 2014
    Mario, you fixed my problem as well

    Thanks. I followed your instructions and it fixed my system as well. I was getting a PW confirmation dialog with every move of a file to another subdirectory or move to the trash.

    I had upgraded to the OS X Yosemite. I had also tried to resize my Windows partition. It didn't go well. I had a backup so wiped the disk and reinstalled my Mac backup, this time with no Win partition. That was fine. I noted that I no longer had a restore partition. I'd read that if the OS was installed from the drive instead of a backup, it would create the partition. I downloaded the OS X Yosemite again and went through the install. It didn't create the restore partition on the disk. Anyway then I found the problem with the permissions and the deleting or movement of files.

    Your instructions worked perfectly. Thanks so much. I don't think I will worry about the restore partition any more.

  18. de01 macrumors newbie

    Dec 8, 2014
    Permissions... Perhaps all is not well

    I no longer have a problem with moving files and moving files and directories to the trash. I did run a program update for an astronomy program called Pix Insight. The update failed with a error. Looking at the log, this line describes the problem:
    *** Error: Cannot chmod target file: /Applications/PixInsight/bin/CosmeticCorrection-pxm.dylib

    So I assume it is a permissions problem. I'm running the disk utility "Repair Disk Permissions". It found thousands of "ACL found but not expected on ... " substitute a path and file name for the "..." in the above. It took a long time to run on the SSD, 20 minutes or so. I wonder if something is hosed.

  19. Colimotl macrumors newbie

    Jan 23, 2015
    Mario, you solved my problem too

    And thanks for the step-by-step instructions!
  20. robertmanningjr macrumors newbie


    Sep 6, 2015

    Thank you. Clear, concise and easy fix.
  21. diversified macrumors newbie

    Aug 29, 2014
    thank you mario!

    macrumoror users- hit the thumbs up on mario's post :)

  22. meikai72 macrumors newbie


    Nov 24, 2015
    Worked like a charm... thanks Mario!!!
  23. SunnyPaul macrumors newbie


    Feb 5, 2016

    Thx for the common sense answer... Not sure why so many others were going all psycho with their answers... :p
  24. Alma Miranda macrumors newbie

    Aug 20, 2016
    --- Post Merged, Aug 20, 2016 ---
    After weeks of trying to find an answer, it was 'the next part is very important' finally did it. I had tried so many things. I never thought to click on the settings gear. You are not only in the know, but you are also a great teacher.
  25. grahamperrin macrumors 601


    Jun 8, 2007
    I could offer a partial explanation, and some additional advice, but 'psycho' is not an incentive o_O

Share This Page