How to disable Private Browsing in Safari!

Psgirl119

macrumors newbie
Aug 17, 2015
1
0
0
For the same reason why anyone would want Private Browsing, namely the convenience.

Im suffering relapses right now so anything I can do to make it take just a bit longer, make it just a bit less convenient, give me just a few more seconds to think about before doing, short of actually impairing my ability to do productive things, is a blessing.

Unfortunately, this is no longer an option. Looks like I'll just need a stronger will...
- I realised you posted this a long time ago, but if you're still fighting this battle, check out "Finally Free" (http://www.wretchedradio.com/store/product_details.cfm?id=494) and "Slaying The Dragon" from Wretched Radio - hope you succeed!
 

reddyrawks

macrumors newbie
Dec 16, 2015
1
0
0
I was looking for a way to disable private browsing in Safari. so i looked and looked and couldn't find one, until i remembered that a lot of Apple apps have the NIB (interface builder) files in the application package. so here's how to disable the "Private Browsing" menu option in safari, effectively disabling private browsing!

(you must have Xcode tools installed... its a free download from apple.com but also included with newer macs. and putting up a modified binary would be futile, because it will be changed every safari/mac os x update, so whenever you update the software, make sure to follow these steps again.)

1. Go to applications folder in Finder
2. right click (with a mighty mouse or 2 button mouse, or Control+click for one button mice) on safari and choose "Show Package Contents"
3. Go to Contents, then Resources, then English.lproj folder (or a respective folder for whatever language you have maybe)
4. Double click on MainMenu.nib to open it in interface builder
5. look at the window with the safari menu, click on Safari to expand it, then click on the Private Browsing menu item.
6. hit the delete key and it disappears!
7. hit command+s to save, close interface builder if you want, and relaunch safari.

and there, no more private browsing option! hope this helps everyone.
I get as far as the English.lprog folder, I click on that and there is no folder that says MainMenu.nib. now what?

Maybe I'm the only one...

Ok, so I'm trying to follow these directions, and here's what I'm getting:

Safari > Contents > Resources > English.lproj > MainMenu.nib (it's a folder) > keyedobjects.nib (un-opening file)

Am I missing something? I'm not even seeing an option for a "mainmenu.nib" file to open. Any insights here?:confused::confused::confused:
I cannot find the mainmen.nib either
 
Last edited by a moderator:

Flatfly

macrumors newbie
May 1, 2016
1
0
0
I believe I pre-modified them, the private browsing option is allready gone.
There's no need to edit them.
You took the mainmenu.nib for your language? Did you replace it in the safari app folder in the correct language folder?
It should work.
Hi schwarzmuller, I would love to have a copy.. where do i download it from.or do you send it.. If this works...then you are a genius!!
 

His4ever

macrumors newbie
Jul 15, 2016
3
0
0
schwarzmuller- By any chance do you still have the pre modified file? Does it work with the iOS X El Capitan 10.11 and Sarari 9.1
[doublepost=1468611141][/doublepost]
I get as far as the English.lprog folder, I click on that and there is no folder that says MainMenu.nib. now what?


I cannot find the mainmen.nib either
I'm also experiencing the same difficulty. I'm guessing it's due to one of their recent updates. Does anyone have any helpful information?
 

andy.ender

macrumors newbie
Sep 10, 2016
1
0
0
schwarzmuller- By any chance do you still have the pre modified file? Does it work with the iOS X El Capitan 10.11 and Sarari 9.1
[doublepost=1468611141][/doublepost]

I'm also experiencing the same difficulty. I'm guessing it's due to one of their recent updates. Does anyone have any helpful information?
The file has moved to /Applications/Safari.app/Resources/Base.lproj/MainMenu.nib.

To be able to edit the MainMenu.nib file, we need to "decompile" it using e.g. this progam called NibDecompiler. Download and copy the NibDecompiler.workflow file to ~/Library/Services. Now there'll be a NibCompiler context menu entry on files which we can use to make the .nibfiles editable.


I had to copy the MainMenu.nib file to my desktop, then run "NibDecompiler" on it. I could then edit it using Xcode. Finally, I had to copy the edited file back to its original location: /Applications/Safari.app/Resources/Base.lproj/MainMenu.nib.
 

retlaw7

macrumors newbie
Sep 20, 2016
1
0
0
The file has moved to /Applications/Safari.app/Resources/Base.lproj/MainMenu.nib.

To be able to edit the MainMenu.nib file, we need to "decompile" it using e.g. this progam called NibDecompiler. Download and copy the NibDecompiler.workflow file to ~/Library/Services. Now there'll be a NibCompiler context menu entry on files which we can use to make the .nibfiles editable.


I had to copy the MainMenu.nib file to my desktop, then run "NibDecompiler" on it. I could then edit it using Xcode. Finally, I had to copy the edited file back to its original location: /Applications/Safari.app/Resources/Base.lproj/MainMenu.nib.
[doublepost=1474399742][/doublepost]Hi Andy, when I moved MainMenu.nib to my desktop and right-clicked and tried to run NibDecompiler on it I get an error saying

"Automator could not run the workflow because one or more actions were not loaded."

Any tips?
 

Attachments

Last edited:

Thunderforge

macrumors newbie
Dec 12, 2009
15
0
0
Hi Andy, when I moved MainMenu.nib to my desktop and right-clicked and tried to run NibDecompiler on it I get an error saying

"Automator could not run the workflow because one or more actions were not loaded."

Any tips?
I believe that this is because the first step was completed (Copy the NibDecompiler.workflow into the Libraries/Services folder), but the second step was skipped:

Compile NibDecompiler.xcodeproj and copy NibDecompiler.action into the Libraries/Automator folder

Basically, you need to run Xcode to compile the project, which produces NibDecompiler.action. Then you copy that file into Libraries/Automator. After that, the context menu item should work.

It's a pity that they didn't just check in the NibDecompiler.action so that people don't need to install Xcode, given that the project changes so infrequently. I created an issue for it.
 

foxster4

macrumors newbie
Jan 4, 2017
1
0
0
The file has moved to /Applications/Safari.app/Resources/Base.lproj/MainMenu.nib.

To be able to edit the MainMenu.nib file, we need to "decompile" it using e.g. this progam called NibDecompiler. Download and copy the NibDecompiler.workflow file to ~/Library/Services. Now there'll be a NibCompiler context menu entry on files which we can use to make the .nibfiles editable.


I had to copy the MainMenu.nib file to my desktop, then run "NibDecompiler" on it. I could then edit it using Xcode. Finally, I had to copy the edited file back to its original location: /Applications/Safari.app/Resources/Base.lproj/MainMenu.nib.
[doublepost=1483558171][/doublepost]I'm new at this and having a bit of trouble so any help would be awesome!

I've downloaded both Xcode and NibDecomplier but I am unable to copy it to the Library/Services....what is that exactly because it seems since I am unable to complete this step, I cannot move forward.

Thanks!!!
 

schwarzmuller

macrumors newbie
Jan 11, 2011
14
0
0
Hi all

I updated the files for English language only. Works with MacOs 10.12 and safari 10.1
You find them attached to this post.
Unzip folder and follow instructions:

MainMenu1.nib has only the private mode disabled, MainMenu2.nib disables the use of private mode and clear history.
Select the option you want to use and rename it to MainMenu.nib
You can not simply put these modified files in the corresponding folder due to limited permissions.
First you restart your mac whilst pressing the following two key combination cmd + r
Your mac will start in system restore.
Just press in the menu bar 'utilities' and click on 'terminal'.
Here you will type 'csrutil disable' without quotes.
Press enter and restart your mac.
Now you can change the appropriate files, make sure safari is not running.
Open the application folder and right click on safari.
Choose "show package contents".
go to Contents/Resources/Base lproj
Rename the MainMenu.nib to eg MainMenuOriginal, like this you keep an original copy in case you want to clear history for example.
Copy one of the two supplied edited MainMenu.nib's into this folder. Make sure you removed the 1 or 2 in the filename of the edited files.
Open safari and you should see the effects.
Do not forget to redo the permissions. This time you type ‘csrutil enable’

Screen Shot 2017-05-28 at 16.58.31.png
 

Attachments

oZZar

macrumors newbie
Jul 13, 2017
1
0
0
Hi all

I updated the files for English language only. Works with MacOs 10.12 and safari 10.1
You find them attached to this post.
Unzip folder and follow instructions:

MainMenu1.nib has only the private mode disabled, MainMenu2.nib disables the use of private mode and clear history.
Select the option you want to use and rename it to MainMenu.nib
You can not simply put these modified files in the corresponding folder due to limited permissions.
First you restart your mac whilst pressing the following two key combination cmd + r
Your mac will start in system restore.
Just press in the menu bar 'utilities' and click on 'terminal'.
Here you will type 'csrutil disable' without quotes.
Press enter and restart your mac.
Now you can change the appropriate files, make sure safari is not running.
Open the application folder and right click on safari.
Choose "show package contents".
go to Contents/Resources/Base lproj
Rename the MainMenu.nib to eg MainMenuOriginal, like this you keep an original copy in case you want to clear history for example.
Copy one of the two supplied edited MainMenu.nib's into this folder. Make sure you removed the 1 or 2 in the filename of the edited files.
Open safari and you should see the effects.
Do not forget to redo the permissions. This time you type ‘csrutil enable’

View attachment 701321
Hey all. I registered only to say thanks to you schwarzmuller. THANK YOU! Didn't get the xcode-thing working so it did it great. However, you might want to look in to the MainMenu2, which at this point doesn't disable clear history menu.

Anyways, it did disable private browsing. Thanks alot!
 

schwarzmuller

macrumors newbie
Jan 11, 2011
14
0
0
Hey all. I registered only to say thanks to you schwarzmuller. THANK YOU! Didn't get the xcode-thing working so it did it great. However, you might want to look in to the MainMenu2, which at this point doesn't disable clear history menu.

Anyways, it did disable private browsing. Thanks alot!
Pleasure to help. Im not a fan of disabling history clearance.
If a website is malfunctioning, clearing the history might be a solution. Without the option available you are stuck.
Use at your will, version with history clearance attached.
 

Attachments

chrfr

macrumors G3
Jul 11, 2009
8,072
2,456
0
If a website is malfunctioning, clearing the history might be a solution. Without the option available you are stuck.
Browser history is just a list of previously visited sites. Clearing the browser's history doesn't change its function if you reload the site. Perhaps you're thinking of browser cache and/or cookies. Those are independent of history.
 

Lel1375

macrumors newbie
Mar 23, 2018
1
0
0
Pleasure to help. Im not a fan of disabling history clearance.
If a website is malfunctioning, clearing the history might be a solution. Without the option available you are stuck.
Use at your will, version with history clearance attached.
I’ve successfully deleted the option from the top menu, but is there any way to delete it as an option when you click and hold the safari icon in the dock on the bottom of the screen?
 

schwarzmuller

macrumors newbie
Jan 11, 2011
14
0
0
I’ve successfully deleted the option from the top menu, but is there any way to delete it as an option when you click and hold the safari icon in the dock on the bottom of the screen?
Lol, thats a good one, I never noticed that option there. Wondering since when it is sitting there.
I'll see what I can do.
 

hansensm

macrumors newbie
Aug 10, 2018
1
0
0
Hey all. I registered only to say thanks to you schwarzmuller. THANK YOU! Didn't get the xcode-thing working so it did it great. However, you might want to look in to the MainMenu2, which at this point doesn't disable clear history menu.

Anyways, it did disable private browsing. Thanks alot!
I am not sure what I am doing wrong. I right click on safari in application and choose "show package contents." from there I choose Contents>Resources> but there is no "English.lproj" folder. There is an "el.lproj" folder. In the "el.lproj" folder there is no item titled "MainMenu.nib" but rather "MainMenu.strings". When I open MainMenu.strings in Xcode, it opens a window of codes that I don't understand. What am I doing wrong?
 

schwarzmuller

macrumors newbie
Jan 11, 2011
14
0
0
I am not sure what I am doing wrong. I right click on safari in application and choose "show package contents." from there I choose Contents>Resources> but there is no "English.lproj" folder. There is an "el.lproj" folder. In the "el.lproj" folder there is no item titled "MainMenu.nib" but rather "MainMenu.strings". When I open MainMenu.strings in Xcode, it opens a window of codes that I don't understand. What am I doing wrong?
Follow steps in post 59. Anyways, private browsing is still available when you right click the safari icon in the dock, so its pretty useless to do so.
use opendns to filter webcontent instead.